Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ipw3945 wireless drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 30, 31, 32  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Wed Mar 08, 2006 1:08 pm    Post subject: Reply with quote

rmh3093: that inut script works like a charm, thank you.

I added
Code:
before net

because it was trying to start after my net.eth1.

This script should go in the ebuild.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Wed Mar 08, 2006 5:47 pm    Post subject: Reply with quote

Ok people here are some new ebuilds for people to play with.... Thanks again VinzC for starting this project.

New
  • svn to make updates easier
  • requires in-kernel IEEE80211 subsystem
  • corrected paths so downloads dont fail
  • ditched the license
  • ipw3945d includes rc-script
  • useflags for QoS and RFmon


Setup
Code:
echo 'PORTDIR_OVERLAY="/usr/local/ipw3945_ebuilds $PORTDIR_OVERLAY"' >> /etc/make.conf
cd /usr/local
svn co http://opensvn.csie.org/rmh3093/ipw3945_ebuilds


Install
Code:
USE="monitor qos" emerge ipw3945



Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-wireless/ipw3945d-0.7.16-r1 0 kB [1]
[ebuild N ] net-wireless/ipw3945-firmware-1.13-r1 0 kB [1]
[ebuild N ] net-wireless/ipw3945-0.0.70-r1 USE="monitor qos" 0 kB [1]

Total size of downloads: 0 kB
Portage overlays:
[1] /usr/local/ipw3945_ebuilds


Post-Install
Code:
rc-update add ipw3945d boot


Kismet
Kismet dosen't support the ipw3945 yet but it does support the ipw2200 which uses radiotap, the same headers the ipw3945 for monitor mode so kistmet can be setup like this
Quote:
source=ipw2200,eth1,ipw3945

_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.


Last edited by rmh3093 on Sat Mar 11, 2006 1:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Sat Mar 11, 2006 6:51 am    Post subject: Reply with quote

Quote:
Code:
echo 'PORTDIR_OVERLAY="/usr/local/ipw3945_ebuilds $PORTDIR_OVERLAY"' > /etc/make.conf


That wants to be a >> .

*sob* why didn't I see that, why didn't I back up my make.conf!

That'll teach me for copying and pasting!

[EDIT] Thank god I made this post http://forums.gentoo.org/viewtopic-t-438454-highlight-.html all my make.conf in there! Phew!
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Sat Mar 11, 2006 1:37 pm    Post subject: Reply with quote

djtreble wrote:
Quote:
Code:
echo 'PORTDIR_OVERLAY="/usr/local/ipw3945_ebuilds $PORTDIR_OVERLAY"' > /etc/make.conf


That wants to be a >> .

*sob* why didn't I see that, why didn't I back up my make.conf!

That'll teach me for copying and pasting!

[EDIT] Thank god I made this post http://forums.gentoo.org/viewtopic-t-438454-highlight-.html all my make.conf in there! Phew!



OMG dude im sooooooo sorrry about that!! My fault, that should be...... thats what happens when I stay up all night playing with Gentoo.
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Sun Mar 12, 2006 8:18 pm    Post subject: Reply with quote

I keep on getting this error:

Code:
 * Preparing ipw3945 module
mkdir -p /var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/tmp/.tmp_versions
cp /lib/modules/2.6.15-gentoo-r1jentoo/net/ieee80211/.tmp_versions/*.mod /var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/tmp/.tmp_versions
cp: Call by stat for ,,/lib/modules/2.6.15-gentoo-r1jentoo/net/ieee80211/.tmp_versions/*.mod" not possible: file or directory not found
make: [modules] error 1 (ignored)
make -C /lib/modules/2.6.15-gentoo-r1jentoo/build M=/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70 MODVERDIR=/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/tmp/.tmp_versions modules
make[1]: Entering directory `/usr/src/linux-2.6.15-gentoo-r1'
  CC [M]  /var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.o
In file included from /var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:68:
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.h:1991: error: field »action« has incomplete type
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_add_power_capability':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:3192: warning: implicit declaration of function »ieee80211_get_channel«
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:3192: warning: initialisation creates pointer of integer without type conversion
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_add_supported_channels':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:3222: warning: implicit declaration of function »ieee80211_get_channel_flags«
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_best_network':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:7090: error: »NETWORK_HAS_IBSS_DFS« not declared (first use in this function)
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:7090: error: (each undeclared variable is only listed once
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:7090: error: for each function it exists in)
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:7099: error: »NETWORK_HAS_POWER_CONSTRAINT« not declared (first use in this function)
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:7108: error: »NETWORK_HAS_TPC_REPORT« not declared (first use in this function)
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_handle_reply_rx':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:9820: error:  unknown field »tsf« listed in initialisation
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:9821: error:  unknown fiel »beacon_time« listed in initialisation
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:9821: warning: element-error in struct initialisation
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:9821: warning: (next to initialisation of »stats«)
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_build_tx_cmd_hwcrypto':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:13227: error: too many arguments for function
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c: In function `ipw_pci_probe':
/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.c:14734: warning: incompatible pointer type
make[2]: *** [/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70/ipw3945.o] error 1
make[1]: *** [_module_/var/tmp/portage/ipw3945-0.0.70-r1/work/ipw3945-0.0.70] error 2
make[1]: Leaving directory `/usr/src/linux-2.6.15-gentoo-r1'
make: *** [modules] error 2

!!! ERROR: net-wireless/ipw3945-0.0.70-r1 failed.
Call stack:
  ebuild.sh, line 1933:   Called dyn_compile
  ebuild.sh, line 971:   Called src_compile
  ipw3945-0.0.70-r1.ebuild, line 55:   Called linux-mod_src_compile



The actual error messages were German, I translated them. Thus, they might be pretty akward to you, but they should convey the point...

(Kernel) module ieee80211 is installed, I did an svn up before compiling, I don't know what's wrong. But as nobody else seems to have this problem I'm guessing it's got something to do with a missing ibrary or so? Might be completely wrong, though :D
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Sun Mar 12, 2006 9:28 pm    Post subject: Reply with quote

@Jobbe:

Make sure you disabled built-in support for IEEE80211 in your kernel and have run
Code:
/bin/sh /usr/portage/net-wireless/ieee80211/files/remove-old /usr/src/linux

You also must install ieee80211-1.1.11 or later.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Sun Mar 12, 2006 9:39 pm    Post subject: Reply with quote

Oh I thought I had to build it into the kernel because of

rmh3093 wrote:

[*]requires in-kernel IEEE80211 subsystem



I'll try disabling it.


EDIT: definately doesn't work:

Code:
 * Checking for suitable kernel configuration options:
 *   ipw3945-0.0.70 requires IEEE80211 support (CONFIG_IEEE80211).



plus loads of errors, mostly related to undeklared symbols (IEEE80211of course) etc...

Any ideas? Should I try compiling a more recent kernel? Mine is based on 2006.0 gentoo-sources, so 2.6 something..


EDIT: Uh, I just took a look at the project homepage on sourceforge and apparently you need 2.6.13 but I had 2.6.12.

:roll:

I'll emerge a newer version and try this later on....
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Mon Mar 13, 2006 9:47 pm    Post subject: Reply with quote

Jobbe wrote:
EDIT: Uh, I just took a look at the project homepage on sourceforge and apparently you need 2.6.13 but I had 2.6.12.

Ah, sure... You should use the same (or later) package versions as we did. So if something goes wrong you know the packages you selected are not the source of the problem. Otherwise the conditions in which you are making your tests are different from the ones we met.

First get a recent kernel and even a masked (~x86). You can chose a masked Gentoo Source tree like I did (2.6.15-r5 or -r7 now).

Next there are two distinct ways to have ipw3945 working: either built-in using rmh3093's patch or using external ebuilds - which my howto is for. rmh3093's patch requires you to use built-in ieee80211 headers (hence you should use the most recent kernel, should it be unmasked).

With my set of ebuilds the kernel built-in headers for ieee80211 must be removed and replaced by the official ebuilds. Otherwise you will probably get errors about missing #defines or so. If you want to keep your 2.6.12 kernel, then you should consider the ebuild patchset instead.

Whether you chose the former or the latter way you must carefully meet the prerequisites we have posted.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Serph
n00b
n00b


Joined: 04 Aug 2005
Posts: 24

PostPosted: Tue Mar 14, 2006 7:30 am    Post subject: Reply with quote

Hi, I originally removed IEEE80211 from the kernel. How can I add it back in? I'd really like to try rmh3093's ebuilds.

Thanks!
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Tue Mar 14, 2006 8:36 am    Post subject: Reply with quote

It's in 'networking'.

VinzC thanks for your reply. I'll tell y'all later how I'm doing ^^
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Tue Mar 14, 2006 10:52 am    Post subject: Reply with quote

Allright, this is for rmh3093's ebuilds:

I can't get them to compile. I upgraded to the most recent gentoo-sources in portage I could find (2.6.15-r7), ieee80211 support is enabled (tried both in-kernel and as a module), still, ipw3945 will not compile, failing with the error messages I posted above.

I guess I'll try VinzC's aproach now...


EDIT:

Weehaa, it worked. Thanks for the work & help :]
Back to top
View user's profile Send private message
djtreble
n00b
n00b


Joined: 09 Jan 2006
Posts: 39
Location: Brisbane, Australia

PostPosted: Tue Mar 14, 2006 1:38 pm    Post subject: Reply with quote

Just to add my 2c.

I couldn't get rmh3093's ebuild to work with my built in kernel headers even though vanilla linux-2.6.16-rc6 has version 1.1.17 of ieee80211 I _think_

The first error was an undeclared ieee80211_action structure, if I remember correctly.

I convinced myself that in kernel 1.1.17 wasn't new enough and went back to VinzC .70 ebuild with rmh3093's init script. This is working fine.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Mar 14, 2006 3:36 pm    Post subject: Reply with quote

i think the error i was getting with IEEE80211 in portage had to do with -mm sources so in the next revision of the ebuild I will check your kernel version.... if you are using -mm sources it will use the inkernel ieee80211 if not it will ask for the version in portage... i bet this would fix your problems...... sorry guys for causing some problems, i cant use a non -mm kernel with out my system crashing
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Tue Mar 14, 2006 6:27 pm    Post subject: Reply with quote

No need to be sorry at all :)
I'd be happy to test your ebuild once it's updated.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Tue Mar 14, 2006 6:54 pm    Post subject: Reply with quote

Serph wrote:
Hi, I originally removed IEEE80211 from the kernel. How can I add it back in?

For now the only way I know is re-emerge your kernel sources.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Thu Mar 16, 2006 9:49 am    Post subject: Reply with quote

After a bit of using the driver I'm really happy. It works, although almost every other time I have to do the modprobe/dhcp calls by hand. I have no idea why, possibly the driver is just a little immature. But even if I have to do this, it still works like a charm afterwards. Thanks for the help&work guys!
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Thu Mar 16, 2006 6:37 pm    Post subject: Reply with quote

Hmmm... strange. It doesn't happen on my system and I must admit I never had to restart the network connection in a week of daily usage.

Have you run the regulatory daemon? Have you also tuned the module configuration file to run the daemon as soon as the module is loaded?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Fri Mar 17, 2006 11:51 am    Post subject: Reply with quote

Yeah that's what I did. It _is_strange especially considering that if I do the worx by hand there never is a problem. I have to unload the daemon (it's obviously started yet the module can't be loaded - weird) and then modprobe ipw3945 again.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Fri Mar 17, 2006 1:04 pm    Post subject: Reply with quote

Jobbe wrote:
Yeah that's what I did. It _is_strange especially considering that if I do the worx by hand there never is a problem. I have to unload the daemon (it's obviously started yet the module can't be loaded - weird) and then modprobe ipw3945 again.

Aha... so I think it is a configuration issue. If you can run the whole process manually and the driver works properly until the machine is powered off then what you experience is likely to be a configuration issue. First thing to check is baselayout version and wireless-tools package version that you have.

However I'm not sure I understand: it seems the deamon is active before the module is loaded, is that right? In that case I suspect you have an init script that launches the deamon before the network is active. On my machine there are enough services that start between pci coldplug and net.eth1 (apache, mysql plus other stuff that take time) hence the driver module can initialize quietly. It might be different on your machine.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Fri Mar 17, 2006 3:31 pm    Post subject: Reply with quote

Uh no I do the following:
modules.autoload.conf: ipw3945
...
...
...
runlevel default: net.eth1

The daemon is loaded by the module, I set it up the way you showed on the first page of this thread.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Mon Mar 20, 2006 10:34 pm    Post subject: Reply with quote

Then I'm afraid I have no idea :(.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Jobbe
n00b
n00b


Joined: 24 Feb 2006
Posts: 29
Location: Darmstadt (Germany)

PostPosted: Tue Mar 21, 2006 12:03 pm    Post subject: Reply with quote

Yeah well it's not too annoying...
Kinda weird though, I noticed that sometimes not even eth0 (e1000 intel adapter) is found and sometimes the system seems to confuse the both of them...

I don't know what's wrong, but it does work most of the time, so, I don't really care ;)
Back to top
View user's profile Send private message
Sejam
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 80

PostPosted: Thu Mar 23, 2006 5:17 pm    Post subject: Reply with quote

VinzC wrote:

Next there are two distinct ways to have ipw3945 working: either built-in using rmh3093's patch or using external ebuilds - which my howto is for. rmh3093's patch requires you to use built-in ieee80211 headers (hence you should use the most recent kernel, should it be unmasked).


How's it going VinzC, looks like we'll be working together again, my E1705 just showed up.

Anyways, trying to follow the pure ebuild path, I could never get the ipw3945 to compile correctly. This was attempted with many different configurations with kernels 2.6.15-gentoo-r1 and 2.6.16-gentoo. Both of them I also tried with built in ieee80211 built in / modules and also trying with the ~x86 version of ieee80211. Each time I tried again I rebuild the sources. During the ebuild of ieee80211, I would remove the headers with the command above.

In the end, I ended up using the kernel patch on the 2.6.16-rc6-mm2 kernel. I built the ipw3945 as modules and the ieee80211 into the kernel. Just a note that I had the ieee80211 not emerged (I unmerged ieee80211 before emerging mm-sources). Once that was done, I then used the ipw3945_ebuilds specified above. Difference is, I only emerged ipw3945-firmware and ipw3945d (since the driver was built through the kernel patch, I did not need the ipw3945 ebuild).

With that configuration, I was able to get everything working great. I haven't had it working long enough to test to make sure that the connection remains stable. My Wireless LED does not stay on, but flashes with wireless activity (which I personally like a lot better anyways).

On a side note, the 2.6.16-rc6-mm2 does have some nice features added to it already, like the sd reader and a cpu scheduler just for multi-core systems.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Mar 23, 2006 10:56 pm    Post subject: Reply with quote

Sejam wrote:
VinzC wrote:

Next there are two distinct ways to have ipw3945 working: either built-in using rmh3093's patch or using external ebuilds - which my howto is for. rmh3093's patch requires you to use built-in ieee80211 headers (hence you should use the most recent kernel, should it be unmasked).


How's it going VinzC, looks like we'll be working together again, my E1705 just showed up.

Anyways, trying to follow the pure ebuild path, I could never get the ipw3945 to compile correctly. This was attempted with many different configurations with kernels 2.6.15-gentoo-r1 and 2.6.16-gentoo. Both of them I also tried with built in ieee80211 built in / modules and also trying with the ~x86 version of ieee80211. Each time I tried again I rebuild the sources. During the ebuild of ieee80211, I would remove the headers with the command above.

In the end, I ended up using the kernel patch on the 2.6.16-rc6-mm2 kernel. I built the ipw3945 as modules and the ieee80211 into the kernel. Just a note that I had the ieee80211 not emerged (I unmerged ieee80211 before emerging mm-sources). Once that was done, I then used the ipw3945_ebuilds specified above. Difference is, I only emerged ipw3945-firmware and ipw3945d (since the driver was built through the kernel patch, I did not need the ipw3945 ebuild).

With that configuration, I was able to get everything working great. I haven't had it working long enough to test to make sure that the connection remains stable. My Wireless LED does not stay on, but flashes with wireless activity (which I personally like a lot better anyways).

On a side note, the 2.6.16-rc6-mm2 does have some nice features added to it already, like the sd reader and a cpu scheduler just for multi-core systems.



yay, someone else who will be using -mm sources with me
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Sejam
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 80

PostPosted: Fri Mar 24, 2006 2:31 pm    Post subject: Reply with quote

For those of you that previously owned the Inspiron 6000 which had the Intel 2200, have you noticed a decrease in range with the 3945? Didn't realize it last night, but I'm not able to get as good as a signal as I did with the 2200 in my house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2, 3, ... 30, 31, 32  Next
Page 2 of 32

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum