Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dropped frames during firewire capture
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
buccia
n00b
n00b


Joined: 26 Aug 2006
Posts: 40

PostPosted: Tue Nov 21, 2006 2:09 am    Post subject: Dropped frames during firewire capture Reply with quote

Hi,

I'm having problems capturing video from my digital camcorder, via firewire. I tried with both Kino and dvgrab. It drops many frames at regular intervals (every 128 frames, I think). If I select autosplit, it creates a new file every 128 captured frames, with many missing frames between successive files.

dvgrab produces errors such as:
Code:
"dvgrab-001.avi": frame dropped: timecode 00:02:35.06 date 2006.01.15 20:05:51
This error means that the ieee1394 driver received an incomplete frame.


I'm guessing that this is a problem with the 1394 interface and not kino/dvgrab. I've captured successfully in the past, but last time was many months ago and I've upgraded a lot of things since.

My setup:

Distro: Gentoo
Kernel: 2.6.17-gentoo-r7
Kino: 0.9.2
Dvgrab: 1.8

"lsmod | grep 1394" produces:
Code:
dv1394 18140 0
raw1394 25532 2
ohci1394 32112 1 dv1394
ieee1394 87576 3 dv1394,raw1394,ohci1394


Grateful for any pointers. Thanks,
Buccia
Back to top
View user's profile Send private message
DocReedSolomon
Guru
Guru


Joined: 28 Aug 2006
Posts: 419

PostPosted: Tue Nov 21, 2006 4:35 am    Post subject: Reply with quote

could it be that DMA got disabled on your HDD?

what gives "hdparm -I /dev/hdx" (hdx = your hdd)
Back to top
View user's profile Send private message
buccia
n00b
n00b


Joined: 26 Aug 2006
Posts: 40

PostPosted: Tue Nov 21, 2006 10:18 pm    Post subject: Reply with quote

What a star!

It was the DMA. I enabled the sis5513 module in the kernel (appropriate for my mobo which was one of my recent upgrades) and now DMA is on by default. It now captures without a problem (and with the hdd showing much less activity). I'll have a good look at the hdparm howto to see what else I can learn.

Perhaps this also explains 1 or 2 other symptoms (system unresponsive when I transfer large files across home network, and cd/dvd burning a bit tempremental).

Thanks.
Back to top
View user's profile Send private message
DocReedSolomon
Guru
Guru


Joined: 28 Aug 2006
Posts: 419

PostPosted: Tue Nov 21, 2006 10:32 pm    Post subject: Reply with quote

:P
well, you are welcome!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum