Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenOffice + skandinaviska tecken i filnamn = skit [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
IsmoHaa
n00b
n00b


Joined: 25 Jun 2005
Posts: 56

PostPosted: Mon Feb 06, 2006 8:40 am    Post subject: OpenOffice + skandinaviska tecken i filnamn = skit [SOLVED] Reply with quote

Mitt problem är följande: OpenOffice jävlas då jag försöker öppna en fil vars namn innehåller skandinaviska tecken. Om jag försöker öppna filen "Test_åäö.txt" så slänger den ett felmeddelande "Filen Test_%E5%E4%F6.txt existerar inte". Det fåniga är att om jag från ett konsolfönster skriver in "oowriter2 Test_åäö.txt" så öppnar den filen utan att mucka, detsamma gäller om jag klickar på filen i Konqueror. Försöker jag däremot öppna den genom OpenOffices "Öpnna"-funktion blankvägrar den. Också om jag försöker spara en fil med ett namn som innehåller skandinaviska tecken ersätts dessa tecken med dynga. Alla andra program fungerar smärtfritt. Det är bara OO.o som trilskas. :evil:

Jag använder alltså:
-Gentoo 2005.1
-KDE 3.5
-OpenOffice.org 2.0.1 kompilerad med följande useflags: -binfilter +curl +eds -gnome +gtk +java +kde -ldap -mozilla +xml2

I min .bashrc fil körs (bl.a.)
export LC_ALL=sv_FI

/etc/locales.build:

en_US/ISO-8859-1
en_US.UTF-8/UTF-8
sv_FI/ISO-8859-1
sv_FI@euro/ISO-8859-15
sv_FI.UTF-8/UTF-8

/etc/conf.d/keymaps:

KEYMAP="fi-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS=""

Några förslag?


Last edited by IsmoHaa on Tue Feb 07, 2006 5:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 372
Location: Svedala

PostPosted: Tue Feb 07, 2006 11:39 am    Post subject: Reply with quote

Det framgick inte, men kan du spara filer i OO.o med åäö i namnet?
Har du kompillerat tidigare versioner av OO.o förut med bättre resultat? (ebuild fel?)
Har du gjort en felanmälan/sökt på bugzilla.gentoo.org?
Lite tips :)
_________________
update world set ignorance=off where religion=on
Back to top
View user's profile Send private message
IsmoHaa
n00b
n00b


Joined: 25 Jun 2005
Posts: 56

PostPosted: Tue Feb 07, 2006 12:20 pm    Post subject: Reply with quote

Quote:
Det framgick inte, men kan du spara filer i OO.o med åäö i namnet?

Bra poäng... Om jag sparar en fil med namnet "Test_åäö.txt" resulterar det i en fil med namnet "Test_%E5%E4%F6.txt". Jag provade på skoj också att konvertera filnamnet till UTF-8 med programmet "convmv". Detta gav upphov till en fil med namnet "Test_åÀö.txt". Då jag försökte öppna den med OO.o så spottade den felmeddelandet "Test_åäö.txt finns inte". :roll: (OO.o verkar alltså använda något slags inkompatibel character-encoding, men jag har inte kommit på hur man skulle kunna få den att sluta upp med det.)

Quote:
Har du kompillerat tidigare versioner av OO.o förut med bättre resultat? (ebuild fel?)

Jo. 1.1.x varianterna hade jag inga problem med... Dessutom när jag googlade efter problemet stötte jag på några Ubuntu-användare med samma problem, vilket tyder på att det inte är kompileringen som är problemet.

Quote:
Har du gjort en felanmälan/sökt på bugzilla.gentoo.org?

Jag gjorde en anmälan till OO.o:s egen "bugzilla". Med tanke på att alla andra program funkar som de skall, så börjar jag misstänka att det är ett OpenOffice-problem, och inte ett Gentoo-problem.
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 372
Location: Svedala

PostPosted: Tue Feb 07, 2006 2:49 pm    Post subject: Reply with quote

Quote:

Quote:
Har du kompillerat tidigare versioner av OO.o förut med bättre resultat? (ebuild fel?)

Jo. 1.1.x varianterna hade jag inga problem med... Dessutom när jag googlade efter problemet stötte jag på några Ubuntu-användare med samma problem, vilket tyder på att det inte är kompileringen som är problemet.

Jag skummade faktiskt runt i dessa bugzilla rubriker och fann andra hade problem med spara-dialogen (ala gnome/gtk+) vilket skulle ha att göra med 'locales'. Sparning ledde till krash av programmet. Vad jag vet är ubuntu ganska gnome-centrerat också...kan bara vara fel antagande från min sida, men visst luktar det skumt? 8O
Quote:

Quote:
Har du gjort en felanmälan/sökt på bugzilla.gentoo.org?

Jag gjorde en anmälan till OO.o:s egen "bugzilla". Med tanke på att alla andra program funkar som de skall, så börjar jag misstänka att det är ett OpenOffice-problem, och inte ett Gentoo-problem.



*förvånad* Inte alla som gör. Klart godkänt.

Annars så sades det att openoffice-bin paketet inte hade dessa problem (med fil-dialogen). Kan vara en grej kanske att felsöka med. Detta skulle då kunna tyda på att problemet _kan_ vara någonting med dina systempaket? Vettigt är isåfall att bevara din färdigkompillerade openoffice någonstans. ;)
Back to top
View user's profile Send private message
IsmoHaa
n00b
n00b


Joined: 25 Jun 2005
Posts: 56

PostPosted: Tue Feb 07, 2006 5:04 pm    Post subject: Reply with quote

Quote:
Jag skummade faktiskt runt i dessa bugzilla rubriker och fann andra hade problem med spara-dialogen (ala gnome/gtk+) vilket skulle ha att göra med 'locales'. Sparning ledde till krash av programmet. Vad jag vet är ubuntu ganska gnome-centrerat också...kan bara vara fel antagande från min sida, men visst luktar det skumt? 8O
Annars så sades det att openoffice-bin paketet inte hade dessa problem (med fil-dialogen). Kan vara en grej kanske att felsöka med. Detta skulle då kunna tyda på att problemet _kan_ vara någonting med dina systempaket? Vettigt är isåfall att bevara din färdigkompillerade openoffice någonstans. ;)

Låter intressant. Jag skall snoka lite mer, och se om det finns någon lösning (eller bättre workaround) på problemet. Jag testade -bin paketet på min andra installation (Jag har en 10GB partition där jag leker med en 64-bits version.) och åtminstone där verkade den fungera smärtfritt. Go figure... Om jag inte kommer på något bättre, så blir det väl -bin-varianten då.

EDIT: Hahaa. Tack för tipset. Då jag letade igenom bugzilla hittade jag denna pärla:

"Hmmm, looks like a bug in the gnome file selector, never experienced that myself, though. Just to make sure, could you de-activate the GNOME file selector (in Tools > Options > OpenOffice.org > General activate "Use OpenOffice.org dialogs" and try again?"

Det hjälpte. :D
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 372
Location: Svedala

PostPosted: Tue Feb 07, 2006 6:27 pm    Post subject: Reply with quote

Då läste vi samma bugzilla logg. :)
Kul att det löste sig.
_________________
update world set ignorance=off where religion=on
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum