Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Poll dissappeared after editing topic post
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Sat Mar 22, 2003 6:49 pm    Post subject: Poll dissappeared after editing topic post Reply with quote

I started a new topic with a poll and noticed I needed to edit the topic post. After I edited the post the poll was gone. I ended up deleting the post and starting a new one.

[EDIT]
I should note that the poll had at least 1 vote when I edited the post. I read the FAQ and I didnt see anything pertaining to editing posts with polls, just editing/deleting polls themselves.
[/EDIT]

Is this supposed to happen?
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/


Last edited by count on Tue Mar 25, 2003 7:32 pm; edited 2 times in total
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16106
Location: Colorado

PostPosted: Sat Mar 22, 2003 8:53 pm    Post subject: Reply with quote

Can you reproduce the problem? I've not had that happen when I've edited poll posts.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Sun Mar 23, 2003 4:12 am    Post subject: Reply with quote

Just tried it ... same thing ... this is my procedure

1. click new topic
2. edit the topic, adding poll questions/anwsers
3. submit topic
4. vote
5. click edit post on first post
6. edit post
7. click submit
8. view topic ... poof, poll gone
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Tue Mar 25, 2003 7:05 pm    Post subject: Reply with quote

count wrote:
1. click new topic
2. edit the topic, adding poll questions/anwsers
3. submit topic
4. vote
5. click edit post on first post
6. edit post
7. click submit
8. view topic ... poof, poll gone

I just tried these exact steps and was unable to reproduce the problem

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Tue Mar 25, 2003 7:10 pm    Post subject: Reply with quote

I just re-performed the exact actions and still had the problem.

Could it be that you are trying it with administrative permissions?

If you want to AIM me (SN in profile) I will go through the steps telling you what I'm doing and you can watch the results in the forum.
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
testing_polls
n00b
n00b


Joined: 25 Mar 2003
Posts: 1

PostPosted: Tue Mar 25, 2003 7:27 pm    Post subject: Reply with quote

count wrote:
Could it be that you are trying it with administrative permissions?

yep -- looks like it. I logged in as a regular user and was able to reproduce the problem.

This is most likely a bug in phpbb, but we'll do some investigating to validate that. If it is, in fact, a phpbb bug, we'll file an upstream bug report.

--kurt
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Tue Mar 25, 2003 7:45 pm    Post subject: Reply with quote

I looked around the phpBB bug tracker and the closest thing I could find was this:

http://phpbb.com/bugs/bug.php?op=show&bugid=1309

Its tough to tell how releated this problem is since the reporter doesnt do the best job of describeing the problem, but it does speak of disappearing poll questions.
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Wed Mar 26, 2003 2:08 pm    Post subject: Reply with quote

count wrote:
I looked around the phpBB bug tracker and the closest thing I could find was this:

http://phpbb.com/bugs/bug.php?op=show&bugid=1309

Its tough to tell how releated this problem is since the reporter doesnt do the best job of describeing the problem, but it does speak of disappearing poll questions.

Yep -- that looks like the exact problem. If I have time, I'll poke around in their CVS to see if I can figure out what that specific fix is. If I can find it, I'll apply it to our current source. Otherwise, this will get fixed in 2.0.5 (probably more likely, to be honest)

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
axxackall
l33t
l33t


Joined: 06 Nov 2002
Posts: 651
Location: Toronto, Ontario, 3rd Rock From Sun

PostPosted: Thu Apr 03, 2003 8:43 pm    Post subject: Reply with quote

I confirm that few weeks ago I had the same problem on Gentoo Forums. When I edited already published poll, its questions has disappered, converting the poll to regular post.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Thu May 22, 2003 7:00 pm    Post subject: Reply with quote

I just went through and resurrected all orphaned polls I could find. If you edit a post that had a poll attached to it, please don't create another poll. It makes it harder to fix things later. Instead send a PM to an admin containing a link to the topic.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum