Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz Fusion black screen :(
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Mon Aug 06, 2007 4:57 am    Post subject: Compiz Fusion black screen :( Reply with quote

Hello everyone! I'm having a problem with compiz fusion, I think something in my config is wrong or is just a nasty bug in compiz fusion, whatever... the problem is that every time I want to start it I only get a black screen and I only can see the cursor, I'm using the Open Source drivers with my ATI X300 video card. I've searched the forums, google, etc but found nothing it can really help me, this is the third day trying to make this thing work, so please help me :?

This is my config and some logs.

emerge --info:
Code:

Portage 2.1.3.3 (default-linux/x86/2007.0/desktop, gcc-4.2.0, glibc-2.6-r0, 2.6.22-gentoo-r2 i686)
=================================================================
System uname: 2.6.22-gentoo-r2 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System release 1.12.10
Timestamp of tree: Sat, 04 Aug 2007 09:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/ziet/Portage /usr/local/layman/xeffects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amr arts avahi bash-completion berkdb bitmap-fonts branding cairo cddb cdr cli cracklib crypt curl daap dbus dri dts dvd dvdr dvdread emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif glibc-omitfp glitz gmp gnutls gpm gsf gstreamer hal iconv imlib isdnlog java jpeg kde kdeenablefinal kdehiddenvisibility kerberos libg++ mad midi mikmod mmx mmxext mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pango pcre pdf perl png pppd python qt qt3 qt3support quicktime readline reflection sdl session spell spl sse sse2 sse3 ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode usb v4l vorbis win32codecs x86 xine xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="ptp2 spca50x" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


cat /var/log/Xorg.0.log | grep -e EE -e WW:
Code:
Current Operating System: Linux bavrit 2.6.22-gentoo-r2 #2 PREEMPT Sat Aug 4 13:59:13 PET 2007 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) Loading extension MIT-SCREEN-SAVER
(WW) RADEON: No matching Device section for instance (BusID PCI:5:0:1) found
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32

glxinfo | grep direct:
Code:

libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes


xorg.conf:
Code:
Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "screen1" 0 0
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    Option      "AIGLX" "true"
EndSection

Section "Module"
    Load        "dbe"
    SubSection  "extmod"
      Option    "omit xfree86-dga"
    EndSubSection
#    Load       "extmod"
    Load       "freetype"
    Load       "glx"
    Load       "dri"
    Load       "drm"
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/lib/X11/fonts/misc/"
    FontPath   "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/lib/X11/fonts/Type1/"
    FontPath   "/usr/lib/X11/fonts/75dpi/"
    FontPath   "/usr/lib/X11/fonts/100dpi/"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "es"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "ExplorerPS/2" # Explorer PS/2
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"   "4 5 6 7"
    Option "Emulate3Buttons"
EndSection

Section "Monitor"
    Identifier  "monitor1"
    Option      "DPMS"          "1"
EndSection

Section "Device"
    Identifier  "gpu1"
    Driver      "radeon"
#    Option      "XAANoOffscreenPixmaps" "true"
    Option      "RenderAccel"           "1"
    Option      "DynamicClocks"         "1"
    Option      "EnablePageFlip"        "1"
    Option      "AccelMethod"           "XAA"
    Option      "backingstore"          "1"
    Option      "GARTSize"              "64"
EndSection

Section "Screen"
    Identifier  "screen1"
    Device      "gpu1"
    Monitor     "monitor1"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
EndSection

Section "DRI"
        Group 0
        Mode 0666
EndSection

Section "Extensions"
        Option "Composite"   "Enable"
        Option "XVideo" "Enable"
EndSection


compiz-manager log:
Code:

Backend     : kconfig
Integration : true
Profile     : default
Adding plugin screenshot (screenshot)
Adding plugin extrawm (extrawm)
Adding plugin mblur (mblur)
Adding plugin clone (clone)
Adding plugin text (text)
Adding plugin put (put)
Adding plugin annotate (annotate)
Adding plugin trailfocus (trailfocus)
Adding plugin switcher (switcher)
Adding plugin gears (gears)
Adding plugin scaleaddon (scaleaddon)
Adding plugin place (place)
Adding plugin splash (splash)
Adding plugin addhelper (addhelper)
Adding plugin scalefilter (scalefilter)
Adding plugin ezoom (ezoom)
Adding plugin resizeinfo (resizeinfo)
Adding plugin move (move)
Adding plugin water (water)
Adding plugin crashhandler (crashhandler)
Adding plugin zoom (zoom)
Adding plugin dbus (dbus)
Adding plugin scale (scale)
Adding plugin vpswitch (vpswitch)
Adding plugin fadedesktop (fadedesktop)
Adding plugin video (video)
Adding plugin workarounds (workarounds)
Adding plugin bench (bench)
Adding plugin glib (glib)
Adding plugin ring (ring)
Adding plugin winrules (winrules)
Adding plugin blur (blur)
Adding core settings (General Options)
Adding plugin firepaint (firepaint)
Adding plugin fs (fs)
Adding plugin animation (animation)
Adding plugin inotify (inotify)
Adding plugin expo (expo)
Adding plugin gotovp (gotovp)
Adding plugin reflex (reflex)
Adding plugin snap (snap)
Adding plugin neg (neg)
Adding plugin group (group)
Adding plugin rotate (rotate)
Adding plugin showdesktop (showdesktop)
Adding plugin decoration (decoration)
Adding plugin minimize (minimize)
Adding plugin imgjpeg (imgjpeg)
Adding plugin wobbly (wobbly)
Adding plugin svg (svg)
Adding plugin cube (cube)
Adding plugin fade (fade)
Adding plugin opacify (opacify)
Adding plugin wall (wall)
Adding plugin regex (regex)
Adding plugin resize (resize)
Adding plugin cubereflex (cubereflex)
Adding plugin png (png)
Adding plugin plane (plane)
Adding plugin thumbnail (thumbnail)
Initializing core options...done
Initializing extrawm options...done
Initializing put options...done
Initializing place options...done
Initializing splash options...done
Initializing move options...done
Initializing crashhandler options...done
Initializing zoom options...done
Initializing workarounds options...done
Initializing ring options...done
Initializing showdesktop options...done
Initializing decoration options...done
Initializing minimize options...done
Initializing imgjpeg options...done
Initializing wobbly options...done
Initializing svg options...done
Initializing fade options...done
Initializing opacify options...done
Initializing resize options...done
Initializing thumbnail options...done
Initializing trailfocus options...done
Initializing group options...done
Initializing cube options...done
Initializing switcher options...done
Initializing scale options...done
Initializing expo options...done
Initializing rotate options...done
Initializing cubereflex options...done
Initializing scaleaddon options...done
Initializing scalefilter options...done

It seems everything is initializing correctly... :?

If you need more info, please ask for it, thank you very much :)
_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Tue Aug 07, 2007 12:44 am    Post subject: Reply with quote

No one?? 8O
_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
roderick
l33t
l33t


Joined: 11 Jul 2005
Posts: 908
Location: St. John's, NL CANADA

PostPosted: Tue Aug 07, 2007 3:32 am    Post subject: Reply with quote

what version of xorg-server and mesa are you running as well as glitz, gtk, cairo and pango? Have you tried rebuilding those packages?

Not sure but it may help.

can you provide output from:

Code:

emerge -pv glitz pango gtk cairo mesa xorg-server

_________________
If God were a pickle, I'd still say "no pickle on my burger".
http://roderick-greening.blogspot.com/
Back to top
View user's profile Send private message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Tue Aug 07, 2007 7:32 pm    Post subject: Reply with quote

This is the output:

Code:
[ebuild   R   ] media-libs/glitz-0.5.6  0 kB
[ebuild   R   ] x11-libs/pango-1.16.4  USE="-debug -doc" 0 kB
[ebuild   R   ] x11-libs/gtk+-2.10.14  USE="X jpeg tiff -debug -doc -xinerama" 0 kB
[ebuild   R   ] x11-libs/cairo-1.4.10  USE="X glitz opengl svg -debug -directfb -doc -newspr -xcb" 0 kB [1]
[ebuild   R   ] media-libs/mesa-6.5.3  USE="nptl -debug -doc (-hardened) -motif -xcb" VIDEO_CARDS="radeon -i810 -mach64 -mga -none -r128 -s3virge -savage -sis (-sunffb) -tdfx -trident -via" 0 kB
[ebuild   R   ] x11-base/xorg-server-1.3.0.0  USE="dri nptl sdl xorg -3dfx -debug -dmx -ipv6 -kdrive -minimal -xprint" INPUT_DEVICES="keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="radeon -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc -nv -nvidia -r128 -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo" 0 kB

_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Tue Aug 07, 2007 9:08 pm    Post subject: Reply with quote

Same thing after rebuilding those packages... black screen :(
_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
roderick
l33t
l33t


Joined: 11 Jul 2005
Posts: 908
Location: St. John's, NL CANADA

PostPosted: Tue Aug 07, 2007 9:10 pm    Post subject: Reply with quote

I believe xcb is now required by compiz. So, you'll have to set xcb use flag in /etc/make.conf and then emerge -avuND world. Basically, it'll install libxcb, rebuild libx11, xorg-server, mesa, cairo, and possibly a few others.

It is NOT sufficient to rebuild libx11 with xcb as I believe this can break xorg-server and mesa, etc. It's all or none.

So, after you rebuild with xcb use flag, then you will need to re-sync layman, and then re-emerge all the compiz stuff in the correct order. I recommend emerge -C the packages and then re-emerge the compiz-fusion meta package to pull the deps in the correct order.

If after that you still have problems, let us know.
_________________
If God were a pickle, I'd still say "no pickle on my burger".
http://roderick-greening.blogspot.com/
Back to top
View user's profile Send private message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Wed Aug 08, 2007 1:14 am    Post subject: Reply with quote

I'm still having that damn black screen every time I start compiz fusion :( I've done everything you said, but nothing... What's the problem? :?
_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
Nsane457
n00b
n00b


Joined: 25 Nov 2004
Posts: 36

PostPosted: Mon Aug 13, 2007 4:38 pm    Post subject: Reply with quote

I'm assuming you've tried this? http://gentoo-wiki.com/HOWTO_DRI_with_ATi_Open-Source_Drivers#Xorg_starts_with_no_errors_but_monitor_is_black
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 695

PostPosted: Thu Aug 16, 2007 11:31 am    Post subject: Reply with quote

zietbukuel wrote:
I'm still having that damn black screen every time I start compiz fusion :( I've done everything you said, but nothing... What's the problem? :?


Have you tried, running a regular WM (like twm or metacity), just run glxgear?

Do you see the gear or do you see a black window?

I had trouble with my radeon driver that's making all opengl program come out black.
_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum