Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200601-17 ] Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Mon Jan 30, 2006 10:26 pm    Post subject: [ GLSA 200601-17 ] Xpdf, Poppler, GPdf, libextractor, pdftoh Reply with quote

Gentoo Linux Security Advisory

Title: Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows (GLSA 200601-17)
Severity: normal
Exploitable: remote
Date: January 30, 2006
Bug(s): #117481, #117494, #117495, #115789, #118665
ID: 200601-17

Synopsis

Xpdf, Poppler, GPdf, libextractor and pdftohtml are vulnerable to integer overflows that may be exploited to execute arbitrary code.

Background

Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base. GPdf is a PDF file viewer for the GNOME 2 platform, also based on Xpdf. libextractor is a library which includes Xpdf code to extract arbitrary meta-data from files. pdftohtml is a utility to convert PDF files to HTML or XML formats that makes use of Xpdf code to decode PDF files.

Affected Packages

Package: app-text/xpdf
Vulnerable: < 3.01-r5
Unaffected: >= 3.01-r5
Architectures: All supported architectures

Package: app-text/poppler
Vulnerable: < 0.4.3-r4
Unaffected: >= 0.4.3-r4
Architectures: All supported architectures

Package: app-text/gpdf
Vulnerable: < 2.10.0-r3
Unaffected: >= 2.10.0-r3
Architectures: All supported architectures

Package: media-libs/libextractor
Vulnerable: < 0.5.9
Unaffected: >= 0.5.9
Architectures: All supported architectures

Package: app-text/pdftohtml
Vulnerable: < 0.36-r4
Architectures: All supported architectures


Description

Chris Evans has reported some integer overflows in Xpdf when attempting to calculate buffer sizes for memory allocation, leading to a heap overflow and a potential infinite loop when handling malformed input files.

Impact

By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r5"
All Poppler users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/poppler-0.4.3-r4"
All GPdf users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r3"
All libextractor users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libextractor-0.5.9"
All pdftohtml users should migrate to the latest stable version of Poppler.

References

CVE-2005-3627
CVE-2005-3626
CVE-2005-3625
CVE-2005-3624


Last edited by GLSA on Sun Jan 27, 2008 4:18 am; edited 9 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum