Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage overlay] pro audio production applications
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 31, 32, 33  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
daseinhorn
Apprentice
Apprentice


Joined: 16 Jan 2009
Posts: 150
Location: Canada

PostPosted: Wed Mar 25, 2009 12:55 am    Post subject: Reply with quote

gimpel wrote:
@ daseinhorn
Try
Code:
FEATURES="-sandbox" emerge jack-audio-connection-kit

if you want to test jack-1.9.x. Additionally you have to unmask it
Code:
echo "media-sound/jack-audio-connection-kit" >> /etc/portage/package.mask


It's an issue with =sandbox-1.6


Something is wrong with the ebuild. I did layman -S all before trying to emerge jack

Code:
xavier-pc xavier # FEATURES="-sandbox" emerge -av =media-sound/jack-audio-connection-kit-1.9.2                                                                       

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-sound/jack-audio-connection-kit-1.9.2 [0.116.2] USE="dbus%* -debug -doc -freebob% -monitor% (-3dnow%) (-alsa%*) (-altivec%) (-coreaudio%) (-cpudetection%) (-examples%) (-mmx%*) (-oss%) (-sse%*)" 2,313 kB [0=>1]                 

Total: 1 package (1 upgrade), Size of downloads: 2,313 kB
Portage tree and overlays:                               
 [0] /usr/portage                                       
 [1] /usr/local/portage/layman/pro-audio                 

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-sound/jack-audio-connection-kit-1.9.2 from proaudio
>>> Downloading 'ftp://mirrors.tera-byte.com/pub/gentoo/distfiles/jack-1.9.2.tar.bz2'                                                                                 
--2009-03-24 20:54:15--  ftp://mirrors.tera-byte.com/pub/gentoo/distfiles/jack-1.9.2.tar.bz2                                                                         
           => `/usr/portage/distfiles/jack-1.9.2.tar.bz2'                         
Resolving mirrors.tera-byte.com... 216.194.64.133                                 
Connecting to mirrors.tera-byte.com|216.194.64.133|:21... connected.               
Logging in as anonymous ... Logged in!                                             
==> SYST ... done.    ==> PWD ... done.                                           
==> TYPE I ... done.  ==> CWD /pub/gentoo/distfiles ... done.                     
==> SIZE jack-1.9.2.tar.bz2 ... done.                                             
==> PASV ... done.    ==> RETR jack-1.9.2.tar.bz2 ...                             
No such file `jack-1.9.2.tar.bz2'.                                                 

>>> Downloading 'ftp://mirror.fslutd.org/linux/distributions/gentoo/distfiles/jack-1.9.2.tar.bz2'                                                                     
--2009-03-24 20:54:16--  ftp://mirror.fslutd.org/linux/distributions/gentoo/distfiles/jack-1.9.2.tar.bz2                                                             
           => `/usr/portage/distfiles/jack-1.9.2.tar.bz2'                         
Resolving mirror.fslutd.org... failed: Unknown host.                               
wget: unable to resolve host address `mirror.fslutd.org'                           
>>> Downloading 'http://www.grame.fr/~letz/jack-1.9.2.tar.bz2'                     
--2009-03-24 20:54:16--  http://www.grame.fr/~letz/jack-1.9.2.tar.bz2             
Resolving www.grame.fr... 194.5.49.4                                               
Connecting to www.grame.fr|194.5.49.4|:80... connected.                           
HTTP request sent, awaiting response... 200 OK
Length: 2369008 (2.3M) [application/x-bzip2]
Saving to: `/usr/portage/distfiles/jack-1.9.2.tar.bz2'

100%[=========================================>] 2,369,008    221K/s   in 11s

2009-03-24 20:54:27 (215 KB/s) - `/usr/portage/distfiles/jack-1.9.2.tar.bz2' saved[2369008/2369008]

('Filesize does not match recorded size', 2369008, 2367748)
!!! Fetched file: jack-1.9.2.tar.bz2 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      2369008
!!! Expected: 2367748
Refetching... File renamed to '/usr/portage/distfiles/jack-1.9.2.tar.bz2._checksum_failure_.v0Uf4J'

!!! Couldn't download 'jack-1.9.2.tar.bz2'. Aborting.
 * Fetch failed for 'media-sound/jack-audio-connection-kit-1.9.2', Log file:
 *  '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.2/temp/build.log'

>>> Failed to emerge media-sound/jack-audio-connection-kit-1.9.2, Log file:

>>>  '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.2/temp/build.log'

 * Messages for package media-sound/jack-audio-connection-kit-1.9.2:

 * Fetch failed for 'media-sound/jack-audio-connection-kit-1.9.2', Log file:
 *  '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.2/temp/build.log'
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Mar 25, 2009 1:10 am    Post subject: Reply with quote

Sorry, something seems wrong on my box. Whenever I create a manifest with "ebuild foo.ebuild manifest" it calculates wrong checksums.

So just type
Code:
ebuild jack-audio-connection-kit-1.9.2.ebuild manifest

manually until I figure out what's wrong here.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
daseinhorn
Apprentice
Apprentice


Joined: 16 Jan 2009
Posts: 150
Location: Canada

PostPosted: Wed Mar 25, 2009 1:26 am    Post subject: Reply with quote

I probably forgot to add something to the command. The result makes sense, as the ebuild was taken from layman, but I do not know how to fix it.

Code:
xavier-pc xavier # ebuild jack-audio-connection-kit-1.9.2.ebuild manifest
Appending / to PORTDIR_OVERLAY...
'/home/xavier/jack-audio-connection-kit-1.9.2.ebuild' does not exist.


Could you just clear out that part? Thanks.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Mar 25, 2009 1:28 am    Post subject: Reply with quote

Hopefully it is fixed now, sync the overlay again please.

Anyways, you would need to cd into the overlay directory, i.e. you need the full or relative path to the ebuild.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
daseinhorn
Apprentice
Apprentice


Joined: 16 Jan 2009
Posts: 150
Location: Canada

PostPosted: Wed Mar 25, 2009 2:41 am    Post subject: Reply with quote

It compiled! I will learn how to use it now.
Back to top
View user's profile Send private message
nowinter
Tux's lil' helper
Tux's lil' helper


Joined: 30 Apr 2006
Posts: 90

PostPosted: Tue Mar 31, 2009 7:15 pm    Post subject: What happened to the overlay? Reply with quote

subversion doesn't work for me anymore, neither checkout nor update
Quote:
# layman -a pro-audio
* Running command "/usr/bin/svn co "svn://svn.tuxfamily.org/svnroot/proaudio/proaudio/trunk/overlays/proaudio/" "/usr/local/overlays/pro-audio""...
svn: Can't connect to host 'svn.tuxfamily.org': Connection timed out

_________________
All In All Is All We All Are
Back to top
View user's profile Send private message
nowinter
Tux's lil' helper
Tux's lil' helper


Joined: 30 Apr 2006
Posts: 90

PostPosted: Wed Apr 01, 2009 8:06 pm    Post subject: Re: What happened to the overlay? Reply with quote

nowinter wrote:
subversion doesn't work for me anymore, neither checkout nor update
Quote:
# layman -a pro-audio
* Running command "/usr/bin/svn co "svn://svn.tuxfamily.org/svnroot/proaudio/proaudio/trunk/overlays/proaudio/" "/usr/local/overlays/pro-audio""...
svn: Can't connect to host 'svn.tuxfamily.org': Connection timed out

seems back for good
no updates though :(
_________________
All In All Is All We All Are
Back to top
View user's profile Send private message
kiwidoc66
n00b
n00b


Joined: 15 Mar 2009
Posts: 12
Location: New Zealand

PostPosted: Sat Apr 11, 2009 1:04 am    Post subject: Wineasio fetch fail Reply with quote

Hi - attempting to emerge wineasio

>>> Emerging (1 of 2) media-libs/asio-sdk-2.2 from proaudio

!!! media-libs/asio-sdk-2.2 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually. See the comments in the ebuild for more information.

* 1. go to http://www.steinberg.net/329+M52087573ab0.html
* 2. read the license agreement
* 3. if you accept it, then download asiosdk2.2.zip
* 4. move asiosdk2.2.zip to /usr/portage/distfiles
*
* Fetch failed for 'media-libs/asio-sdk-2.2', Log file:
* '/var/tmp/portage/media-libs/asio-sdk-2.2/temp/build.log'

I have downloaded the asiosdk file and installed it
How do I overcome the fetch restriction?

Thanks
David
Back to top
View user's profile Send private message
nowinter
Tux's lil' helper
Tux's lil' helper


Joined: 30 Apr 2006
Posts: 90

PostPosted: Sat Apr 11, 2009 8:32 am    Post subject: Reply with quote

Quote:
I have downloaded the asiosdk file

I guess this is exactly how you overcome the fetch restriction :)
The point is to have the .zip you downloaded properly named and put in your dist files directory (typically /usr/portage/distfiles/asiosdk2.2.zip) so the portage would find them etc.
_________________
All In All Is All We All Are
Back to top
View user's profile Send private message
kiwidoc66
n00b
n00b


Joined: 15 Mar 2009
Posts: 12
Location: New Zealand

PostPosted: Sat Apr 11, 2009 9:53 am    Post subject: Reply with quote

What an eejit! :?
Thanks for the pointer - I had downloaded the wrong sdk file from steinberg - with asiosdk2.2 it has compiled perfectly...
Back to top
View user's profile Send private message
anli
Tux's lil' helper
Tux's lil' helper


Joined: 08 Sep 2006
Posts: 80

PostPosted: Thu Apr 16, 2009 1:48 am    Post subject: media-libs/oscpack-1.0.2-r1 emerge failed... Reply with quote

... on ~amd64 with these errors:

Code:
>>> Emerging (1 of 3) media-libs/oscpack-1.0.2-r1 from proaudio
 * oscpack_1_0_2.zip RMD160 SHA1 SHA256 size ;-) ...                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                   [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                  [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                 [ ok ]
>>> Unpacking source...                                                                                                                     
>>> Unpacking oscpack_1_0_2.zip to /wrk/tmp/portage/portage/media-libs/oscpack-1.0.2-r1/work                                                 
>>> Source unpacked in /wrk/tmp/portage/portage/media-libs/oscpack-1.0.2-r1/work                                                             
>>> Compiling source in /wrk/tmp/portage/portage/media-libs/oscpack-1.0.2-r1/work/oscpack ...                                               
make -j1                                                                                                                                     
g++ -Wall -O3 -fPIC -I./ -DOSC_HOST_LITTLE_ENDIAN   -c -o tests/OscUnitTests.o tests/OscUnitTests.cpp                                       
tests/OscUnitTests.cpp: In function ‘void osc::assertEqual_(const T*, const T*, const char*, const char*, const char*, int) [with T = char]’:
tests/OscUnitTests.cpp:82: error: ‘strcmp’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp: In function ‘char* osc::NewMessageBuffer(const char*, long unsigned int)’:                                           
tests/OscUnitTests.cpp:102: error: ‘memcpy’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp: In function ‘void osc::test1()’:                                                                                     
tests/OscUnitTests.cpp:116: error: ‘strcmp’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp: In function ‘void osc::test3()’:                                                                                     
tests/OscUnitTests.cpp:313: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:322: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:322: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:323: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:323: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:324: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:324: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:326: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:326: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:327: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:327: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:329: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:329: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:331: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:331: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:333: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:333: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:335: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:335: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:337: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:337: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:339: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:339: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:341: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:341: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:343: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:343: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:348: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:361: error: ‘memcmp’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:365: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:365: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:367: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:367: error: ‘memset’ was not declared in this scope                                                                   
tests/OscUnitTests.cpp:373: error: ‘memset’ was not declared in this scope                                                                   
make: *** [tests/OscUnitTests.o] Error 1                                                                                                     
 *                                                                                                                                           
 * ERROR: media-libs/oscpack-1.0.2-r1 failed.                                                                                               
 * Call stack:                                                                                                                               
 *               ebuild.sh, line   48:  Called src_compile                                                                                   
 *             environment, line 2227:  Called die                                                                                           
 * The specific snippet of code:                                                                                                             
 *       emake || die "make failed";                                                                                                         
 *  The die message:                                                                                                                         
 *   make failed                                                                                                                             
 *                                                                                                                                           
 * If you need support, post the topmost build error, and the call stack if relevant.                                                       
 * A complete build log is located at '/wrk/tmp/portage/portage/media-libs/oscpack-1.0.2-r1/temp/build.log'.                                 
 * The ebuild environment file is located at '/wrk/tmp/portage/portage/media-libs/oscpack-1.0.2-r1/temp/environment'.                       
 * This ebuild is from an overlay named 'proaudio': '/usr/local/portage/layman/pro-audio/'                                                   
 *                                                                                                                                           

>>> Failed to emerge media-libs/oscpack-1.0.2-r1, Log file:
...
Back to top
View user's profile Send private message
daseinhorn
Apprentice
Apprentice


Joined: 16 Jan 2009
Posts: 150
Location: Canada

PostPosted: Mon May 11, 2009 5:31 pm    Post subject: Reply with quote

Having trouble to rebuild Ardour during a revdep-rebuild command:

Code:

Checking for C header file fftw3.h... yes
Checking for usb_interrupt_write() in C library usb... yes
Checking for C header file linux/input.h... yes           
Checking for FLAC__seekable_stream_decoder_init() in C++ library FLAC... no
Checking for C++ header file boost/shared_ptr.hpp... yes                   
Checking for lo_server_new() in C library lo... yes                       
Checking for dmalloc_shutdown() in C library dmallocth... no               
Checking for C header file alsa/asoundlib.h... yes                         
Checking for gtkmm-2.4... yes                                             
Checking for sigc++-2.0... yes                                             
Checking for libgnomecanvasmm-2.6... yes                                   
Package soundtouch-1.0 was not found in the pkg-config search path.       
Perhaps you should add the directory containing `soundtouch-1.0.pc'       
to the PKG_CONFIG_PATH environment variable                               
No package 'soundtouch-1.0' found                                         
OSError: 'pkg-config --cflags --libs soundtouch-1.0' exited 1:             
  File "/var/tmp/portage/media-sound/ardour-2.7.1/work/ardour-2.7.1/SConstruct", line 1106:
    libraries['soundtouch'].ParseConfig ('pkg-config --cflags --libs soundtouch-1.0')     
  File "/usr/lib/scons-1.2.0/SCons/Environment.py", line 1447:                             
    return function(self, self.backtick(command))                                         
  File "/usr/lib/scons-1.2.0/SCons/Environment.py", line 585:                             
    raise OSError("'%s' exited %d" % (command, status))                                   
 *                                                                                         
 * ERROR: media-sound/ardour-2.7.1 failed.                                                 
 * Call stack:                                                                             
 *               ebuild.sh, line   49:  Called src_compile                                 
 *             environment, line 2840:  Called die                                         
 * The specific snippet of code:                                                           
 *       scons $(ardour_use_enable DEBUG debug) FPU_OPTIMIZATION=${FPU_OPTIMIZATION} DESTDIR="${D}" $(ardour_use_enable NLS nls) $(ardour_use_enable FREESOUND freesound) $(ardour_use_enable LV2 lv2) FFT_ANALYSIS=1 SYSLIBS=1 CFLAGS="${CFLAGS}" PREFIX=/usr || die "scons failed"                                                   
 *  The die message:                                                                                         
 *   scons failed                                                                                           
 *                                                                                                           
 * If you need support, post the topmost build error, and the call stack if relevant.                       
 * A complete build log is located at '/var/tmp/portage/media-sound/ardour-2.7.1/temp/build.log'.           
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/ardour-2.7.1/temp/environment'.   
 * This ebuild is from an overlay named 'proaudio': '/usr/local/portage/layman/pro-audio/'                   
 *


I reemerged a package named "libsoundtouch", but it did not help.

My emerge --info

Code:
xavier-portable xavier # emerge --info   
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r3 x86_64)                                                                                                         
=================================================================                                           
System uname: Linux-2.6.29-gentoo-r3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9500_@_2.53GHz-with-gentoo-2.0.0     
Timestamp of tree: Mon, 11 May 2009 15:45:02 +0000                                                           
app-shells/bash:     4.0_p17-r1                                                                             
dev-java/java-config: 2.1.7                                                                                 
dev-lang/python:     2.6.2                                                                                   
dev-util/cmake:      2.6.4                                                                                   
sys-apps/baselayout: 2.0.0                                                                                   
sys-apps/openrc:     0.4.3-r2                                                                               
sys-apps/sandbox:    1.9                                                                                     
sys-devel/autoconf:  2.13, 2.63-r1                                                                           
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                               
sys-devel/binutils:  2.19.1-r1                                                                               
sys-devel/gcc-config: 1.4.1                                                                                 
sys-devel/libtool:   2.2.6a                                                                                 
virtual/os-headers:  2.6.29                                                                                 
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                               
CBUILD="x86_64-pc-linux-gnu"                                                                                 
CFLAGS="-O2 -pipe"                                                                                           
CHOST="x86_64-pc-linux-gnu"                                                                                 
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"     
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                           
CXXFLAGS="-O2 -pipe"                                                                                         
DISTDIR="/usr/portage/distfiles"                                                                             
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                                                           
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo/ ftp://mirror.fslutd.org/linux/distributions/gentoo/"
LDFLAGS="-Wl,-O1"                                                                                           
LINGUAS="en en_US fr fr_CA nb no nb_NO"                                                                     
MAKEOPTS="-j3"                                                                                               
PKGDIR="/usr/portage/packages"                                                                               
PORTAGE_CONFIGROOT="/"                                                                                       
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/nouveau /usr/local/portage/layman/zugaina /usr/local/portage/layman/pro-audio /usr/local/portage/layman/berkano"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa amd64 autoipd automount avahi berkdb bittorrent-external bluetooth branding bzip2 cairo cdaudio cddb cdr cdrkit cli consolekit cracklib crypt css cuda cups dbus dhcp dhcpcd dri dts dvb dvd dvdr dvdread eds embedded emboss encode esd evo fam ffmpeg firefox flac fluidsynth fortran fuse gdbm gif gimp git gnome gpm gstreamer gtk hal iconv isdnlog jack java jpeg kate kde kdeenablefinal ldap libnotify mad mdnsresponder-compat midi mikmod mmx mng mp3 mpeg msn mudflap multilib mysql ncurses networkmanager nls npp nptl nptlonly nsplugin ogg openexr opengl openmp pam pcre pdf perl plasma png ppds pppd ptp2 pulseaudio python qt3 qt3support qt4 quicktime readline reflection resolvconf samba sdl session skins sound spell spl sqlite sse sse2 sse3 ssl startup-notification subversion svg symlink sysfs tcpd tga theora tiff truetype unicode usb v4l v4l2 vcd vorbis webkit wiki wlm x264 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US fr fr_CA nb no nb_NO" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Any idea why this happens?

Thanks!
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 729
Location: Alaska

PostPosted: Thu May 21, 2009 10:35 pm    Post subject: Reply with quote

I've tried installing ardour-2.8 by downloading it from ardour.org and keywording ardour-2.8 in my keywords file. I'm running ~x86.

It failed here:
Code:
Chmod("gtk2_ardour/ardour.sh", 0755)
Substituting vars from gtk2_ardour/ardour2_ui_dark.rc.in into gtk2_ardour/ardour2_ui_dark.rc
Substituting vars from gtk2_ardour/ardour2_ui_light.rc.in into gtk2_ardour/ardour2_ui_light.rc
Substituting vars from gtk2_ardour/ardour2_ui_dark_sae.rc.in into gtk2_ardour/ardour2_ui_dark_sae.rc
Substituting vars from gtk2_ardour/ardour2_ui_light_sae.rc.in into gtk2_ardour/ardour2_ui_light_sae.                                 rc
os.chdir('gtk2_ardour')
cpp -E -P ardour.menus.in ardour.menus
gcc -o libs/clearlooks-older/clearlooks_draw.os -c `pkg-config --cflags gtk+-2.0` -fPIC -Ilibs/clear                                 looks-older libs/clearlooks-older/clearlooks_draw.c
os.chdir('/var/tmp/portage/media-sound/ardour-2.8/work/ardour-2.8')
gcc -o libs/clearlooks-older/clearlooks_rc_style.os -c `pkg-config --cflags gtk+-2.0` -fPIC -Ilibs/c                                 learlooks-older libs/clearlooks-older/clearlooks_rc_style.c
gcc: libs/clearlooks-older/clearlooks_draw.c: No such file or directory
gcc: no input files
scons: *** [libs/clearlooks-older/clearlooks_draw.os] Error 1
scons: building terminated because of errors.
 *
 * ERROR: media-sound/ardour-2.8 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2767:  Called die
 * The specific snippet of code:
 *       scons ${myconf} ${MAKEOPTS} || die "compilation failed"

 *


I've got scons-1.2.0-r1 installed.

emerge --info:
Code:

Portage 2.2_rc33 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r1-i686-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-gentoo-2.0.0
Timestamp of tree: Thu, 21 May 2009 06:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.usu.edu/mirrors/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/pro-audio /usr/local/portage/layman/kde-testing /usr/local/portage /usr/local/portage/layman/kde-testing /usr/local/portage/layman/pro-audio"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aiglx alsa berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups dbus divx4linux dri dvd dvdr exif fam flac foomatic fortran gdbm gif gimp gimpprint gpm hal iconv ipv6 isdnlog jack jack-tmpfs jackmidi java jpeg kde kdeprefix kipi ladspa mad midi mikmod mp3 mpeg mudflap mysql ncurses nfs nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pcre pdf perl php5 png ppds pppd python qt3support qt4 quicktime raw readline reflection samba sane scanner sdl session sndfile spell spl sse sse2 ssl swscaler sysfs tcpd theora tiff truetype type1-fonts unicode usb v4l2 vorbis vst vst-sdk win32codecs x264 x86 xanim xcomposite xinerama xml xorg xrandr xsane xulrunner xv xvid zlib" ALSA_CARDS="ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


thanks for looking and cheers! /jim
Back to top
View user's profile Send private message
kolas
n00b
n00b


Joined: 26 Jan 2009
Posts: 25
Location: San Francisco

PostPosted: Thu May 28, 2009 3:06 pm    Post subject: Reply with quote

csound 5.09 from this overlay is giving me 'no legal opcode' errors with poscil and vco2:
Code:

time resolution is 0.312 ns
0dBFS level = 32768.0
Csound version 5.09 beta (float samples) May 28 2009
libsndfile-1.0.20
UnifiedCSD:  funtonight.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
orchname:  /tmp/fileYReAvV.orc
scorename: /tmp/fileKxMBK7.sco
orch compiler:
31 lines read
   instr   1   
error:  no legal opcode, line 17:
a1   poscil   k1, p5, p8
error:  input arg 'a1' used before defined, line 20:
   out   a1
   instr   2   
error:  no legal opcode, line 25:
a2   vco2   k2, p5
error:  input arg 'a2' used before defined, line 26:
   out   a2
   instr   3   
        ################################################################
        #               WARNING: OPCODEDIR IS NOT SET !                #
        # Csound requires this environment variable to be set to find  #
        # its plugin libraries. If it is not set, you may experience   #
        # missing opcodes, audio/MIDI drivers, or utilities.           #
        ################################################################
4 syntax errors in orchestra.  compilation invalid
Removing temporary file /tmp/fileKxMBK7.sco ...
Removing temporary file /tmp/fileYReAvV.orc ...


I have the 'osc_opcodes' and 'stk_opcodes' USE flags on for the ebuild. Anyone know why it can't recognize these opcodes?

Also, I've never gotten any FLTK widgets to work with this csound ebuild. Anyone had success with that?
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Wed Jun 03, 2009 7:52 pm    Post subject: Reply with quote

audiodef wrote:
...realtime-lsm still fails to compile, though...

Also, this link says "make sure you have the latest version of PAM installed from the overlay" - is this even if the non-overlay version of pam is higher than the overlay version?

I use the portage ~arch version of the pam (v1.0.4) which works fine.
I switched to pam because not only it is the new and recommended way, but also realtime-lsm mostly fails to compile. Actually if I urge my mind to remember if realtime-lsm compiles fine, than my mind fails, too. Mostly because of the following line in the ebuild.
Code:

rm "${D}/etc/modules.d/realtime" || die "unable to remove upstream configuration file"

If I don't remember wrong, removing the "${D}", from above line makes it compile.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"


Last edited by keenblade on Fri Jun 19, 2009 5:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
Raoul
n00b
n00b


Joined: 30 Jul 2006
Posts: 67
Location: Adelaide, Aust.

PostPosted: Sun Jun 14, 2009 2:53 am    Post subject: Reply with quote

I am getting some errors in revdep-rebuild which requires ardour3 to be rebuild. When this happens, the following error ensues:
Code:
>>> Emerging (1 of 1) media-sound/ardour-3.9999 from proaudio
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> cfg-update-1.8.2-r1: Checksum index is up-to-date ...
>>> Unpacking source...
 * subversion update start -->
 *      repository: http://subversion.ardour.org/svn/ardour2/branches/3.0
svn: OPTIONS of 'http://subversion.ardour.org/svn/ardour2/branches/3.0': could not connect to server (http://subversion.ardour.org)
 *
 * ERROR: media-sound/ardour-3.9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2888:  Called subversion_src_unpack
 *             environment, line 3237:  Called subversion_fetch
 *             environment, line 3199:  Called die
 * The specific snippet of code:
 *                           ${ESVN_UPDATE_CMD} ${options} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}.";
 *  The die message:
 *   subversion: can't update /usr/portage/distfiles/svn-src/ardour/3.0 from http://subversion.ardour.org/svn/ardour2/branches/3.0.
 *


My emerge --info is here:
Code:
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.10.1-r0, 2.6.26.8-rt12 x86_64)
=================================================================
System uname: Linux-2.6.26.8-rt12-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4800+-with-glibc2.2.5
Timestamp of tree: Sat, 13 Jun 2009 21:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -fprefetch-loop-arrays -funroll-loops -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -fprefetch-loop-arrays -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.swin.edu.au/gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/pro-audio"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 audiofile berkdb bzip2 c++ cairo cdaudio cdda cdio cdparanoia cdr cdrom clamav clamd cli cracklib crypt cups cupsddk dbus dc1394 divx dri dv dvb dvbplayer dvbsetup dvd dvdarchive dvdr dvdread dvi epson fax ffmpeg fftw firefox flac flash float foomaticdb fortran fortran95 ftp gdbm gftp gif gimp glade glib gmp gnome gnome-print gpg gphoto2 gpm gtk gtkhtml hal html iconv ieee1394 ipv6 isdnlog jack jack-tmpfs java javascript jpeg kino lame midi mmx mp2 mp3 mp4 mpeg mpeg2 mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntp nvidia opengl openmp oss pam pascal pcre pda pdf perl png portaudio pppd python quicktime readline reflection session sndfile spl sse sse2 ssl sysfs tcpd tiff unicode vcd xface xhtml xine xml xorg xvid xvmc zlib" ALSA_CARDS="ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Hoping someone can help.

Thanks
Raoul
_________________
**************
Not all pain is gain.
Back to top
View user's profile Send private message
Xtroce
n00b
n00b


Joined: 27 Apr 2004
Posts: 12

PostPosted: Thu Jun 18, 2009 12:44 pm    Post subject: Reply with quote

hi, i got an error compiling the svn libclam.
the svn location has changed.

it is now:
http://clam-project.org/clam/trunk

also the homepage of the project is now:
http://clam-project.org

both are wrong in the ebuild(s)

**edit** sry posted the data svn, now corrected
_________________
In the land of the blind, the one eyed man is king!
Back to top
View user's profile Send private message
gry
n00b
n00b


Joined: 11 Jul 2009
Posts: 4

PostPosted: Sat Jul 11, 2009 2:36 pm    Post subject: Reply with quote

Hi!
Real time patch for sys-kernel/rt-sources-2.6.24.7-r17 is now moved from http://www.kernel.org/pub/linux/kernel/projects/rt/ to 'old' directory. Current patch is -r27. Ebuilds should be updated.
Thanks in advance!

/*
* gry
*/
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Mon Aug 03, 2009 1:07 pm    Post subject: Reply with quote

There are some ebuilds in proaudio overlay needs to be adjusted for midi useflag. ALSA team has dropped the "midi" use flags from alsa-lib starting with
1.0.19-r1 and alsa-lib-1.0.20-r1 ebuilds. See the gentoo bugzilla entry for more info.

In the overlay there are packages that check for alsa-lib w/midi use flag
support, either through EAPI2 alsa-lib[midi] or --built-with-use. They need to
be updated to allow both versions. Here are some of them:
Code:

media-sound/ardour
media-sound/rosegarden
media-sound/seq24
media-sound/qjackctl
media-sound/lash
media-sound/qtractor

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
|Quantum|
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2004
Posts: 133
Location: Belgium

PostPosted: Mon Aug 03, 2009 5:27 pm    Post subject: Reply with quote

Lash is very critical here as quite some ebuilds from the pro-audio overlay are now broken:

Code:

media-sound/laditools
media-plugins/ll-plugins
media-sound/machina
media-sound/seq24
media-sound/ingen
media-sound/meterbridge
media-sound/smack
media-sound/azr3-jack
Back to top
View user's profile Send private message
|Quantum|
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2004
Posts: 133
Location: Belgium

PostPosted: Mon Aug 03, 2009 10:02 pm    Post subject: Reply with quote

Hmmm, I also seem to have problems with the compilation of libdsp. I don't have very high hopes because the project looks rather abandoned.
Anyway, I googled around and tried several "solutions": use "-fPIC" in the CFLAGS/CXXFLAGS, compile with GCC 3.4.6 and all combination between those two.
Nothing works, though...
Back to top
View user's profile Send private message
hurricane
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 100

PostPosted: Sun Aug 16, 2009 3:04 am    Post subject: asiosdk2.2.zip gone Reply with quote

Has anyone got a mirror for the asiosdk2.2.zip file? It is gone from the Steinberg website, FTP server, and I couldn’t even find it in an extensive Google search. :(
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Thu Aug 20, 2009 5:56 pm    Post subject: Reply with quote

Hi,
For ardour-3, the building system is being shifted from scons to waf. Could somebody update the ebuild to use waf. Since scons scripts are pretty behind in being updated, often emerging media-sound/ardour3.9999 fails.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 228
Location: Ukraine

PostPosted: Thu Aug 20, 2009 7:20 pm    Post subject: Reply with quote

Sorry for offtopic.
But anybody uses Audacity here? If yes, how stable is it?
I experience segfaults after 5-10 minutes of work. Maybe there is some trickery?
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Thu Aug 20, 2009 9:13 pm    Post subject: Reply with quote

MageSlayer wrote:
Sorry for offtopic.
But anybody uses Audacity here? If yes, how stable is it?
I experience segfaults after 5-10 minutes of work. Maybe there is some trickery?

Audacity is rock stable here. I have audacity-1.3.8 with ~amd64 arch. It only gives a warning while starting that it can not create the dir '/usr/share/audacity/help'. But it works perfect.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 31, 32, 33  Next
Page 32 of 33

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum