Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[audicy] compilation impossible (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Mon Apr 17, 2006 8:14 pm    Post subject: [audicy] compilation impossible (résolu) Reply with quote

Bonjour tout le monde,
je n'arrive plus à compiler audacity, j'ai toujours cette erreur :
Code:
i686-pc-linux-gnu-g++ -o ../audacity obj/AColor.o obj/AStatus.o obj/AboutDialog.o obj/AudacityApp.o obj/AudioIO.o obj/Benchmark.o obj/ControlToolBar.o obj/DirManager.o obj/Envelope.o obj/EditToolBar.o obj/FFT.o obj/FormatSelection.o obj/FreqWindow.o obj/Help.o obj/HistoryWindow.o obj/ImageManipulation.o obj/Internat.o obj/LabelTrack.o obj/Languages.o obj/LangChoice.o obj/Legacy.o obj/Menus.o obj/MeterToolBar.o obj/Mix.o obj/MixerToolBar.o obj/NoteTrack.o obj/PitchName.o obj/PlatformCompatibility.o obj/Project.o obj/Resample.o obj/RingBuffer.o obj/Sequence.o obj/Spectrum.o obj/Tags.o obj/Track.o obj/TrackArtist.o obj/TrackPanel.o obj/ToolBar.o obj/UndoManager.o obj/WaveTrack.o obj/TimeTrack.o obj/commands/CommandManager.o obj/commands/Keyboard.o obj/effects/Effect.o obj/effects/SimpleMono.o obj/effects/TwoPassSimpleMono.o obj/effects/SimplePairedTwoTrack.o obj/effects/SoundTouchEffect.o obj/effects/LoadEffects.o obj/effects/Amplify.o obj/effects/BassBoost.o obj/effects/ChangePitch.o obj/effects/ChangeSpeed.o obj/effects/ChangeTempo.o obj/effects/ClickRemoval.o obj/effects/Compressor.o obj/effects/Echo.o obj/effects/Equalization.o obj/effects/Fade.o obj/effects/Filter.o obj/effects/Invert.o obj/effects/Noise.o obj/effects/NoiseRemoval.o obj/effects/Normalize.o obj/effects/Phaser.o obj/effects/Repeat.o obj/effects/Reverse.o obj/effects/Silence.o obj/effects/ToneGen.o obj/effects/Wahwah.o obj/export/Export.o obj/export/ExportMultiple.o obj/export/ExportMP3.o obj/export/ExportOGG.o obj/export/ExportPCM.o obj/export/ExportCL.o obj/import/Import.o obj/import/ImportLOF.o obj/import/ImportMIDI.o obj/import/ImportMP3.o obj/import/ImportOGG.o obj/import/ImportPCM.o obj/import/ImportRaw.o obj/import/RawAudioGuess.o obj/prefs/PrefsDialog.o obj/prefs/AudioIOPrefs.o obj/prefs/QualityPrefs.o obj/prefs/FileFormatPrefs.o obj/prefs/DirectoriesPrefs.o obj/prefs/GUIPrefs.o obj/prefs/KeyConfigPrefs.o obj/prefs/MousePrefs.o obj/prefs/SpectrumPrefs.o obj/widgets/AButton.o obj/widgets/ASlider.o obj/widgets/Meter.o obj/widgets/Ruler.o obj/widgets/Warning.o obj/xml/XMLFileReader.o obj/xml/XMLTagHandler.o  obj/effects/nyquist/Nyquist.o obj/effects/nyquist/LoadNyquist.o obj/effects/ladspa/LoadLadspa.o obj/effects/ladspa/LadspaEffect.o ../lib-src/expat/expat.a ../lib-src/allegro/allegro.a ../lib-src/soundtouch/source/SoundTouch/.libs/libSoundTouch.a ../lib-src/libnyquist/libnyquist.a ../lib-src/libresample/libresample.a ../lib-src/portaudio/pa_unix_oss/portaudio.a ../lib-src/portmixer/px_unix_oss/portmixer.a libaudacity.a -lsndfile -lmad -lvorbisenc -lvorbisfile -lvorbis -logg -lid3tag  -pthread    -lwx_gtk2-2.4  -lpangox-1.0
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libwx_gtk2-2.4.so: undefined reference to `vtable for wxFileProto'
collect2: ld a retourné 1 code d'état d'exécution
make[1]: *** [../audacity] Erreur 1
make[1]: Leaving directory `/var/tmp/portage/audacity-1.2.4b-r1/work/audacity-src-1.2.4b/src'
make: *** [audacity] Erreur 2

!!! ERROR: media-sound/audacity-1.2.4b-r1 failed.
Call stack:
  ebuild.sh, line 1525:   Called dyn_compile
  ebuild.sh, line 928:   Called src_compile
  audacity-1.2.4b-r1.ebuild, line 54:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.


Mon make.conf :
Code:
# These settings were set by the catalyst build script
#that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example

CFLAGS="-march=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

USE="gtk gnome qt -kde dvd dvdread alsa cdr XvMCNVIDIA java mozilla browserplugin win32codecs divx4linux apache2 mysql pam ssl xml xml2 kerberos acl cups ldap pam readline python oav usb lm_sensors X -doc ppds lirc nls dri motif matroska real xvid quinnstorm"

ALSA_CARDS="emu10k1"

LIRC_OPTS="--with-driver=serial"

LINGUAS="fr fr_FR"

PORTDIR_OVERLAY="/usr/local/portage /usr/local/xgl-coffee"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR=/usr/portage
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
PORT_LOGDIR="/var/log/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
RSYNC_RETIRES="5"
RSYNC_TIMEOUT="120"
PORTAGE_NICENESS="-3"
AUTOCLEAN="yes"
CCACHE_SIZE="5G"
GENTOO_MIRRORS="http://mir.zyrianes.net/gentoo/"

INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nvidia"
PORT_ENOTICE_DIR=/var/enotice


Des idées ?

Merci d'avance.


Last edited by SnowBear on Wed Apr 19, 2006 7:07 am; edited 1 time in total
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Tue Apr 18, 2006 1:32 am    Post subject: Reply with quote

lut

oui , ben il semble qu'il y ai un probleme avec gcc v4 et wx-GTK.
il y a des indications ici, mais cela vient de chez redhat.
Essaye avec la version 2.6 de wxGTK.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Tue Apr 18, 2006 6:32 am    Post subject: Reply with quote

Salut,
je viens de regarder et j'ai la dernière version stable de wxGTK (2.6.2-r1).
Je passe à la testing 2.6.3.2 pour voir si ça change quelque chose ;)
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Tue Apr 18, 2006 9:44 am    Post subject: Reply with quote

Salut,
je viens d'essayer et le problème est toujours le même :s
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Tue Apr 18, 2006 10:08 am    Post subject: Reply with quote

tu dois avoir un soucis avec les versions car
Code:
libwx_gtk2-2.4.so

ne correspond pas a une version 2.6 mais 2.4.
Peut-etre est-ce le temps d'un revdep-rebuild, verifie les options de ce dernier , il me semble qu'il y a une option pour preciser les librairies.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Tue Apr 18, 2006 10:13 am    Post subject: Reply with quote

bonne remarque :oops:

Je regarde le revdep-rebuild de plus prés ;)
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Tue Apr 18, 2006 11:03 am    Post subject: Reply with quote

regardes sur bugzilla: il y a pas mal de d'ebuild avec des patch pour corriger les problèmes d'audacity (notament les problèmes causés par wxgtk-2.6): paf
_________________
Reality is that which, when you stop believing in it, doesn't go away.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Tue Apr 18, 2006 1:23 pm    Post subject: Reply with quote

Salut,
tout d'abord merci à vous 2 de m'aider ;) .

Donc pour le revdep-rebuild je dois avoir du mal, j'ai fait : revdep-rebuild -X wxGTK puis emerge audacity et j'ai toujours la même erreur avec 2.4.

En ce qui concerne bugzilla je ne comprends pas comment ça fonctionne ni ce que je dois faire, j'ai bien vu des patchs mais je ne sais pas m'en servir :s
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Tue Apr 18, 2006 2:11 pm    Post subject: Reply with quote

Bon, déjà repasses à wxGTK-2.4 car les version 1.2* d'aucity ne mercheront qu'avec wxgtk-2.4.

Ensuite, dans la page du bug 110809 il y a un patch nommé "audacity-1.2.4b-compilefix.patch" qui pourrait correspondre à ton problème. Pour l'appliquer, voici la marche à suivre:

  • copies l'ebuild audacity-1.2.4b-r1 dans un overlay (genre /usr/local/overlay/media-sound/audacity)
  • copie le patch dans le répertoire "files" (soit /usr/local/overlay/media-sound/audacity/files)
  • édites l'ebuild pour qu'il contienne "epatch "${FILESDIR}"/audacity-1.2.4b-compilefix.patch " (dans la partie src_unpack)
  • fais le digest de l'ebuild (commande: ebuild moncherebuild digest
  • emerges audacity en espérant que ça marche


Voilou.
Si ça ne change rien, dans cette même page il y a des ebuild pour la version 1.3_beta d'aucity qui supporte wxGTK-2.6 alors tu peux également essayer ces ebuilds.
_________________
Reality is that which, when you stop believing in it, doesn't go away.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Tue Apr 18, 2006 5:42 pm    Post subject: Reply with quote

je suis modi :D
J'ai essayé la version béta.
J'ai donc créé un fichier audacity-1.3.0b.ebuild dans /usr/portage/meadia-sound/audacity.
Là je fais : emerge -av audacity
et je tombe sur cette erreur :
Code:
>>> Emerging (1 of 1) media-sound/audacity-1.3.0b to /
>>> checking ebuild checksums
>>> checking auxfile checksums
>>> checking miscfile checksums
>>> checking distfiles checksums
Traceback (most recent call last):
  File "/usr/bin/emerge", line 3390, in ?
    mydepgraph.merge(pkglist)
  File "/usr/bin/emerge", line 2028, in merge
    retval=portage.doebuild(y,"merge",myroot,self.pkgsettings,edebug,tree="porttree")
  File "/usr/lib/portage/pym/portage.py", line 2633, in doebuild
    if not digestcheck(checkme, mysettings, ("strict" in features), (mydo not in ["digest","fetch","unpack"] and settings["PORTAGE_CALLER"] == "ebuild" and "noauto" in features)):
  File "/usr/lib/portage/pym/portage.py", line 2169, in digestcheck
    mf.checkFileHashes(mf.findFile(f), f)
  File "/usr/lib/portage/pym/portage_manifest.py", line 460, in checkFileHashes
    myhashes = self.fhashdict[ftype][fname]

J'ai raté quelque chose je suppose :D
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Wed Apr 19, 2006 2:17 am    Post subject: Reply with quote

lut

c'est pas la bonne methode , portage est aux petit soins avec ses ebuilds, il aime pas trop qu'on y touche.
Comme te l'as dit ubik , c'est dans /usr/LOCAL/portage qu'il faut le mettre ... :wink:

Pour ma part , je ne comprend pas , je viens de l'emerger du coup audacity et c'est passé comme une lettre a la poste malgé un gcc 4.1.

Code:

gentoo ryo # emerge -av audacity

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-libs/libsndfile-1.0.11  USE="-static" 796 kB
[ebuild  NS   ] x11-libs/wxGTK-2.4.2-r4  USE="gtk2 opengl unicode -debug -odbc -wxgtk1" 0 kB
[ebuild  N    ] media-sound/audacity-1.2.4b-r1  USE="encode mad vorbis" 0 kB

Total size of downloads: 796 kB

Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 723
Location: Dax [40]

PostPosted: Wed Apr 19, 2006 7:07 am    Post subject: Reply with quote

Bonjour,
en fait je suis un gros boulet :oops: , j'avais oublié de faire un digest :s .

J'ai réussi à installer la version 1.3.0b.

Merci à vous deux ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum