Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Svenska tecken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
nsg
n00b
n00b


Joined: 19 Mar 2003
Posts: 20
Location: Stockholm, Sweden

PostPosted: Wed Mar 19, 2003 7:06 pm    Post subject: Svenska tecken Reply with quote

Jag hoppas att minna svenska tecken (åöä) går att läsa, för det är mitt problem.

På webbsidor och nästan överallt så ser jag åäö utan problem, man i titlen på mozilla, i emacs när jag öppnar en fil som är formaterad i windows, så blir det bara konstiga tecken istället. Desstu större problem är det att när jag skriver i xchat så kan ingen läsa minna åäö. Antar att det är något i confugurationen som måste rättas till, men vad?

Skriver ut lite ur vissa filer som kanse kan vara intressant.

/etc/X11/XF86Config
Code:
Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"   "se"


är pc101 rätt?

/etc/rc.conf
Code:
KEYMAP="se-latin1 euro2"
CONSOLEFONT="iso01.14"
CONSOLETRANSLATION="8859-1_to_uni"
LANG="sv_SE"

_________________
// Stefan Berggren
// Gentoo on amd64
Back to top
View user's profile Send private message
jahve
n00b
n00b


Joined: 25 Aug 2002
Posts: 44
Location: Uppsala, Sweden

PostPosted: Wed Mar 19, 2003 7:32 pm    Post subject: Reply with quote

Ah, det härliga problemet med våra kära vokaler.

Jag hade liknande problem som du, tills jag ändrade lite i miljövariablerna.

Lösningen på ditt problem finns säkert redan i denna tråd,
http://forums.gentoo.org/viewtopic.php?t=17623

I det sista inlägget i den tråden (i dagsläget) kan du läsa hur jag fick min installation att fungera med åä och ö.
Back to top
View user's profile Send private message
nsg
n00b
n00b


Joined: 19 Mar 2003
Posts: 20
Location: Stockholm, Sweden

PostPosted: Thu Mar 20, 2003 5:02 pm    Post subject: tuvärr .. Reply with quote

Ingenting hjälper, fast nu funkar åäö i consol och xterm iallafall ...
Någon som har något annat jag kan pröva?
_________________
// Stefan Berggren
// Gentoo on amd64
Back to top
View user's profile Send private message
jahve
n00b
n00b


Joined: 25 Aug 2002
Posts: 44
Location: Uppsala, Sweden

PostPosted: Thu Mar 20, 2003 6:14 pm    Post subject: Re: tuvärr .. Reply with quote

nsg wrote:
Ingenting hjälper, fast nu funkar åäö i consol och xterm iallafall ...
Någon som har något annat jag kan pröva?

Om det enda som inte fungerar för dig just nu är de svenska vokalerna i fönstertitlar kan det bero på att det typsnitt som används i fönstertiteln inte stöder dessa bokstäver. Prova med att byta typsnitt.

Fungarar det i KDE, Gnome eller Fluxbox? De använder standardtypsnitt som stödjer åäö. Om det fungerar så beror det troligen bara på typsnittet.
Back to top
View user's profile Send private message
nsg
n00b
n00b


Joined: 19 Mar 2003
Posts: 20
Location: Stockholm, Sweden

PostPosted: Thu Mar 20, 2003 9:57 pm    Post subject: tack ... Reply with quote

Tack för svaret, i fönstertitlar i webbläsaren så bryr jag mig inte. Men det enda igentliga problemet som är kvar är i xchat, där jag är den enda som kan läsa minna åäö:s. Jag glömmer bort det och skriver på i irc och den stackaren som läser det får tyda vad jag skrev.
_________________
// Stefan Berggren
// Gentoo on amd64
Back to top
View user's profile Send private message
jahve
n00b
n00b


Joined: 25 Aug 2002
Posts: 44
Location: Uppsala, Sweden

PostPosted: Fri Mar 21, 2003 8:33 am    Post subject: Re: tack ... Reply with quote

nsg wrote:
Tack för svaret, i fönstertitlar i webbläsaren så bryr jag mig inte. Men det enda igentliga problemet som är kvar är i xchat, där jag är den enda som kan läsa minna åäö:s. Jag glömmer bort det och skriver på i irc och den stackaren som läser det får tyda vad jag skrev.

Detta kan vara lösningen på ditt xchat-problem:
http://forums.gentoo.org/viewtopic.php?t=15733
Back to top
View user's profile Send private message
nsg
n00b
n00b


Joined: 19 Mar 2003
Posts: 20
Location: Stockholm, Sweden

PostPosted: Fri Mar 21, 2003 10:38 pm    Post subject: hm... Reply with quote

Läste tråden men fattade inte var jag ska ändra.
_________________
// Stefan Berggren
// Gentoo on amd64
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Sat Mar 22, 2003 8:09 am    Post subject: Reply with quote

jag tanka xchat 2.0 o så funka åäö.
export lang="sv_SE" i /etc/rc.conf kan vara nåt om du inte har provat det.
Vad har du på keymap btw i rc.conf?

Kan du pasta dina keyboardinställningar i XF86Config
Back to top
View user's profile Send private message
jahve
n00b
n00b


Joined: 25 Aug 2002
Posts: 44
Location: Uppsala, Sweden

PostPosted: Sat Mar 22, 2003 9:59 am    Post subject: Reply with quote

nsg wrote:
Läste tråden men fattade inte var jag ska ändra.

Precis som ozt använder jag xchat 2 (2.0.1 faktiskt) utan problem. Du kan ju försöka pröva det, om inte annat. Kräver iofs GTK2 men det är nog ingen nackdel. :)

ozt wrote:
jag tanka xchat 2.0 o så funka åäö.
export lang="sv_SE" i /etc/rc.conf kan vara nåt om du inte har provat det.


export lang i rc.conf har jag faktiskt aldrig fått att fungera. Som vanligt har tyskarna kommit på den slutgiltiga lösningen: :?

slyzer wrote:
Hallo,

Ich habe eine 02locale Datei in /etc/env.d erstellt, die wird dann nach einem env-update automatisch zur /etc/profile.env hinzugeügt:

Code:
thomas# cat /etc/env.d/02locale
LANG="C"
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="C"
thomas#


Das sollte reichen, denn Umlaute wie äüöß kann ich tippern und die Programme sind in Englisch

cu
slyzer
http://forums.gentoo.org/viewtopic.php?t=38658

Ersätter man de_DE med sv_SE borde ju man få ett ur språksynpunkt trevligt system, efter svenska standarder men utan de relativt dåliga översättningarna.
Kanske är det dags för en ordentlig HOWTO om svenska inställningar. Verkar som rätt många råkar ut för de här problemen för eller senare.
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Sat Mar 22, 2003 10:54 am    Post subject: Reply with quote

jahve wrote:



Kanske är det dags för en ordentlig HOWTO om svenska inställningar. Verkar som rätt många råkar ut för de här problemen för eller senare.



sant..sammanställ allt i en FAQ
Back to top
View user's profile Send private message
Yarrick
Bodhisattva
Bodhisattva


Joined: 05 Jun 2002
Posts: 304
Location: Malmö, Sweden

PostPosted: Sat Mar 22, 2003 5:02 pm    Post subject: Reply with quote

http://www.gentoo.org/doc/en/guide-localization.xml
Back to top
View user's profile Send private message
nsg
n00b
n00b


Joined: 19 Mar 2003
Posts: 20
Location: Stockholm, Sweden

PostPosted: Mon Mar 24, 2003 9:35 am    Post subject: tack Reply with quote

Det löste sig, gjorde det på ett rätt fult sätt, nergraderade till xchat 1.8.10
_________________
// Stefan Berggren
// Gentoo on amd64
Back to top
View user's profile Send private message
Sacred-Eagle
n00b
n00b


Joined: 22 Mar 2003
Posts: 5

PostPosted: Mon Mar 31, 2003 9:41 am    Post subject: Svenska tecken och Mutt! Reply with quote

[snip]
export lang i rc.conf har jag faktiskt aldrig fått att fungera. Som vanligt har tyskarna kommit på den slutgiltiga lösningen: :?

[quote="slyzer"]Hallo,

Ich habe eine 02locale Datei in /etc/env.d erstellt, die wird dann nach einem env-update automatisch zur /etc/profile.env hinzugeügt:

Code:
thomas# cat /etc/env.d/02locale
LANG="C"
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="C"
thomas#

Ach, Wunderbaum!
Med hjälp av tipset ovan fick jag äntligen svenska tecken (istället för frågetecken) att visas i Mutt...:-)
Annars har jag inga andra problem med fonterna. Jag håller dock med att det behövs en del till när det gäller fonter i Linux. Det finns inte många Linux distar där man slipper koda för hand för att svenska tecken skall fungera globalt utan tjafs.

Tuus,
Helgi Örn


Edit: Tog bort dubbelpost /Yarrick
Back to top
View user's profile Send private message
Poosha
n00b
n00b


Joined: 09 Mar 2003
Posts: 7
Location: Sweden

PostPosted: Wed May 14, 2003 3:23 pm    Post subject: Reply with quote

slyzer wrote:
Hallo,

Ich habe eine 02locale Datei in /etc/env.d erstellt, die wird dann nach einem env-update automatisch zur /etc/profile.env hinzugeügt:

Code:
thomas# cat /etc/env.d/02locale
LANG="C"
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="C"
thomas#

Das sollte reichen, denn Umlaute wie äüöß kann ich tippern und die Programme sind in Englisch

cu
slyzer


det verkar ju smidigt :) vad betyder LANG="C"?
Back to top
View user's profile Send private message
trinity_
n00b
n00b


Joined: 15 May 2003
Posts: 1
Location: Sweden

PostPosted: Thu May 15, 2003 6:31 pm    Post subject: Reply with quote

Har liknande problem med svenska tecken i xchat2. Dock så visas tecknen snyggt och prydligt på min skärm men dyker upp som skräp på andras. Hur kommer det sig?
Back to top
View user's profile Send private message
Sputnik
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2003
Posts: 84

PostPosted: Mon May 19, 2003 8:00 pm    Post subject: Reply with quote

Ok vet inte om de är rätt avdeling men jag får inte Alt Gr och ctrl att funka som de ska..
Har dock åäö men kan inte göra @ osv. vilket är mycket iriterande.. lika så hittar inte fluxkeys på Alt Gr och ctrl. :cry:

Glömde nästan home och end funkar i min vanliga användare men inte i root..
Back to top
View user's profile Send private message
Yyrkoon
n00b
n00b


Joined: 23 May 2003
Posts: 22

PostPosted: Tue Jun 03, 2003 7:53 pm    Post subject: Reply with quote

I X-Chat 2 måste du ställa in teckenkodning manuellt, den kör på UTF-8 som standard nämligen.

Gå in på Serverlista sen i Redigeringsläge och välj iso-8859-1 där så får du svenska tecken som alla kan se korrekt.


david
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum