Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Avidemux-2.1.0-r1 ebuild (testing!)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 15, 2006 1:21 pm    Post subject: Avidemux-2.1.0-r1 ebuild (testing!) Reply with quote

There are some great improvements in the latest avidemux release, but is "unconfirmed" that there are also
some drawback (first of all, someone claimed WMP10 incompatibility, I wonder if they tried to change fourcc with my AviUtils....)
Also, 2.1.0 introduces the dependancy by spidermonkey (java scripting language)


Plus there are some things to adjust (currently spidermonkey installs is includes in /usr/lib/mozilla-firefox/include/js and
avidemux get them from there.....)

However, I found a way to modify current ebuilds to compile (at least in ~x86, please test ~amd64 and ~ppc) and run.
here are the two ebuilds (for TESTING PURPOSE):

you can start to download at http://bugs.gentoo.org/show_bug.cgi?id=115229,
you will need some files:


1) new /usr/local/portage/dev-lang/spidermonkey-1.5.ebuild
( needed dependancy.... ebuild spidermonkey-1.5.ebuild digest)

2+3) /usr/local/portage/media-video/avidemux/avidemux-2.1.0-r1.ebuild and
/usr/local/portage/media-video/avidemux/files/avidemux-avifix.patch
(main files, after having both in place: ebuild avidemux-2.1.0-r1.ebuild digest)

4+5 optional) /usr/local/portage/media-libs/x264-svn/files/x264-svn-sobuild.patch and
/usr/local/portage/media-libs/x264-svn/x264-svn-20051004-r2.ebuild
(optionals files for x264 support, that you'll find at http://bugs.gentoo.org/show_bug.cgi?id=115628
or following the previous link, you'll need x264 use flag to use, ebuild digest here too)

Enjoy! (and please report any issue or comment)
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/


Last edited by Matteo Azzali on Sun Jan 22, 2006 2:11 pm; edited 7 times in total
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sat Jan 21, 2006 12:35 pm    Post subject: Reply with quote

A new patch was released,
to fix avi compatibility of 2.1.0, I'll post new ebuild as soon as possible...
ok, ebuild added....

anyone testing now? seems that all compatibility issues are gone.... :D

OMG, sorry for this distraction, fixed "disable-warnings command not found" bug
(I loosed a slash somewhere, now I found it....)
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Jan 21, 2006 2:13 pm    Post subject: Reply with quote

woohoo! will test it!

some notes:
* please post ebuilds and patches as links (maybe put it on http://phpfi.com and one can use 'save file' to avoid c&p), because copy&paste replaces tabs with spaces --> spidermonkey ebuild fails
* the patch doesn't even work on plain source (rej on avidemux/oplug_avi/op_aviwrite.cpp), and completely fails on epatch, i had to fix and re-diff
* esd support is optional, make fails here if i don't disable it, because no esound here
* x264-svn is in portage, lets make that an option
* and it seems avidemux ebuild has an error:

Code:
checking spidermonkey engine ... using : -I/usr/lib/mozilla-firefox/include/js -DXP_UNIX : as extra flags
checking jsapi.h usability... no
checking jsapi.h presence... no
checking for jsapi.h... no
configure: error: *** SPIDERMONKEY javascript engine not found !***


the headers get installed to /usr/include/js/. so
Code:
      --with-jsapi-include=/usr/lib/mozilla-firefox/include/js \

is wrong

link to my overlay with fixed things:
http://gimpel.ath.cx/~tom/files/portage_overlay/dev-lang/spidermonkey/
http://gimpel.ath.cx/~tom/files/portage_overlay/media-video/avidemux/

note: i had to disable esd (don't want that) and sdl due to make errors

hope i could help with that test
cheers!
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
NightMonkey
Guru
Guru


Joined: 21 Mar 2003
Posts: 312
Location: Brisbane, CA

PostPosted: Sat Jan 21, 2006 9:20 pm    Post subject: Reply with quote

gimpel wrote:
woohoo! will test it!

some notes:
* please post ebuilds and patches as links (maybe put it on http://phpfi.com and one can use 'save file' to avoid c&p), because copy&paste replaces tabs with spaces --> spidermonkey ebuild fails
* the patch doesn't even work on plain source (rej on avidemux/oplug_avi/op_aviwrite.cpp), and completely fails on epatch, i had to fix and re-diff
* esd support is optional, make fails here if i don't disable it, because no esound here
* x264-svn is in portage, lets make that an option
* and it seems avidemux ebuild has an error:

Code:
checking spidermonkey engine ... using : -I/usr/lib/mozilla-firefox/include/js -DXP_UNIX : as extra flags
checking jsapi.h usability... no
checking jsapi.h presence... no
checking for jsapi.h... no
configure: error: *** SPIDERMONKEY javascript engine not found !***


the headers get installed to /usr/include/js/. so
Code:
      --with-jsapi-include=/usr/lib/mozilla-firefox/include/js \

is wrong

link to my overlay with fixed things:
http://gimpel.ath.cx/~tom/files/portage_overlay/dev-lang/spidermonkey/
http://gimpel.ath.cx/~tom/files/portage_overlay/media-video/avidemux/

note: i had to disable esd (don't want that) and sdl due to make errors

hope i could help with that test
cheers!


OK, these links now return "connection refused". Can we have these e-builds submitted in a standard fashion? In other words, in the existing bug that has been filed at http://bugs.gentoo.org/show_bug.cgi?id=115229 ? Thanks! :)
_________________
I like Linux. :D
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sun Jan 22, 2006 12:46 am    Post subject: Reply with quote

oops, sorry. forgot about apache after kernel change and hadn't added it to rc. should work now.

Matteo, go for it if you like and put them on bugs.gentoo.org.

had no time to actually test the new version, encode a video and find some dude with media player 10 :P
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 22, 2006 12:44 pm    Post subject: Reply with quote

gimpel wrote:
woohoo! will test it!

some notes:
* please post ebuilds and patches as links (maybe put it on http://phpfi.com and one can use 'save file' to avoid c&p), because copy&paste replaces tabs with spaces --> spidermonkey ebuild fails
* the patch doesn't even work on plain source (rej on avidemux/oplug_avi/op_aviwrite.cpp), and completely fails on epatch, i had to fix and re-diff
* esd support is optional, make fails here if i don't disable it, because no esound here
* x264-svn is in portage, lets make that an option


*posted in http://bugs.gentoo.org/show_bug.cgi?id=115229 , these should work for standard (unstable at least) systems.
*patch works here, I'm ebuilding it fine
*esd support is the same that was present in old ebuild, I'll try to fix as fast as I can.
*x264 seems to not work "out of the box" with this release, I'll recheck avidemux forum for better infos

For the location of jsapi.h , this ebuild is a little hack, I just noticed where my spidermonkey ebuild was putting jsapi.h and redirected avidemux
ebuild to search there. If someone knows where is the best place to have jsapi.h please help me fixing both the ebuilds.
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 22, 2006 12:58 pm    Post subject: Reply with quote

Ok, here is x264 topic I can't fix all this all alone so is better if someone else
helps me here or I'll keep the avidemux ebuild without x264, sorry.....

For the esd requirement I'm testing the fix, I'll post as soon as I find the volume patch (actually avidemux has a play-volume control that's
useless cause is bugged) to not release 200 versions.

EDIT: volume seems bugged only for alsa+dmix configurations (which need to choose "hwplug:0,0"), alsa non-dmix may
choose "hw:0" instead and volume should work. I posted the non-esd ebuild.

P.S.: incompatibility of avi isn't only with wmp, is also with totem. without the patch avifix your avi will be readable just
by mplayer cause is more robust and don't care of an header error.
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/


Last edited by Matteo Azzali on Sun Jan 22, 2006 1:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 22, 2006 1:14 pm    Post subject: Reply with quote

gimpel wrote:

the headers get installed to /usr/include/js/. so


this is the right place in which the headers should be installed? I'll try to modify my spidermonkey ebuild to accomplish this....

EDIT: modified and uploaded new ebuild (lacking only x264 support as of now, you can check why with the avidemux forum link above...)
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 22, 2006 2:04 pm    Post subject: Reply with quote

finished, x264 support is here (patching x264 ebuild with a makefile patch to build libx264.so),
you can get all at http://bugs.gentoo.org/show_bug.cgi?id=115229
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sun Jan 22, 2006 2:36 pm    Post subject: Reply with quote

Matteo Azzali wrote:
gimpel wrote:

the headers get installed to /usr/include/js/. so


this is the right place in which the headers should be installed? I'll try to modify my spidermonkey ebuild to accomplish this....

EDIT: modified and uploaded new ebuild (lacking only x264 support as of now, you can check why with the avidemux forum link above...)


hmmm, all i changed to your spidermonkey ebuild, was replacing spaces with tabs, copy&paste error. other than that i didn't change anything, and:
Code:
SiRiUS tom # epm -ql spidermonkey | grep include
/usr/include/js/js.msg
/usr/include/js/jsopcode.tbl
/usr/include/js/jsshell.msg
/usr/include/js/jsapi.h
/usr/include/js/jsarena.h
/usr/include/js/jsarray.h
/usr/include/js/jsatom.h
...etc


about x264:
good stuff! indeed the .so hadn't been built. seems to work now (just encoding a x264 file to avi)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 22, 2006 7:22 pm    Post subject: Reply with quote

gimpel wrote:

about x264:
good stuff! indeed the .so hadn't been built. seems to work now (just encoding a x264 file to avi)


I found the info on how to patch x264-svn to build libx264.so in avidemux forum, tested and (at least here)
Code:

dir /usr/lib/libx264*
/usr/lib/libx264.a  /usr/lib/libx264.so


I need some people to test these changes, cause I cant' be sure for different configuration or archs differents from ~x86.....
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sun Jan 22, 2006 8:37 pm    Post subject: Reply with quote

well, mostly ~x86 here too.

couldn't find any errors so far, beside the one you mentioned: alsa + dmix issue.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 29, 2006 10:08 am    Post subject: Reply with quote

further testing:

bugfix - hotkeys don't lose anymore functionality after some cutting of the avi (randomly happened with 2.0.42 and lavc mpeg4).

glitches - hitting enter after filling name for saved file does nothing, need to click save
----------save directory seems always to be ~ instead of the folder of the opened file

bug - none found.
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
mean
Guru
Guru


Joined: 25 Sep 2002
Posts: 313

PostPosted: Sun Jan 29, 2006 5:35 pm    Post subject: Reply with quote

There is a 2.1.1 available, if no showstopper is found it will be 2.1.1 official
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Jan 29, 2006 10:13 pm    Post subject: Reply with quote

yeow! Mean? pleased to meet a developer after having done an humble ebuild/testing,
I'm just testing 2.1.1 ebuild (by me,brute hacker, you can obviously refine it whenever you want),
some feedback in some days....

for now I can confirm the little glitches in interface, save dir is defaulted to last save dir?
(before when I opened a file from command line save dir was defaulted to that file's dir),
pressing enter after filling save file name does nothing,
volume isn't affecting my system config (alsa + dmix)
(obviously, these are all minor glitches more than bugs...)
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
mean
Guru
Guru


Joined: 25 Sep 2002
Posts: 313

PostPosted: Mon Jan 30, 2006 7:05 am    Post subject: Reply with quote

yes, last dir has 2 entries : last read dir/last write dir
For the enter stuff, maybe a bug
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Thu Dec 21, 2006 12:42 am    Post subject: Reply with quote

Hi

Is the latest version (2.x) available in portage as unstable?

Thanks
Shelton.
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Thu Dec 21, 2006 7:09 pm    Post subject: Reply with quote

the 2.3 version is out...why not making an ebuild of this version instead and adding it to portage?
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Thu Dec 21, 2006 10:15 pm    Post subject: Reply with quote

GNUtoo wrote:
the 2.3 version is out...why not making an ebuild of this version instead and adding it to portage?


unfortunately it takes time - due to all the tests etc - until it is released as stable :roll:
Back to top
View user's profile Send private message
BorgDrone2
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2006
Posts: 107

PostPosted: Thu Dec 21, 2006 10:59 pm    Post subject: Reply with quote

Nonsense! The version in portage is ancient. But don't bother the devs about that sort of thing...

This will bring in 2.3

avidemux-2.3.0.ebuild

# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils flag-o-matic subversion

MY_P=${PN}_${PV/_pre/_preview}

DESCRIPTION="Great Video editing/encoding tool"
HOMEPAGE="http://fixounet.free.fr/avidemux/"
SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="a52 aac alsa altivec arts esd mp3 nls vorbis sdl x264 xvid xv oss"

RDEPEND=">=x11-libs/gtk+-2.6
>=dev-libs/libxml2-2.6.7
>=dev-lang/spidermonkey-1.5-r2
>=media-libs/freetype-2.1.5
a52? ( >=media-libs/a52dec-0.7.4 )
aac? ( >=media-libs/faac-1.23.5
>=media-libs/faad2-2.0-r7 )
esd? ( media-sound/esound )
mp3? ( media-libs/libmad
>=media-sound/lame-3.93 )
xvid? ( >=media-libs/xvid-1.0.0 )
x264? ( >=media-libs/x264-svn-20061014 )
nls? ( >=sys-devel/gettext-0.12.1 )
vorbis? ( >=media-libs/libvorbis-1.0.1 )
arts? ( >=kde-base/arts-1.2.3 )
alsa? ( >=media-libs/alsa-lib-1.0.9 )
sdl? ( media-libs/libsdl )
|| ( (
xv? ( x11-libs/libXv )
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
) virtual/x11 )"

DEPEND="$RDEPEND
|| ( (
x11-base/xorg-server
x11-libs/libXt
x11-proto/xextproto
) virtual/x11 )
dev-util/pkgconfig
>=sys-devel/autoconf-2.58
>=sys-devel/automake-1.8.3"

S="${WORKDIR}/${MY_P}"

pkg_setup() {
filter-flags "-fno-default-inline"
filter-flags "-funroll-loops"
filter-flags "-funroll-all-loops"
filter-flags "-fforce-addr"

if ! built_with_use dev-lang/spidermonkey threadsafe ; then
eerror "dev-lang/spidermonkey is missing threadsafe support, please"
eerror "make sure you enable the threadsafe USE flag and re-emerge"
eerror "dev-lang/spidermonkey - this Avidemux build will not compile"
eerror "nor work without it!"
die "dev-lang/spidermonkey needs threadsafe support"
fi

if ! ( use oss || use arts || use alsa ); then
die "You must select at least one between oss, arts and alsa audio output."
fi
}

src_unpack() {
unpack ${A}
cd ${S} || die

epatch ${FILESDIR}/remove-auto-deps.patch
epatch ${FILESDIR}/dts-internal.patch
sed -i -e 's/x264=no,-lm/x264=no,-lm -lX11/' configure.in.in || die "sed failed."

gmake -f Makefile.dist || die "autotools failed."
}

src_compile() {
econf \
$(use_enable nls) \
$(use_enable altivec) \
$(use_enable xv) \
$(use_with arts) \
$(use_with alsa) \
$(use_with esd) \
$(use_with oss) \
$(use_with vorbis) \
$(use_with a52 a52dec) \
$(use_with sdl libsdl) \
$(use_with aac faac) $(use_with aac faad2) \
$(use_with xvid) \
$(use_with x264) \
$(use_with mp3 lame) $(use_with mp3 libmad) \
--with-newfaad --with-freetype2 --with-jsapi-include=/usr/include/js \
--disable-warnings --disable-dependency-tracking \
${myconf} || die "configure failed"
emake -j1 || die "emake failed"
}

src_install() {
# removed until we figure out why it's broke
# make DESTDIR=${D} install || die "make install failed"
dobin avidemux/avidemux2
dodoc AUTHORS ChangeLog History README TODO
insinto /usr/share/pixmaps
newins ${S}/avidemux_icon.png avidemux.png
make_desktop_entry avidemux2 "Avidemux2" avidemux.png
}

pkg_postinst() {
if use ppc && use oss; then
echo
einfo "OSS sound output may not work on ppc"
einfo "If your hear only static noise, try"
einfo "changing the sound device to ALSA or arts"
fi
}
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Thu Dec 21, 2006 11:25 pm    Post subject: Reply with quote

HI
thanks for that - but what do I need to do with that ebuild?

Do I copy and paste it somewhere and how do I run it?

Shelton.
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Fri Dec 22, 2006 3:29 pm    Post subject: Reply with quote

shazam75 wrote:
GNUtoo wrote:
the 2.3 version is out...why not making an ebuild of this version instead and adding it to portage?


unfortunately it takes time - due to all the tests etc - until it is released as stable :roll:

i don't want it as stable...i only need an ebuild in order to install this version and if it's in portage it would be great for a lot of peolpe if it's only in the ~ branch
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Fri Dec 22, 2006 3:30 pm    Post subject: Reply with quote

BorgDrone2 wrote:
Nonsense! The version in portage is ancient. But don't bother the devs about that sort of thing...

This will bring in 2.3

avidemux-2.3.0.ebuild


thanks a lot
why not sending this ebuild to bugzilla for it's integration in portage
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Fri Dec 22, 2006 3:40 pm    Post subject: Reply with quote

shazam75 wrote:
HI
thanks for that - but what do I need to do with that ebuild?

Do I copy and paste it somewhere and how do I run it?

Shelton.

create an overlay somewhere
mkdir /usr/overlay
add PORTDIR_OVERLAY="/usr/overlay" to your /etc/make.conf
create /usr/overlay/media-video/
create /usr/overlay/media-video/avidemux
copy the ebuild in avidemux name it
go into the avidemux folder
name the ebuild avidemux-2.3.0.ebuild
run the folowing command
ebuild avidemux-2.3.0.ebuild digest
then proceed as normal:
echo ~media-video/avidemux-2.3.0>>/etc/portage/package.keywords
USE="threadsafe" emerge -av avidemux
but it won't work because it needs a patch


Last edited by GNUtoo on Fri Dec 22, 2006 3:47 pm; edited 3 times in total
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Fri Dec 22, 2006 3:41 pm    Post subject: Reply with quote

BorgDrone2 wrote:

epatch ${FILESDIR}/remove-auto-deps.patch
epatch ${FILESDIR}/dts-internal.patch

}

where can i find the patch?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum