Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cross compiling xorg for ARM imake cannot execute binary
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
raphaelb
n00b
n00b


Joined: 06 Oct 2005
Posts: 6

PostPosted: Thu Jan 12, 2006 7:19 pm    Post subject: cross compiling xorg for ARM imake cannot execute binary Reply with quote

Hello Folks, I've just started trying to cross compile xorg for an ARM machine, and am getting trouble with this:

./config/imake/imake: ./config/imake/imake: cannot execute binary file
command I used was:

ROOT=/opt/cross CHOST=arm-unknown-linux-gnu USE="cross arm" emerge xorg-x11 --nodeps

Any suggestions on what to look at?
Thanks much
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31976
Location: 56N 3W

PostPosted: Thu Jan 12, 2006 8:34 pm    Post subject: Reply with quote

raphaelb,

Code:
CHOST=arm-unknown-linux-gnu
is certainly wrong. That says you are compining on an arm system.
Code:
USE="cross arm"
looks a bit strange too. That would set two USE flags, 'cross' and 'arm'. I don't think they exist.

Your first step is to aquire a cross compiler tool chain. There are many ways of doing that.
Code:
emerge  sys-devel/crossdev-0.9.10
will provide a tools with which to generate cross compiler toolchains for many crosses. I don't know if the one you want is there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
raphaelb
n00b
n00b


Joined: 06 Oct 2005
Posts: 6

PostPosted: Thu Jan 12, 2006 8:44 pm    Post subject: Reply with quote

Thank you for your reply.

the CHOST=arm-unknown-linux-gnu is what I've been using for cross compiling,
I should have also mentioned I have CBUILD set in make.conf to x86

I built my cross toolchain with crossdev, and have compiled several things (including even tougher compiles like glibc) for arm with this method.
Sometimes it seems to get confused, and as far as I can tell, what is happening is that it compiles imake for arm, then trys to run it on this machine, which is an x86 machine.

Any ideas?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum