Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200601-03 ] HylaFAX: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Fri Jan 06, 2006 2:26 pm    Post subject: [ GLSA 200601-03 ] HylaFAX: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: HylaFAX: Multiple vulnerabilities (GLSA 200601-03)
Severity: high
Exploitable: remote
Date: January 06, 2006
Bug(s): #116389
ID: 200601-03

Synopsis

HylaFAX is vulnerable to arbitrary code execution and unauthorized access vulnerabilities.

Background

HylaFAX is an enterprise-class system for sending and receiving facsimile messages and for sending alpha-numeric pages.

Affected Packages

Package: net-misc/hylafax
Vulnerable: < 4.2.3-r1
Unaffected: >= 4.2.3-r1
Architectures: All supported architectures


Description

Patrice Fournier discovered that HylaFAX runs the notify script on untrusted user input. Furthermore, users can log in without a password when HylaFAX is installed with the pam USE-flag disabled.

Impact

An attacker could exploit the input validation vulnerability to run arbitrary code as the user running HylaFAX, which is usually uucp. The password vulnerability could be exploited to log in without proper user credentials.

Workaround

There is no known workaround at this time.

Resolution

All HylaFAX users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/hylafax-4.2.3-r1"


References

CVE-2005-3538
CVE-2005-3539
HylaFAX release announcement


Last edited by GLSA on Sun May 07, 2006 4:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum