Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EBUILDS+HOWTO: installation of Catalyst Framework 5.80029
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Apr 13, 2006 10:56 am    Post subject: Reply with quote

Hello!

OK, 5.66-r5 is out with the Catalyst::Enzyme module included. It's not in the meta-packages (as most people won't need it probably), so install it just do:

Code:

emerge -av Catalyst-Enzyme


which will pull in its dependencies as well.

Here's the changelog:

Code:

New ebuilds:
------------
Catalyst-Enzyme: 0.11
Class-DBI-AsForm : 2.42
Class-DBI-Plugin-Type: 0.02
Catalyst-View-TT-ControllerLocal: 0.02
Class-DBI-FromForm: 0.04
Class-DBI-Pager: 0.08


Let me know how it works!

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Thu Apr 13, 2006 1:49 pm    Post subject: Reply with quote

LordArthas wrote:
I wrote something regarding the IDE in a previous post. ;) Anyway, what I'm using is vim and gedit. I like vim much more, but it doesn't feature tabs so I choose gedit quite often.

If you're using KDE you should try kate, which is very nice. I use Gnome, and I hate how KDE apps look into Gnome. ;-)


I use openbox, so KDE apps are kinda heavy :P I used vim + gedit too!! love vim, but love the gedit tabs too!! But now I'm trying to get used to vim 7, since it supports tabs too, both in text mode and on GUI! I was just asking if there was better alternatives..

Thanks for your help and keep the good work :)
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Apr 13, 2006 4:55 pm    Post subject: Reply with quote

Hello!

krani1 wrote:
But now I'm trying to get used to vim 7, since it supports tabs too, both in text mode and on GUI! I was just asking if there was better alternatives..


vim 7.0 tabs still seem to have some problems. I.e. take a look at this screenshot where I opened 5 tabs:

http://www.varlogarthas.net/images/vim_7_beta.png

As you can see, only 3 of the 5 tabs are shown (and the latter two have the whole path instead of the filename). Moreover, the 3rd is truncated.

OK, it's a beta. ;-)

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Sat Apr 15, 2006 4:36 pm    Post subject: Reply with quote

I got a problem with Catalyst-Plugin-XMLRPC

Code:
>>> emerge (1 of 2) dev-perl/Catalyst-Plugin-XMLRPC-1.0 to /
>>> md5 files   ;-) Catalyst-Plugin-XMLRPC-1.0.ebuild
>>> md5 files   ;-) Catalyst-Plugin-XMLRPC-0.06.ebuild
>>> md5 files   ;-) files/digest-Catalyst-Plugin-XMLRPC-1.0
>>> md5 files   ;-) files/digest-Catalyst-Plugin-XMLRPC-0.06
>>> md5 src_uri ;-) Catalyst-Plugin-XMLRPC-1.0.tar.gz
>>> Unpacking source...
>>> Unpacking Catalyst-Plugin-XMLRPC-1.0.tar.gz to /mnt/backup/var/tmp/portage/Catalyst-Plugin-XMLRPC-1.0/work
>>> Source unpacked.
 * Using ExtUtils::MakeMaker
Cannot determine perl version info from lib/Catalyst/Plugin/XMLRPC.pm
*** Module::AutoInstall version 1.02
*** Checking for Perl dependencies...
[Core Features]
- Catalyst ...missing. (would need 5.64)
- RPC::XML ...loaded. (1.35)
==> Auto-install the 1 mandatory module(s) from CPAN? [y] y
ACCESS DENIED  open_wr:   /usr/lib/perl5/5.8.7/CPAN/Config.pm
Cannot open >/usr/lib/perl5/5.8.7/CPAN/Config.pm at /usr/lib/perl5/5.8.7/CPAN/HandleConfig.pm line 231
        CPAN::HandleConfig::_configpmtest('/usr/lib/perl5/5.8.7/CPAN', '/usr/lib/perl5/5.8.7/CPAN/Config.pm') called at /usr/lib/perl5/5.8.7/CPAN/HandleConfig.pm line 266
        CPAN::HandleConfig::load('CPAN::HandleConfig') called at inc/Module/AutoInstall.pm line 623
        Module::AutoInstall::_load_cpan() called at inc/Module/AutoInstall.pm line 239
        Module::AutoInstall::_check_lock() called at inc/Module/AutoInstall.pm line 216
        Module::AutoInstall::import('Module::AutoInstall', '-core', 'ARRAY(0x835da6c)') called at inc/Module/Install/AutoInstall.pm line 36
        Module::Install::AutoInstall::auto_install('undef') called at Makefile.PL line 9
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-dev-perl_-_Catalyst-Plugin-XMLRPC-1.0-30882.log"

open_wr:   /usr/lib/perl5/5.8.7/CPAN/Config.pm
--------------------------------------------------------------------------------


is that bad?? It says Catalyst is missing but:

Code:
server ~ # emerge -s catalystframework
Searching...                    m   
[ Results for search key : catalystframework ]
[ Applications found : 2 ]
 
*  dev-perl/catalystframework
      Latest version available: 5.66
      Latest version installed: 5.66
      Size of downloaded files: 0 kB
      Homepage:    http://www.catalystframework.org/
      Description: Meta package for Catalyst - The Elegant MVC Web Application Framework, and all the plugins you need to get started
      License:     || ( Artistic GPL-2 )

*  dev-perl/catalystframework-extras
      Latest version available: 5.66-r2
      Latest version installed: 5.66-r2
      Size of downloaded files: 0 kB
      Homepage:    http://www.catalystframework.org/
      Description: Meta package for catalystframework and many useful plugins
      License:     || ( Artistic GPL-2 )


any hint? my catalyst app's are working great
Back to top
View user's profile Send private message
gerene
n00b
n00b


Joined: 18 Oct 2005
Posts: 37
Location: Belgium

PostPosted: Sun Apr 16, 2006 7:07 am    Post subject: Reply with quote

LordArthas wrote:
Hello!

OK, 5.66-r5 is out with the Catalyst::Enzyme module included. It's not in the meta-packages (as most people won't need it probably), so install it just do:

Code:

emerge -av Catalyst-Enzyme


which will pull in its dependencies as well.

Here's the changelog:

Code:

New ebuilds:
------------
Catalyst-Enzyme: 0.11
Class-DBI-AsForm : 2.42
Class-DBI-Plugin-Type: 0.02
Catalyst-View-TT-ControllerLocal: 0.02
Class-DBI-FromForm: 0.04
Class-DBI-Pager: 0.08


Let me know how it works!

Michele.


Thank you for the effort, but unfortunately, I could not get it to work and finally gave up on it. I guess the problem is that I have a DBIC based model and tried to create CDBI models for Enzyme, thereby confusing the whole system. :?
Anyhow, it did not live up to expectation and I decided to use HTML::Widget to create my own widgets. I have to tweak them anyhow.
Thanks again.
_________________
Jan Gerene
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Apr 16, 2006 9:53 am    Post subject: Reply with quote

Hello!

gerene wrote:
Thank you for the effort, but unfortunately, I could not get it to work and finally gave up on it. I guess the problem is that I have a DBIC based model and tried to create CDBI models for Enzyme, thereby confusing the whole system. :?
Anyhow, it did not live up to expectation and I decided to use HTML::Widget to create my own widgets. I have to tweak them anyhow.
Thanks again.


Yeah, I've never used it either because of Class:DBI. Since DBIx::Class is (in my opinion) far superior, I decided to stick with it and leave Class::DBI aside.

Anyhow, the Catalyst::Enzyme ebuild is now there, so maybe come other Class::DBI folks will use it. ;-) And myabe it'll get ported to DBIx::Class soon or after.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Apr 16, 2006 10:05 am    Post subject: Reply with quote

Hello!

krani1 wrote:
I got a problem with Catalyst-Plugin-XMLRPC


That's quite weird, it seems like although your packages are correctly installed (including Catalyst), you miss some Catalyst-realted files. Maybe a re-emersion of Catalyst could help:

Code:

emerge -av --oneshot Catalyst


and then try re-emerging the whole thing including XMLRPC plugin:

Code:

emerge -uDav catalystframework


Let me know if problems persist.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Sun Apr 16, 2006 10:30 am    Post subject: Reply with quote

Hello!

Did what you told me to do, and the problem persists :( Luckly I don't use XMLRPC (for now I think), so it's not a big problem.. Don't bother too much...
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Tue Apr 18, 2006 3:48 pm    Post subject: Reply with quote

Hello!

krani1 wrote:
Did what you told me to do, and the problem persists :( Luckly I don't use XMLRPC (for now I think), so it's not a big problem.. Don't bother too much...


This is quite strange, as there seems to be a problem with where you installed modules are being looked for. I think on most system it works (including mines). Oh well, we'll dig into that when there's need. ;-)

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
gerene
n00b
n00b


Joined: 18 Oct 2005
Posts: 37
Location: Belgium

PostPosted: Tue Apr 18, 2006 3:58 pm    Post subject: Reply with quote

Hello,

I found that following packages are not installed with the catalystframework:

Catalyst::Plugin::Message
Catalyst::Plugin::Dumper

is this correct?

I installed them with g-cpan.
_________________
Jan Gerene
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed Apr 19, 2006 8:09 am    Post subject: Reply with quote

Hello!

gerene wrote:
I found that following packages are not installed with the catalystframework:

Catalyst::Plugin::Message
Catalyst::Plugin::Dumper

is this correct?


It is correct, as they're not in Task::Catalyst. However, I just added them to the ebuilds and made the news catalystframework-extras depend on them. So, when you install the extras you get them, or you can emerge them one-by-one.

At present time these new ebuilds are in SVN repository only, I'll release a new package in a few days.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Apr 23, 2006 11:44 am    Post subject: Reply with quote

And here we are with 5.66-r6.

CHANGES:

Code:

New ebuilds:
------------
Catalyst-Plugin-Dumper: 0.000002
Catalyst-Plugin-Message: 0.03

Updated ebuilds:
----------------
Catalyst-Plugin-Authentication-Store-DBIC: 0.06 [ 0.05002 ]
Email-Send: 2.05 [ 2.04 ]
Test-MockObject: 1.06 [ 1.05 ]
Test-Deep: 0.095 [ 0.094 ]
DBIx-Class: 0.06002 [0.06001]
catalystframework-extras: 5.66-r3 [5.66-r2]
Catalyst-Model-DBIC: 0.14 [ 0.13 ]
Test-WWW-Mechanize-Catalyst: 0.36 [ 0.35 ]
File-Copy-Recursive: 0.20 [ 0.19 ]
Module-ScanDeps: 0.58 [ 0.57 ]


The 2 new ebuilds get pulled in by catalystframework-extras.

Michele.

P.S.: On a side note, I just fetched (iTunes Music Store still hasn't got it, so I guess I'll have to wait a couple of days to be... lawful) the latest work of Bruce Springsteen (We Shall Overcome - The Seeger Sessions). I think it's just astonishing, I recommend it everybody!
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Mon Apr 24, 2006 8:34 am    Post subject: Reply with quote

i see you're already working on 5.67 :D
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon Apr 24, 2006 10:22 am    Post subject: Reply with quote

Ela!

krani1 wrote:
i see you're already working on 5.67 :D


And here we are... ;-) I also added the Catalyst::Plugin::UploadProgress module (gets installed with catalystframework-extras).

CHANGES:

Code:

New ebuilds:
------------
Catalyst-Plugin-UploadProgress: 0.02

Updated ebuilds:
----------------
catalystframework-extras: 5.67 [5.66-r3]
catalystframework: 5.67 [5.66]
Catalyst: 5.67 [ 5.66 ]
Data-Visitor: 0.05 [ 0.04 ]
FormValidator-Simple: 0.15 [ 0.14 ]


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Apr 27, 2006 2:37 pm    Post subject: Reply with quote

Hello!

5.682 is out, and the ebuilds as well. ;-)

Code:

Updated ebuilds:
----------------
catalystframework-extras: 5.682
catalystframework: 5.682
Catalyst: 5.682
HTML-Widget: 1.07
File-Copy-Recursive: 0.21
Task-Catalyst: 1.90
Catalyst-Model-DBIC-Schema: 0.13


as usual, see first message of the thread for download info.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed May 03, 2006 10:23 am    Post subject: Reply with quote

Hello!

krani1 wrote:
Did what you told me to do, and the problem persists :( Luckly I don't use XMLRPC (for now I think), so it's not a big problem.. Don't bother too much...


I finally discovered the bug. It should be fixed now (in SVN; for the packaged ebuilds, wait next release).

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed May 03, 2006 7:04 pm    Post subject: Reply with quote

Hello!

Version 5.6901 is out...

CHANGES:

Code:

- Fixed a bug in Catalyst-Plugin-XMLRPC: a "skipdeps" was needed. ;)

Updated ebuilds:
----------------
catalystframework-extras: 5.6900
catalystframework: 5.6900
Catalyst: 5.6900
Module-ScanDeps: 0.59
Module-Install: 0.62
Catalyst-Plugin-DefaultEnd: 0.06
Catalyst-Plugin-XMLRPC: 1.0-r1

New ebuilds:
------------
Catalyst-Plugin-Static-Simple: 0.14
Catalyst-Plugin-MortalForward: 0.01


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun May 07, 2006 12:18 pm    Post subject: Reply with quote

5.6902 is out. First of all, I got rid of the Catalyst-Plugin-Static-Simple ebuild I added by mistake some versions ago (the module is Catalyst Core). So, you should uninstall it:

Code:

emerge -C Catalyst-Plugin-Static-Simple


Sorry for this, sometimes I'm a bit too lame. ;-)

So, the changes...

Code:

Deleted ebuilds:
----------------
Catalyst-Plugin-Static-Simple (it's core)

Updated ebuilds:
----------------
catalystframework-extras: 5.6902
catalystframework: 5.6902
Catalyst: 5.6902


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Sun May 07, 2006 11:15 pm    Post subject: Reply with quote

hi :)

compiling dev-perl/PAR gives me problems:

Code:
make[1]: Entering directory `/mnt/backup/var/tmp/portage/PAR-0.92/work/PAR-0.92/myldr'
/usr/bin/perl5.8.7 sha1.c.PL sha1.c
i686-pc-linux-gnu-gcc -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I/usr/lib/perl5/5.8.7/i686-linux-thread-multi/CORE  sha1.c
/usr/bin/perl5.8.7 ./file2c.pl /usr/lib/libperl.so.1 my_perl.c load_me_0 0 30000
i686-pc-linux-gnu-gcc -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I/usr/lib/perl5/5.8.7/i686-linux-thread-multi/CORE  main.c
In file included from main.c:4:
perlxsi.c: In function `xs_init':
perlxsi.c:30: warning: passing arg 3 of `Perl_newXS' from incompatible pointer type
In file included from main.c:57:
internals.c: In function `par_xs_init':
internals.c:109: error: too many arguments to function `xs_init'
make[1]: *** [main.o] Error 1
make[1]: Leaving directory `/mnt/backup/var/tmp/portage/PAR-0.92/work/PAR-0.92/myldr'
make: *** [subdirs] Error 2

!!! ERROR: dev-perl/PAR-0.92 failed.
Call stack:
  ebuild.sh, line 1525:   Called dyn_compile
  ebuild.sh, line 928:   Called src_compile
  ebuild.sh, line 1237:   Called perl-module_src_compile
  perl-module.eclass, line 121:   Called die

!!! compilation failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


any hint?
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon May 08, 2006 5:04 pm    Post subject: Reply with quote

Hello!

krani1 wrote:
hi :)
compiling dev-perl/PAR gives me problems:


Mmm, it compiles with no problem on both my systems (x86 and amd64). What architechture are you running on?

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Mon May 08, 2006 5:58 pm    Post subject: Reply with quote

I'm runnig on x86 too.. and this problem happens with latest mod_perl too... maybe I will fill a bug report :)
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon May 08, 2006 6:47 pm    Post subject: Reply with quote

krani1 wrote:
I'm runnig on x86 too.. and this problem happens with latest mod_perl too... maybe I will fill a bug report :)


Oh, so it's not PAR-related maybe... ;)

By the way, the Catalyst ebuilds repository has now been added to the layman official list of Portage overlays. So now it's even simpler to install and keep updated.

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
krani1
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Mon May 08, 2006 6:51 pm    Post subject: Reply with quote

can you please update your howto or give here instructions of how to use your ebuilds with layman please? TIA
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon May 08, 2006 6:54 pm    Post subject: Reply with quote

Hello!

krani1 wrote:
can you please update your howto or give here instructions of how to use your ebuilds with layman please? TIA


I'll update my Howto later on or tomorrow, I'm working on that. In the meanwhile you can take a look at this:

http://gentoo-wiki.com/Portage_Overlay_Listing

which has a section on the usage of layman. It's quite handy, as it gets packages from the svn repository, so you always get the latest versions as soon as I create the ebuilds.

Let me know if it works well. ;-)

Thanks,
Michele.

Edit: I updated the HOWTO.

Edit 2: Now we have also gensync support, the HOWTO has been update to reflect that.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu May 25, 2006 10:54 pm    Post subject: Reply with quote

New release of the package, for the ones not using layman/svn/gensync!!!

CHANGES:

Code:

New ebuilds:
------------
Lingua-EN-Inflect-Number: 1.1
DateTime::Format::Strptime: 1.0700
Catalyst-Plugin-Images: 0.01

Updated ebuilds:
----------------
HTML-Prototype: 1.45
Class-Data-Accessor: 0.03
Module-ScanDeps: 0.60
FormValidator-Simple: 0.16
DBIx-Class-Schema-Loader: 0.03000
Object-Signature: 1.04
DBIx-Class: 0.06003
PAR: 0.93
File-Copy-Recursive: 0.22
catalystframework-extras: 5.6902-r1


Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 3 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum