Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EBUILDS+HOWTO: installation of Catalyst Framework 5.80029
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Thu Apr 15, 2010 10:53 am    Post subject: Reply with quote

Hi!

Quote:

Now dev-perl/MooseX-Types-Common-0.001001 requires update also.

I start to think, that using cpan tool is easier than maintaining extra overlay for Gentoo.


Using emerge keeps things a bit cleaner, and upgrades seem easier to do.

There are some outdated packages (mainly because there are not enough people maintianing the overlay). I'll try to bump them today so the installation should complete well.

M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Fri Apr 16, 2010 10:10 am    Post subject: Reply with quote

I'm not yet finished (bumping Task::Catalyst required a long time), but you can try the installation.

Please report success/failure.

Thanks,
M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
dmmedia
n00b
n00b


Joined: 13 Nov 2005
Posts: 7

PostPosted: Fri Apr 16, 2010 8:08 pm    Post subject: Reply with quote

LordArthas wrote:

Please report success/failure.


emerge -p Task-Catalyst
requires many x11 libraries as dependencies. I would not like to install x11 and will stick to cpan. -X and -xfree flags are in the make.conf. Thanks for your time and effort.
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sat Apr 17, 2010 8:04 am    Post subject: Reply with quote

Hi!

dmmedia wrote:

emerge -p Task-Catalyst
requires many x11 libraries as dependencies. I would not like to install x11 and will stick to cpan. -X and -xfree flags are in the make.conf. Thanks for your time and effort.


Can you please emerge -avt Task-Catalyst and see what ebuild(s) is causing the X11 stuff to be emerged? We might fix that.

Thanks,
M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
dmmedia
n00b
n00b


Joined: 13 Nov 2005
Posts: 7

PostPosted: Sun Apr 18, 2010 10:44 pm    Post subject: Reply with quote

LordArthas wrote:
Hi!

dmmedia wrote:

emerge -p Task-Catalyst
requires many x11 libraries as dependencies. I would not like to install x11 and will stick to cpan. -X and -xfree flags are in the make.conf. Thanks for your time and effort.


Can you please emerge -avt Task-Catalyst and see what ebuild(s) is causing the X11 stuff to be emerged? We might fix that.

Thanks,
M.


I guess, I copied it correctly

Code:
Calculating dependencies... done!
[ebuild  N    ] dev-perl/Task-Catalyst-4.00  10 kB [1]
[ebuild  N    ]  dev-perl/CatalystX-REPL-0.04  USE="-test" 10 kB [1]
[ebuild  N    ]   dev-perl/Carp-REPL-0.15  24 kB [1]
[ebuild  N    ]    dev-perl/Devel-REPL-1.003009  49 kB [0]
[ebuild  N    ]     dev-perl/App-Nopaste-0.19  USE="clipboard github pastebin" 30 kB [0]
[ebuild  N    ]      dev-perl/WWW-Pastebin-PastebinCom-Create-0.003  USE="-test" 9 kB [0]
... lots of deps ...
[nomerge      ] dev-perl/App-Nopaste-0.19  USE="clipboard github pastebin"  [0]
[ebuild  N    ]  dev-perl/Clipboard-0.09  15 kB [0]
[ebuild  N    ]   x11-misc/xclip-0.12  62 kB [0]
[ebuild  N    ]    x11-libs/libXmu-1.0.5  USE="ipv6 -debug" 316 kB [0]
[ebuild  N    ]     x11-libs/libXext-1.1.1  USE="-debug" 312 kB [0]
[ebuild  N    ]     x11-libs/libXt-1.0.8  USE="-static-libs" 524 kB [0]
[ebuild  N    ]      x11-libs/libX11-1.3.3  USE="ipv6 xcb -debug -doc -test" 2,116 kB [0]
[ebuild  N    ]       x11-libs/libxcb-1.5  USE="-debug -doc (-selinux)" 326 kB [0]
[ebuild  N    ]        dev-libs/libpthread-stubs-0.1  USE="-debug" 190 kB [0]
[ebuild  N    ]        x11-libs/libXdmcp-1.0.3  USE="-static-libs" 251 kB [0]
[ebuild  N    ]        x11-libs/libXau-1.0.5  USE="-static-libs" 245 kB [0]
[ebuild  N    ]        x11-proto/xcb-proto-1.6  91 kB [0]
[ebuild  N    ]       x11-proto/inputproto-2.0  137 kB [0]
[ebuild  N    ]       x11-proto/xf86bigfontproto-1.2.0  49 kB [0]
[ebuild  N    ]      x11-libs/libSM-1.1.1  USE="ipv6 uuid -debug" 257 kB [0]
[ebuild  N    ]       x11-libs/libICE-1.0.6  USE="ipv6 -debug" 273 kB [0]
[ebuild  N    ]   dev-perl/Spiffy-0.30  27 kB [0]
... even more deps...
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 903
Location: Pompano Beach, Florida

PostPosted: Mon Apr 19, 2010 3:56 am    Post subject: Reply with quote

Tested using perl 5.12.0 emerge Task-Catalyst pulled in dev-perl/Data-Alias-1.07 fails to build with dev-lang/perl-5.12.0
http://bugs.gentoo.org/show_bug.cgi?id=314933
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon Apr 19, 2010 12:36 pm    Post subject: Reply with quote

Hi!

dmmedia wrote:


I guess, I copied it correctly

Code:

..cut...
[nomerge      ] dev-perl/App-Nopaste-0.19  USE="clipboard github pastebin"  [0]
[ebuild  N    ]  dev-perl/Clipboard-0.09  15 kB [0]
[ebuild  N    ]   x11-misc/xclip-0.12  62 kB [0]
...cut...



On Unix system dev-perl/Clipboard requires xclip: My suggestion is to emerge dev-perl/App-Nopaste without the clipboard USE flag. Ie put the following in your /etc/portage/package.use:

Code:

dev-perl/App-Nopaste -clipboard


This should avoid X to be merged.

Hope this help,
M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
titanofold
Developer
Developer


Joined: 30 Dec 2003
Posts: 228
Location: Bryson City, NC USA

PostPosted: Wed Jun 09, 2010 10:32 am    Post subject: Reply with quote

Well, I gave it a shot last night. The 133rd ebuild gave me this issue:
Code:
ACCESS DENIED  rename:       /usr/lib/perl5/5.10.1/CPAN/Config.pm
commit: wrote '/usr/lib/perl5/5.10.1/CPAN/Config.pm'
*** Module::AutoInstall version 1.03
*** Checking for Perl dependencies...
[Core Features]
- ExtUtils::MakeMaker ...loaded. (6.56 >= 6.31)
- ExtUtils::Install   ...loaded. (1.54 >= 1.43)
- ExtUtils::CBuilder  ...loaded. (0.2703)
- ExtUtils::ParseXS   ...loaded. (2.2205)
- Module::Build       ...loaded. (0.3607 >= 0.28)
- CPAN                ...loaded. (1.9402 >= 1.82)
*** Module::AutoInstall configuration finished.
Checking if your kit is complete...
Looks good
Writing Makefile for local::lib
>>> Source configured.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-8329.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: rename
S: deny
P: /usr/lib/perl5/5.10.1/CPAN/Config.pm
A: /usr/lib/perl5/5.10.1/CPAN/Config.pm
R: /usr/lib/perl5/5.10.1/CPAN/Config.pm
C: perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLMAN3DIR=none DESTDIR=/var/tmp/portage/dev-perl/local-lib-1.006000/image/
--------------------------------------------------------------------------------

>>> Failed to emerge dev-perl/local-lib-1.006000, Log file:

>>>  '/var/tmp/portage/dev-perl/local-lib-1.006000/temp/build.log'


Additionally:
Code:
 * Messages for package dev-perl/Cookie-XS-0.11:

 * This ebuild is DEPRECATED and will be removed.
 * Please use CGI-Cookie-XS!!!

_________________
The best things in life are free.
Guy-1: Surely, you will fold with me...
Guy-2: Alright, but don't call me Shirley
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Tue Aug 10, 2010 10:17 am    Post subject: Reply with quote

Hello titanofold!

Sorry for the delayed reply.

The ebuild expect to find a CPAN's "Config.pm" file. The best thing would be that you creare it with the command:

Code:

cpan


Let it do all the configuration automatically. Emerging should then work.

Hope this helps!

Michele.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
davobe
n00b
n00b


Joined: 03 Oct 2003
Posts: 25

PostPosted: Mon Oct 11, 2010 9:24 pm    Post subject: Unresolved Block - emerge -v Task-Catalyst Reply with quote

Code:
.
.
[ebuild  N    ] dev-perl/CatalystX-REPL-0.04  USE="-test" 10 kB [1]
[ebuild  N    ] dev-perl/Task-Catalyst-4.00  10 kB [1]
[blocks B     ] <dev-perl/config-general-2.47 ("<dev-perl/config-general-2.47" is blocking dev-perl/Config-Any-0.20)

Total: 283 packages (5 upgrades, 277 new, 1 reinstall), Size of downloads: 53,288 kB
Conflict: 1 block (1 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/perl-experimental


Both config-general and Config-Any are pulled in as (N)ew dependencies. A solution or work-around will be most appreciated.

Regards,
davobe
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Tue Oct 12, 2010 10:42 am    Post subject: Reply with quote

Hello davobe!

You probably just need to update config-general to a version accepted by Config-Any 0.20.

So, just unmask ~arch config-general and re-emerge it: it should install version 2.49.

M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
davobe
n00b
n00b


Joined: 03 Oct 2003
Posts: 25

PostPosted: Tue Oct 12, 2010 7:12 pm    Post subject: Reply with quote

Michele,

Your suggestion to unmask ~arch config-general worked!

In the meantime I installed Task-Catalyst via CPAN. Now when use emerge I get the following:
Code:
emerge -upvDN --backtrack=30 Task-Catalyst
.
.
[ebuild  N    ] dev-perl/CatalystX-REPL-0.04  USE="-test" 10 kB [1]
[ebuild  N    ] dev-perl/Task-Catalyst-4.00  10 kB [1]

Total: 272 packages (5 upgrades, 266 new, 1 reinstall), Size of downloads: 52,775 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/perl-experimental

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  ('ebuild', '/', 'dev-lang/perl-5.10.1', 'merge') pulled in by
    ~dev-lang/perl-5.10.1 required by ('ebuild', '/', 'virtual/perl-CPAN-1.94.02', 'merge')
    (and 243 more)

  ('ebuild', '/', 'dev-lang/perl-5.12.2-r1', 'merge') pulled in by
    ~dev-lang/perl-5.12.2 required by ('installed', '/', 'virtual/perl-Module-Pluggable-3.9', 'nomerge')
    ~dev-lang/perl-5.12.2 required by ('installed', '/', 'virtual/perl-version-0.82', 'nomerge')
    ~dev-lang/perl-5.12.2 required by ('installed', '/', 'virtual/perl-Test-Harness-3.17', 'nomerge')
    (and 261 more)


Could virtual/perl-CPAN-1.94.02 be upgraded to require ~dev-lang/perl-5.12.2? If so, how is that accomplished?

Any pointers are appreciated.

Regards,
davobe
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Wed Oct 13, 2010 7:09 am    Post subject: Reply with quote

Hello!

davobe wrote:

Could virtual/perl-CPAN-1.94.02 be upgraded to require ~dev-lang/perl-5.12.2? If so, how is that accomplished?


Try it now, it should work with 5.12.2 as well.

M.
_________________
Michele Beltrame
Italian Perl Workshop 2011
http://www.perl.it/workshop/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9
Page 9 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum