Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alt-Gr
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Sun Mar 16, 2003 4:06 pm    Post subject: Alt-Gr Reply with quote

Har problem med att få alt-gr att funka utan den uppför sig som vanliga alt-tagenten. Vet att det står mycket om det i forumet och har testat det mesta dock utan resultat. Kör med "se-latin1" i rc.conf och i XF86Config ser det ut så här:

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "keyboard"
   Option       "AutoRepeat" "500 30"
   Option       "XkbRules"   "xfree86"
   Option       "XkbModel"   "pc105"
   Option       "XkbLayout"  "se"

EndSection


Finns det något sätt att uppdatera alla config-filer (nu menar jag inte etc-update utan att dra hem alla på nytt och sedan uppdatera ens cofig-filer med hjälp av etc-update ifall att felet inte ligger i XF86Conifg (har precis kört 'emerge -e world' och det var då problemet uppstod))
Back to top
View user's profile Send private message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Mon Mar 17, 2003 2:44 am    Post subject: Reply with quote

hmm jag har kommit på en ful-lösning så länge (inte riktigt nöjd med den men tills jag kommer på ett bättre alternativ så får det duga).

Nåväl vet inte om andra har råkat ut för samma problem men det är inte Alt-Gr som inte funkar utan det var min keymapping som inte stämmer. För att få @ att funka igen så gjorde jag följande:

Code:
$ xmodmap -e "keycode 11 = 2 quotedbl at"


För att få reda på vilken keycode som motsvarar en tagent så gäller följande:

Code:
$ xmodmap -pk    //list keymap table


Be någon polare som har ett fungerande tangentbord att köra "xmodmap -pk" och ge dig de rätta värderna. Jag gjorde allt som user och bytte sedan till rooten och körde;

Code:
# /etc/init.d/keymaps restart


för att starta om keymaps utan att behöva logga ut.
Det finns säkert ett mycket bättre sätt att åtgärda problemet på och jag skulle vara tacksam om någon kunde komplettera med den lösningen men tills vidare är det för mig enda alternativet.
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Mon Mar 17, 2003 11:26 am    Post subject: Re: Alt-Gr Reply with quote

Crow wrote:
Finns det något sätt att uppdatera alla config-filer (nu menar jag inte etc-update utan att dra hem alla på nytt och sedan uppdatera ens cofig-filer med hjälp av etc-update ifall att felet inte ligger i XF86Conifg (har precis kört 'emerge -e world' och det var då problemet uppstod))


Från Gentoo install:
Code:
# export CONFIG_PROTECT="-*"

Note: The export CONFIG_PROTECT="-*" line ensures that any new scripts installed to /etc will overwrite the old scripts (stored in sys-apps/baselayout), bypassing Portage's new config file management support. Type emerge --help config for more details.


Jag fattar det som att konfigfilerna skrivs över med stardardvärden, och det var väl det du ville?
/Patrik
Back to top
View user's profile Send private message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Mon Mar 17, 2003 4:47 pm    Post subject: Reply with quote

tackar tackar, ska testa det /Crow
Back to top
View user's profile Send private message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Mon Mar 17, 2003 5:29 pm    Post subject: Reply with quote

en liten uppdatering till min ful-lösning (hoppas ingen har försökt den ännu -och jag jobbar på en bättre lösning)

Code:
$ xmodmap -e "codekey 113 = Mode_switch Multi_key"


jag hade "codekey 113 = Alt_R" innan men jag tror att jag ändrade det i ett tidigare stadie när Alt_Gr inte ville.
(har pc105)
Back to top
View user's profile Send private message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Mon Mar 17, 2003 11:57 pm    Post subject: Reply with quote

Nåväl det här blev lite av en monolog men... om jag vill att följande körs vid inloggnig som user:
Code:
$ xmodmap -e "keycode 113 = Mode_switch Multi_key"
$ xmodemap -e "//resterande Alt-Gr funktioner som @ och dyligt"

Det verkar inte som om min /home/user/.xinitrc fil fungerar, eller iaf så la jag in de raderna dock utan resultat. Testade även att lägga in det i /etc/conf.d/local.start vilket var helt fel... troligen är det inte länkat rätt eller något.
Ska jag lägga in något i "/etc/X11/Session/fluxbox alt. Gnome" som t.ex. "/home/user/.xinitrc" eller dyligt för att aktivera den vid inloggning?

Btw att restarta keymaps var onödigt när man använder xmodmap utan de fungerar direkt.[/code]
Back to top
View user's profile Send private message
Lilltiger
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2003
Posts: 76

PostPosted: Tue Mar 18, 2003 3:12 pm    Post subject: Reply with quote

Är du säker på att du använder:

Identifier "Keyboard0"

Å inte något annat, för jag hadde samma problem då jag använde se-latin1 i X.
Men gör du det så är en lösning att lägga till det "språket" du skapade som ett nytt språk. Och sedan låta X använda detta, hur detta görs står nog i dokumentationen till X.
Back to top
View user's profile Send private message
Crow
n00b
n00b


Joined: 20 Feb 2003
Posts: 10

PostPosted: Wed Mar 19, 2003 12:40 am    Post subject: Reply with quote

jepp jag kör med Identifier "Keyboard0" och nu har jag kommit upp i varv så nu ska jag ta och lösa problemet via xmodmap och låta .xinitrc loada den (som det är nu har jag en fungerade xmodmap-fil med alla de extra värden jag vill ha så nu ska jag bara få .xinitrc att loada 'xmodmap $HOME/.Xmodmap' så jag slipper köra den manuellt).
När jag har fått det att funka så skriver jag nog om "keytable/språket" och låter X köra med den istället (tänkte inte ens på det så tackar) men det är alltid kul att få en lösning man har pillat med att funka och det kan vara bra om .xinitrc funkar oxå -om inte inför framtiden.

-tack för all hjälp (via "quick search" och respons).
Back to top
View user's profile Send private message
Stekern
n00b
n00b


Joined: 20 Mar 2003
Posts: 1

PostPosted: Thu Mar 20, 2003 7:19 am    Post subject: Reply with quote

Jag hade exakt samma problem, men dessa inställningar i XF86Config löste det:
Code:

Section "InputDevice"

    Identifier "Keyboard1"
    Driver     "Keyboard"
    Option     "CoreKeyboard"
    Option     "AutoRepeat"  "250 30"
    Option     "XkbRules"    "xfree86"
    Option     "XkbModel"    "pc102"
    Option     "XkbVariant"  "nodeadkeys"
    Option     "XkbLayout"   "se"
    Option     "XkbOptions"  "ctrl:nocaps"
EndSection
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5236
Location: France, Old Europe

PostPosted: Fri Jul 02, 2004 11:46 am    Post subject: Reply with quote

Crow wrote:
Nåväl det här blev lite av en monolog men... om jag vill att följande körs vid inloggnig som user:
Code:
$ xmodmap -e "keycode 113 = Mode_switch Multi_key"
$ xmodemap -e "//resterande Alt-Gr funktioner som @ och dyligt"

Det verkar inte som om min /home/user/.xinitrc fil fungerar, eller iaf så la jag in de raderna dock utan resultat. Testade även att lägga in det i /etc/conf.d/local.start vilket var helt fel... troligen är det inte länkat rätt eller något.
Ska jag lägga in något i "/etc/X11/Session/fluxbox alt. Gnome" som t.ex. "/home/user/.xinitrc" eller dyligt för att aktivera den vid inloggning?

Btw att restarta keymaps var onödigt när man använder xmodmap utan de fungerar direkt.[/code]


http://forums.gentoo.org/viewtopic.php?p=1304048#1304048 8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum