Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[alsa]pas de 5.1 avec une carte intégrée ad1985 d'AsusP4P800
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Mon May 28, 2007 10:19 am    Post subject: [alsa]pas de 5.1 avec une carte intégrée ad1985 d'AsusP4P8 Reply with quote

Ma carte mère est une asus p4p800 avec une carte son intégrée ad1985. J'aimerai faire fonctionner le son 5.1 vu que j'ai l'equipement pour mais pas moyen d'y arriver (alors que ça fonctionne sans pb sous windows xp). J'ai essayé de suivre ce howto http://gentoo-wiki.com/HOWTO_Surround_Sound en testant différent .asoundrc mais sans resultats.
Lorsque je test avec speaker-test :
Code:
speaker-test -Dplug:surround51 -c6

je n'entend du son que sur le front left et front right :(

Mon /etc/modules.d/alsa est le suivant (snd-intel8x0 pour mon ad1985 et snd-usb-audio pour le micro de ma webcam Logitech Quickcam 4000 pro) :
Quote:
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
alias snd-card-1 snd-usb-audio

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=2
options snd-intel8x ac97_quirk=3
options snd-pcm-oss nonblock_open=1


Mon ancien .asoundrc est le suivant (prend en compte mon mic et dmix mais pas le 5.1 par contre) :
Quote:
pcm.asymed {
type asym
playback.pcm "dmix"
capture.pcm "hw:1,0"
}

pcm.!default {
type plug
slave.pcm "asymed"
}



Je pense que ça n'est pas une question de .asoundrc car je devrais avoir du son avec speaker-test sur les 5 haut-parleurs tout de même mais je ne vois pas ce qu'il manque... :( (et tous les branchements sont corrects vu que cela fonctionne sous windows)

Qq un aurait une idée svp ? :idea:


Last edited by dreamer86 on Wed May 30, 2007 9:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4917

PostPosted: Mon May 28, 2007 10:39 am    Post subject: Reply with quote

Houlà rêves pas trop. Un chip AD c'est un truc de base mais vraiment de base (cf alsa-project.org dans soundcard: mattes ce que le driver supporte. pas grand chose...). Le fait que ouinouin réussisse à utiliser la fonction 5.1 de la carte n'est en aucun cas une référence, c'est pas comparable car sous ouinouin tu as le driver proprio qui a été fait selon les specs et qui permet d'utiliser au mieux les fonctions de la cartes. Bref: tout ce que n'ont pas les devs pour faire des drivers open-source adéquats. Donc la rèf win xp tu oublis :P
Je ne sais si quelqu'un a déjà réussis à faire fonctionner le 5.1 sur cette carte mais si c'est pas le cas ne t'en étonnes pas outre-mesure.

Lis tout de mêmes ces deux pages : http://alsa-project.org/alsa-doc/doc-php/template.php?company=Analog+Devices&card=ADAT%2Fpcr.&chip=AD1881%2C+AD1881A%2C+AD1885%2C+AD1886%2C+AD1887%2C+AD1980%2C+AD1981A%2C+AD1981B%2C+AD1985&module=intel8x0 et http://alsa-project.org/alsa-doc/doc-php/template.php?company=Analog+Devices&card=ADAT%2Fpcr.&chip=AD1881%2C+AD1881A%2C+AD1885%2C+AD1886%2C+AD1887%2C+AD1980%2C+AD1981A%2C+AD1981B%2C+AD1985&module=via82xx
on sait jamais...
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Wed May 30, 2007 8:26 pm    Post subject: Reply with quote

J'avais déjà vu ces pages sur le site d'alsa kwenspc, mais ça ne m'aide pas bcp :(

J'ai trouvé ce lien : http://ubuntuforums.org/showthread.php?t=120488
Apparament, le param a appliquer pour ma carte est
Quote:
options snd-intel8x0 ac97_quirk=ad_sharing
J'ai aussi essayé tous les autres param possibles à passer à l'option ac97_quirk comme indiqué mais sans resultat :(

Le truc c'est que dans alsamixer, il y a plein de choses possibles à configurer mais je ne sais pas à quoi cela correspond exactement, comme par exemple :
  • le Surround Jack Mode où il est possible de mettre Independant ou bien Shared (j'ai laissé Independant vu que mon 5.1 est branché sur le line In et Auxiliaire je crois),
  • l'option IEC958 que je laisse active,
  • l'option IEC958 Playback AC97-SPSA que je laisse à 100%,
  • l'option IEC958 Playback Source où il est possible de mettre "A/D Converter" ou bien "AC-Link"


Pour le Chanel Mode, j'ai laissé en 6ch (vu que je veux du 5.1, je pense que cela doit être cela). Sinon il y a également (à activer ou désactiver) :
  • Exchange Center/LFE,
  • Exchange Front/Surround,
  • External Amplifier,
  • High Pass Filter Enable,
  • Spread Front to Surround and Center/LFE,
  • Stereo Mic,
  • V_REFOUT (avec comme valeur possible : 0 V, 2.25 V, 3.7 V, High-Z)


Je n'ai pas trouvé de doc sur tout cela, si qq un sait à quoi correspondent tous ces param, ça pourrait peut-etre m'aider :D merci d'avance
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Wed May 30, 2007 8:49 pm    Post subject: Reply with quote

Pour infos, j'utilise :
Quote:
media-sound/alsa-driver-1.0.14_rc2-r1
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu May 31, 2007 12:43 pm    Post subject: Reply with quote

@kwenspc tu peux mettre tes liens entre balises s'il te plaît.

Sinon tu devrais trouver des infos ici : How to activate surround out on Soundblaster Live 5.1 card C'est pas le même carte mais y'a de la méthode :lol: Bonne chance.

EDIT : j'ai pas le temps de creuser la question, mais regarde le changelog de alsa. Car ici : lkml.org on trouve un patch, avec dans le changelog :
Quote:
[ALSA] ac97 - fix malfunctioning mixer controls for AD1985

_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Tue Jun 05, 2007 10:24 pm    Post subject: Reply with quote

Merci MickTux. Apparament le patch dont tu parles est inclus dans la release stable 1.0.14 des drivers alsa (sorti depuis 2 jours seulement le 4/06) : http://www.alsa-project.org/changes/v1-0-13--v1-0-14.txt

Et surtout j'ai trouvé qq sections interessantes dans ce changelog (notamment le fameux patch) :
Quote:
This patch fixes the control logic for shared
Microphone in/Center+LFE out and Line in/Surround out jacks
for Analog Devices AD1888, AD1980 and AD1985 AC '97 CODECs.

Quote:
ac97 - fix malfunctioning mixer controls for AD1985


Je vais attendre avec impatience que cette release stable soit dispo dans portage :P
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Tue Jun 05, 2007 10:37 pm    Post subject: Reply with quote

MickTux, apparemment le patch de ton lien était déjà inclus dans la rc2 que j'utilise (version stable gentoo) http://www.alsa-project.org/changes/v1-0-14rc1--v1-0-14rc2.txt :(

Avec un peu de chance les modifs de la dernière release corrigeront le pb :P
Quote:
This patch fixes the control logic for shared
Microphone in/Center+LFE out and Line in/Surround out jacks
for Analog Devices AD1888, AD1980 and AD1985 AC '97 CODECs.
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Sat Jul 14, 2007 7:23 pm    Post subject: Reply with quote

La dernière release d'alsa (1.0.14) corrige bien le pb ! :-D
Par contre, nouveau souci, quand je test avec speaker-test, le Front Left se retrouve dans le Rear Left et inversement, LFE dans le Center, tout est mélangé ! j'ai essayé d'activer les options "Exchange Front/Surround" et "Exchange Center/LFE" mais c'est pire, le Front Left se retrouve en Rear Right, en gros, c'est le boxon !
J'ai trouvé ce lien : http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml#t
où il est dit qi'il y aurait un pb avec les chip ICH5 :
Quote:
You should hear noise one by one on all your speakers. A common issue with some ICH5 chips is that the Center and LFE channels are swapped with rear channels. To fix this, you'll have to edit a section of /etc/alsa/cards/ICH4.conf to make it like /etc/alsa/cards/ICH.conf. You can use my ICH4.conf. Also, some older versions of ALSA have a problem with the rear right channel; so upgrade in that case


J'ai effectué la manip qu'ils decrivent, c'est-à-dire de remplacer le fichier ICH4.conf par ICH.conf (ils sont placés dans /usr/share/alsa/cards/ contrairement au lien) et lors de l'ecoute avec speaker-test, j'entend bien tous les sons dans les bons haut-parleurs, sauf que pour Rear Left, j'entend en même temps Front Left et pour Rear Right j'entend en meme temps Front Right.

J'ai essayé de parcourir plusieurs howto mais j'ai du mal à trouver la config adéquate pour avoir seulement Rear Left et Rear Right.
Please help :roll:
Back to top
View user's profile Send private message
dreamer86
Apprentice
Apprentice


Joined: 08 Aug 2004
Posts: 207
Location: Poitiers - France

PostPosted: Sun Jul 22, 2007 7:34 pm    Post subject: Reply with quote

Personne aurait une petite idée ? :idea: :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum