Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200512-02 ] Webmin, Usermin: Format string vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu Dec 08, 2005 12:31 pm    Post subject: [ GLSA 200512-02 ] Webmin, Usermin: Format string vulnerabil Reply with quote

Gentoo Linux Security Advisory

Title: Webmin, Usermin: Format string vulnerability (GLSA 200512-02)
Severity: high
Exploitable: remote
Date: December 07, 2005
Bug(s): #113888
ID: 200512-02

Synopsis


Webmin and Usermin are vulnerable to a format string vulnerability which
may lead to the execution of arbitrary code.


Background


Webmin is a web-based interface for Unix-like systems. Usermin is
a simplified version of Webmin designed for use by normal users rather
than system administrators.


Affected Packages

Package: app-admin/webmin
Vulnerable: < 1.250
Unaffected: >= 1.250
Architectures: All supported architectures

Package: app-admin/usermin
Vulnerable: < 1.180
Unaffected: >= 1.180
Architectures: All supported architectures


Description


Jack Louis discovered that the Webmin and Usermin "miniserv.pl"
web server component is vulnerable to a Perl format string
vulnerability. Login with the supplied username is logged via the Perl
"syslog" facility in an unsafe manner.


Impact


A remote attacker can trigger this vulnerability via a specially
crafted username containing format string data. This can be exploited
to consume a large amount of CPU and memory resources on a vulnerable
system, and possibly to execute arbitrary code of the attacker's choice
with the permissions of the user running Webmin.


Workaround


There is no known workaround at this time.


Resolution


All Webmin users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-admin/webmin-1.250"

All Usermin users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-admin/usermin-1.180"


References

CVE-2005-3912
Dyad Security Advisory


Last edited by GLSA on Sun May 30, 2010 4:21 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum