Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200512-04 ] Openswan, IPsec-Tools: Vulnerabilities in ISAKMP Protocol implementation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Dec 12, 2005 8:53 pm    Post subject: [ GLSA 200512-04 ] Openswan, IPsec-Tools: Vulnerabilities in Reply with quote

Gentoo Linux Security Advisory

Title: Openswan, IPsec-Tools: Vulnerabilities in ISAKMP Protocol implementation (GLSA 200512-04)
Severity: low
Exploitable: remote
Date: December 12, 2005
Updated: December 14, 2005
Bug(s): #112568, #113201
ID: 200512-04

Synopsis

Openswan and IPsec-Tools suffer from an implementation flaw which may allow a Denial of Service attack.

Background

Openswan is an implementation of IPsec for Linux. IPsec-Tools is a port of KAME's implementation of the IPsec utilities, including racoon, an Internet Key Exchange daemon. Internet Key Exchange version 1 (IKEv1), a derivate of ISAKMP, is an important part of IPsec. IPsec is widely used to secure exchange of packets at the IP layer and mostly used to implement Virtual Private Networks (VPNs).

Affected Packages

Package: net-misc/openswan
Vulnerable: < 2.4.4
Unaffected: >= 2.4.4
Architectures: All supported architectures

Package: net-firewall/ipsec-tools
Vulnerable: < 0.6.3
Unaffected: >= 0.6.3
Unaffected: >= 0.6.2-r1 < 0.6.3
Unaffected: >= 0.4-r2 < 0.5
Architectures: All supported architectures


Description

The Oulu University Secure Programming Group (OUSPG) discovered that various ISAKMP implementations, including Openswan and racoon (included in the IPsec-Tools package), behave in an anomalous way when they receive and handle ISAKMP Phase 1 packets with invalid or abnormal contents.

Impact

A remote attacker could craft specific packets that would result in a Denial of Service attack, if Openswan and racoon are used in specific, weak configurations.

Workaround

There is no known workaround at this time.

Resolution

All Openswan users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/openswan-2.4.4"
All IPsec-Tools users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose net-firewall/ipsec-tools


References

CVE-2005-3671
CVE-2005-3732
Original Advisory


Last edited by GLSA on Wed May 24, 2006 4:18 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum