Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Få Gentoo på norsk/dansk/svenska
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Ixzat
n00b
n00b


Joined: 23 Jan 2004
Posts: 34
Location: Sweden

PostPosted: Wed Oct 19, 2005 10:09 am    Post subject: Reply with quote

Jag har också ett liknande problem. Jag satt och jiddrade runt med locales inställningar för att få svenskt tangentbord, men nu så visar det sig att programen är på svenska också. Det öär lite störigt när tex gcc spottar ut sig felmeddelande på svenska om man skall felsöka och sådär...

Code:

gentoo ~ # locale
LANG=C
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE


Code:

gentoo ~ # locale charmap
ISO-8859-1


Code:

gentoo ~ # grep CONSOLE /etc/rc.conf
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
#CONSOLEFONT="lat9w-16"
#CONSOLETRANSLATION="8859-15_to_uni"


Code:

gentoo ~ # grep KEY /etc/rc.conf
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.
#KEYMAP="sv-latin1"


Code:

gentoo ~ # cat /etc/env.d/02locale
LC_ALL=sv_SE
LANG=C


Vad mer kan jag göra? Kan jag på något sätt söka efter tex "LC_TIME" i alla filer för att se var jag har det definierat nånstans?


jonasmattsson wrote:
Jag har jättekonstiga med mina åäö både som root och som användare. det konstigaste är att det inte är konsekvent. om jag tex vill starta xmms från gnome-menyn så blir åäö helt ur-k**ade medans om jag startar xmms från gnome-terminal:en så blir allting bra (allting? mjae) förutom filnamn, dom blir inte bra i xmms, filnamn blr däremot bra i terminalen, samma problem får jag med gnome-commander bara att där blir ingenting bättre för att jag startar den ifrån terminalen. gabber och ayttm beter sig likadant som xmms men många andra program verkar inte ha några problem. är det någon som kan hjälpa/tipsa?

jag antar att det är ett sjuttiotal miljövariabler som måste balanseras j***igt väl, men vilka? om det nu är så.

lite output som andra verkar tycka är viktig
Code:
 ~ $ locale
LANG=sv_SE
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE
~ $ locale charmap
ISO-8859-1
~ $ grep CONSOLE /etc/rc.conf
CONSOLEFONT="iso01.14"
CONSOLETRANSLATION="8859-1_to_uni"
~ $ grep KEY /etc/rc.conf
KEYMAP="sv-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad euro"

detta känns väldigt störande, det är nästan så att man funderar på att byta förstaspråk. Ett stort tack utlovas till den som kan reda ut denna härva med Miljövariabler åt höger å vänster och massa olika konfigurationsfiler åt mig.
Back to top
View user's profile Send private message
forsen
n00b
n00b


Joined: 01 Nov 2003
Posts: 23
Location: Oslo, Norway

PostPosted: Mon Oct 31, 2005 4:39 pm    Post subject: Reply with quote

Noen som vet hvordan man får emacs til å støtte norske tegn? Min nekter :P
Back to top
View user's profile Send private message
Karl-Franz
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2005
Posts: 121
Location: /se/lund

PostPosted: Wed Dec 21, 2005 11:30 am    Post subject: Reply with quote

Vet inte varför det inte tas upp någonstans men jag var tvungen att ställa in locales.build för att språket skulle funka, annars kommer det bara massa felmeddelanden om att den inte hittar sv_SE.
Back to top
View user's profile Send private message
conchyliferous
n00b
n00b


Joined: 28 May 2005
Posts: 50
Location: Sweden

PostPosted: Fri Feb 24, 2006 12:54 pm    Post subject: Inga å ä och ö i Vim Reply with quote

Jag har problemet att inga å ä eller ö går att skriva i vim.
I en terminal eller i nano är det inga problem.
Tror jag har testat det mesta som nämnts i den här tråden.

Någon lösning?
Back to top
View user's profile Send private message
psy_ill
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2003
Posts: 106

PostPosted: Wed Mar 01, 2006 10:07 am    Post subject: Reply with quote

Vim använder sig av readline så i värsta fall kan du mixtra med ~/.inputrc för att få det att fungera, men jag tycker att saker och ting borde fungera direkt för dig.
När du skriver i Vim, är det i en terminal eller i konsollen?
Back to top
View user's profile Send private message
conchyliferous
n00b
n00b


Joined: 28 May 2005
Posts: 50
Location: Sweden

PostPosted: Wed Mar 01, 2006 3:49 pm    Post subject: Reply with quote

Jag använder aterm och xterm mest. Men jag kom just på lite mer om problemet. Det går bra med å, ä och ö när jag loggar på som root. Det är bara för användaren som det skiter sig (i vim). 8O
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 374
Location: Svedala

PostPosted: Wed Mar 01, 2006 4:17 pm    Post subject: Reply with quote

Lite 'from the top of my head' :
Hos mig, så får inte /root/.bashrc något genomslag, däremot /home/<username>/.bashrc.
Har du samma sak, så kolla igenom .bashrc om du glömt någon miljövariabel som finns där i.

Jag hade även kollat igenom miljövariablerna användrana emellan.

Code:
 root # env <enter>
user $ env <enter>
Back to top
View user's profile Send private message
conchyliferous
n00b
n00b


Joined: 28 May 2005
Posts: 50
Location: Sweden

PostPosted: Wed Mar 01, 2006 4:44 pm    Post subject: Reply with quote

Jag hittar inget viktigt som skiljer sig i miljöveriablerna. Kankse kan någon annan se något?

Code:
conchyliferous ~$ diff user.env root.env

4d3
< SHELL=/bin/bash
7d5
< XTERM_SHELL=/bin/bash
8a7
> XTERM_SHELL=/bin/bash
11d9
< PAGER=/usr/bin/less
12a11
> PAGER=/usr/bin/less
14,15c13
< MAIL=/var/mail/conchyliferous
< PATH=/usr/java/bin:/usr/java/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.4.4:/usr/games/bin
---
> PATH=/sbin:/bin:/usr/sbin:/usr/bin
18c16
< PS1=\[\033[01;31m\]\u \[\033[01;32m\]\w\$ \[\033[00m\]
---
> PS1=\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\]
20,23c18,19
< SHLVL=4
< HOME=/home/conchyliferous
< LESS=-R -M --shift 5
< PYTHONPATH=/usr/lib/portage/pym
---
> HOME=/root
> SHLVL=5
25c21,22
< CVS_RSH=/home/conchyliferous/script/sshsledge.sh
---
> PYTHONPATH=/usr/lib/portage/pym
> LESS=-R -M --shift 5
26a24
> CVS_RSH=/home/conchyliferous/script/sshsledge.sh
31d28
< G_BROKEN_FILENAMES=1
33,34c30,32
< XAUTHORITY=/home/conchyliferous/.Xauthority
< _=/usr/bin/env
---
> G_BROKEN_FILENAMES=1
> XAUTHORITY=/root/.xauthiXIrRL
> _=/bin/env
Back to top
View user's profile Send private message
zhark
n00b
n00b


Joined: 26 Feb 2006
Posts: 29

PostPosted: Fri Mar 10, 2006 2:57 pm    Post subject: Reply with quote

Jeg har 2 problemer når det gjelder Gentoo på norsk:

I Java (har prøvd både 1.4x og 1.5.0_06) dialogbokser ved bruk av inputbokser så blir øæå gjort om til firkant-tegn. Ferdiglagde programmer, som Azureus fungerer fint med norske tegn. Problemet oppstår altså når jeg lager programmer selv.

Joe (Joe's own editor) viser ikke norske tegn riktig, i stedet for øæå får jeg xfe (markert). Norske tegn fungerer ellers fint både i X og konsollen og ved bruk av andre editorer som nano.


Håper noen har noen tips!
Back to top
View user's profile Send private message
brormagnus
n00b
n00b


Joined: 18 Sep 2005
Posts: 3
Location: Roskilde.dk

PostPosted: Tue Jun 20, 2006 6:28 pm    Post subject: Någon har städat i /usr/lib/locale !!! [solved - se nedan] Reply with quote

Efter att ha bootat om datorn efter sådär tre veckor upptäckte jag till min fasa att de tre magiska ÅÄÖ'na var borta i consolen.
Jag fick ett intressant felmeddelande från locale när jag körde det -- dessvärre kan jag inte riktigt komma ihåg den exakta ordalydelsen, men innebörden var dock att locale inte kunde sätta miljövariablerna då den inte hittade någon fil.

Jag kollade lite i /usr/lib/locale:
Code:
segburken ~ $ ls /usr/lib/locale/
de_DE  de_DE@euro  en_HK  en_PH  en_US  en_US.utf8  es_MX  fa_IR  fr_FR  fr_FR@euro  it_IT  ja_JP  ja_JP.eucjp  ja_JP.utf8

och till min fasa ser det ut som någon har varit där och städat. Jag har kört en hel del uppdateringar sedan sista rebooten -- och har ingen aning om vilken uppdatering det kan vara som har fått städmani. Någon som har någon idé om hur man får tillbaka sv_SE.UTF-8 i /usr/lib/locale/ på enklast möjliga vis?

Edit: Som Kallamej så vist säger... Man borde synca och uppdatera lite oftare, men framför allt borde man vara mer vaken på vad som händer när man uppdaterar. /etc/locale-gen var en nyhet för mig då jag feg-kör stable. Tack för hjälpen!


Last edited by brormagnus on Wed Jun 21, 2006 5:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Jun 20, 2006 10:48 pm    Post subject: Reply with quote

Det här beror på glibc. Kör du stable beror det på USE="userlocales" och en default /etc/locales.build. Kör du testing så beror det på en default /etc/locale.gen. I det senare fallet är det bara att editera den på lämpligt sätt och sedan köra locale-gen, i det förra kan du köra
Code:
localedef -c -f UTF-8 -i POSIX sv_SE.UTF-8

för att fixa det nu, och editera /etc/locales.build om du skulle behöva kompilera om glibc.

Edit: Borde visst synca lite oftare. Det är locale-gen som gäller även för stable (x86) glibc nu. Se bug 137121.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
zhark
n00b
n00b


Joined: 26 Feb 2006
Posts: 29

PostPosted: Thu Jul 20, 2006 8:52 am    Post subject: Reply with quote

Have a weird problem when logging in via ssh from a windows pc with putty.
When using ø,æ or å, in the console, the letter doesn't appear before I press an additional button,
like when I type æ, for instance, nothing appears before I type an additional letter.

This seems to cause issues with joe (jonathans own editor), although not with pico.

When logging in locally everything is working normally, including joe.

zhark.
Back to top
View user's profile Send private message
spetznaz
n00b
n00b


Joined: 07 Dec 2003
Posts: 34
Location: Risør, Norway

PostPosted: Tue Dec 19, 2006 11:42 pm    Post subject: Reply with quote

Siden denne tråden begynner å bli ganske utdatert tenkte jeg jeg kunne fortelle hvordan i allefall tastaturoppsett gjøres "nå til dags" på en x86 / x86_64 maskin.
Quote:

# /etc/conf.d/keymaps

KEYMAP="no-latin1"
SET_WINDOWKEYS="yes"

Quote:

# /etc/rc.conf

UNICODE="yes"

Quote:

# /etc/conf.d/consolefont

CONSOLEFONT="default8x16"
CONSOLETRANSLATION="8859-1_to_uni"

Quote:

#/etc/X11/xorg.conf

Option "XkbLayout" "no"
Back to top
View user's profile Send private message
ShredOrBeDead
n00b
n00b


Joined: 15 Mar 2007
Posts: 1

PostPosted: Thu Mar 15, 2007 11:12 am    Post subject: Reply with quote

Hmm, har gjort som du har skrevet i siste posten, men norske taster funker fortsatt ikke... Ikke AltGr + 2(snabel a) heller... Noen som har noen smarte ideer?
_________________
make install - Not War
Back to top
View user's profile Send private message
Growlizing
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2005
Posts: 94

PostPosted: Fri Aug 17, 2007 10:08 am    Post subject: Reply with quote

Tror du også trenger blant annet:

Code:

grep -v "#" /etc/locale.gen

en_US ISO-8859-1
en_US.UTF-8 UTF-8

nb_NO.UTF-8 UTF-8
nb_NO ISO-8859-1


Enkelte programmer trenger også noe ala dette i /etc/make.conf (ikke 100% sikker på hva som er riktig, tar derfor en helgardering ;)):
Code:

LINGUAS="nb no nb_NO en"

_________________
Is this where I write something clever?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum