Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem z drukarką lexmark z815
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 12:50 pm    Post subject: Problem z drukarką lexmark z815 Reply with quote

Witam!

Mam problem z zainstalowaniem drukarki lexmark z815. Stanąłem na kompilacji modułu obsługi drukarek usb. Dalej nie wiem co mam robić. Proszę o porady.

Dziękuję i pozdrawiam

PS. Cups mam już zainstalowany...
_________________
caruso
Back to top
View user's profile Send private message
kadu
Apprentice
Apprentice


Joined: 09 Oct 2005
Posts: 267

PostPosted: Sat Nov 19, 2005 12:56 pm    Post subject: Reply with quote

Quote:
Stanąłem na kompilacji modułu obsługi drukarek usb
. Dokładniej mozna??
_________________
:*
Back to top
View user's profile Send private message
arsen
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 1803
Location: Tychy, Poland

PostPosted: Sat Nov 19, 2005 12:57 pm    Post subject: Reply with quote

wątek przesunięty do "instalacja i sprzęt"
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 1:02 pm    Post subject: Reply with quote

kadu wrote:
Quote:
Stanąłem na kompilacji modułu obsługi drukarek usb
. Dokładniej mozna??

Oczywiście że można - skompilowałem moduł jądra do obsługi drukarek. I dalej nie wiem co mam robić aby system mógł drukować. W centrum sterowania kde mogę dodać drukarkę i znaleziony gdzieś w necie plik ppd. Także cups widzi drukarkę ale nic nie może wydrukować - drukarka nawet nie drgnie.

Pozdrawiam
_________________
caruso
Back to top
View user's profile Send private message
Kajan
Guru
Guru


Joined: 23 Dec 2004
Posts: 308
Location: Poland/Warsaw

PostPosted: Sat Nov 19, 2005 1:03 pm    Post subject: Reply with quote

Wydaj polecenie:
Code:

lsusb

Rozpoznawana jest drukarka ??
_________________
Oracle Solaris
Oracle Linux
Gentoo Linux
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 1:09 pm    Post subject: Reply with quote

Kajan wrote:
Wydaj polecenie:
Code:

lsusb

Rozpoznawana jest drukarka ??

tak :
Bus 002 Device 013: ID 043d:008e Lexmark International, Inc.
_________________
caruso
Back to top
View user's profile Send private message
Kajan
Guru
Guru


Joined: 23 Dec 2004
Posts: 308
Location: Poland/Warsaw

PostPosted: Sat Nov 19, 2005 1:14 pm    Post subject: Reply with quote

Ja na twoim miejscu zrobilbym tak:
Code:

emerge rpm

Po tej operacji sciagamy z810llpddk-2.0-3.i386.rpm, instalujemy poleceniem:
Code:

rpm -Uvh --nodeps z810llpddk-2.0-3.i386.rpm

ładujemy:
Code:

modprobe usblp

Dodajemy ja do Centrum, no i testujemy czy dziala.


Pozdro
_________________
Oracle Solaris
Oracle Linux
Gentoo Linux
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 2:11 pm    Post subject: Reply with quote

W dalszym ciągu drukarka nie drgnie.

Pozdrawiam
_________________
caruso
Back to top
View user's profile Send private message
Kajan
Guru
Guru


Joined: 23 Dec 2004
Posts: 308
Location: Poland/Warsaw

PostPosted: Sat Nov 19, 2005 2:52 pm    Post subject: Reply with quote

harry.tx wrote:
W dalszym ciągu drukarka nie drgnie.

Pozdrawiam

Zainstalowales foomatic-db ??


Pozdro
_________________
Oracle Solaris
Oracle Linux
Gentoo Linux
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 5:18 pm    Post subject: Reply with quote

Kajan wrote:
harry.tx wrote:
W dalszym ciągu drukarka nie drgnie.

Pozdrawiam

Zainstalowales foomatic-db ??


Pozdro

Tak, ale drukarka dalej ani nie drgnie.
_________________
caruso
Back to top
View user's profile Send private message
Kajan
Guru
Guru


Joined: 23 Dec 2004
Posts: 308
Location: Poland/Warsaw

PostPosted: Sat Nov 19, 2005 5:23 pm    Post subject: Reply with quote

http://www.gentoo.org/doc/pl/printing-howto.xml -> przebudowywales jadro ??


Pozdro
_________________
Oracle Solaris
Oracle Linux
Gentoo Linux
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Nov 19, 2005 5:29 pm    Post subject: Reply with quote

Kajan wrote:
http://www.gentoo.org/doc/pl/printing-howto.xml -> przebudowywales jadro ??


Pozdro

Nie. Skompilowałem obsługę drukarki jako moduł usblp.

Pozdrawiam
_________________
caruso
Back to top
View user's profile Send private message
Kajan
Guru
Guru


Joined: 23 Dec 2004
Posts: 308
Location: Poland/Warsaw

PostPosted: Sun Nov 20, 2005 4:17 pm    Post subject: Reply with quote

Hmmm, moze bezposrednio za pomoca http://localhost:631/printers dodaj drukarke.


Pozdro
_________________
Oracle Solaris
Oracle Linux
Gentoo Linux
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sun Nov 20, 2005 4:28 pm    Post subject: Reply with quote

Nie mogę zastosować tej metody bo w foomatic nie ma driverów do mojej drukarki a plik ppd mam na pulpicie.

Pozdrawiam
_________________
caruso
Back to top
View user's profile Send private message
zbrodel
n00b
n00b


Joined: 08 Nov 2005
Posts: 5

PostPosted: Tue Nov 22, 2005 12:19 pm    Post subject: Reply with quote

Ustaw sobie w /etc/cups/cups.conf LogLevel na error i pokaż, co jest wypluwane do loga przy próbie drukowania.
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Sat Dec 03, 2005 10:27 pm    Post subject: Reply with quote

Sorka za spóźnioną odpowiedź. Nic nie wypluwa.
_________________
caruso
Back to top
View user's profile Send private message
Radioaktywny
Apprentice
Apprentice


Joined: 01 Sep 2005
Posts: 247
Location: Jestem przed komputerem ;)

PostPosted: Tue Dec 06, 2005 9:38 am    Post subject: Reply with quote

Witam
Spróbuj np.:
Code:
echo "echo "print" > /dev/usb/lp0

Jak nic nie da to przekompiluj jeszcze raz wszystkie moduły do obsługi drukarki, np. cups i ghostscript.
_________________
pozdrawiam
Radioaktywny
Back to top
View user's profile Send private message
jodri
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 122

PostPosted: Tue Dec 06, 2005 3:01 pm    Post subject: Reply with quote

Tam znajdziesz instrukcje uruchomienia drukarki:
http://gentoo-wiki.com/HOWTO_Lexmark_Printers

Wpierw jednak zajrzyj tu:
http://www.gentoo.org/doc/pl/usb-guide.xml oraz tu: http://www.gentoo.org/doc/pl/printing-howto.xml
U mnie moja Z601 dziala, choc mialem troche wiecej kombinowania, gdyz pracuje na AMD64 (64 bitowy)
Powodzenia
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Tue Dec 06, 2005 3:16 pm    Post subject: Reply with quote

Właśnie, ale nie ma żadnego opisu dotyczącego drukarki w wersji z815, sterowników też do niej nie mogłem znaleźć, a te które znalazłem nie działały :(.
_________________
caruso
Back to top
View user's profile Send private message
jodri
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 122

PostPosted: Tue Dec 06, 2005 4:11 pm    Post subject: Reply with quote

Jak nie ma, jak jest:
http://cerqueira.org/software/z810/
Stery sa przeznaczone dla drukarek z serii Z800, powinny wiec u ciebie dzialac.
Powodzenia
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Tue Dec 06, 2005 8:02 pm    Post subject: Reply with quote

Quote:
a te które znalazłem nie działały :(.

właśnie te znalzłem z:
http://cerqueira.org/software/z810/
_________________
caruso
Back to top
View user's profile Send private message
jodri
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 122

PostPosted: Wed Dec 07, 2005 10:50 am    Post subject: Reply with quote

Nie ma rady musi działac, ale zacznij od poczatku. Wpierw skonfiguruj w jadrze prawidlowo USB.
Posluz sie tym opisem : http://www.gentoo.org/doc/pl/usb-guide.xml
Pozniej juz z gorki. Znajomy na swoim Ubuntu uruchomil te drukarke. Mysle wiec iz na Gentoo tez ruszy.

Powdzenia.
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Thu Dec 08, 2005 2:34 pm    Post subject: Reply with quote

Tylko że pojawił się problem, bo nie mogę zainstalować drukarki poprzez cups bo nie ma jej na liście mimo iż zainstalowałem pakiet rpm. :( Opadam z sił.
_________________
caruso
Back to top
View user's profile Send private message
jodri
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 122

PostPosted: Fri Dec 09, 2005 1:16 pm    Post subject: Reply with quote

Sprawdz czy plik .ppd nie jest czasem spakowany. Miałem podobny probelm.
W katalogu
Code:
cd /usr/share/cups/model
mialem
Code:
Lexmark-Z600-lxz600cj-cups.ppd.gz

Wystarczylo rozpakowac i cups zobaczyl moja drukarke. Moze masz ten sam problem.
Powodzenia.
Back to top
View user's profile Send private message
caruso
Apprentice
Apprentice


Joined: 10 Jul 2005
Posts: 277

PostPosted: Fri Dec 09, 2005 3:58 pm    Post subject: Reply with quote

W moim przypadku w ogóle tam nie było tego pliku... Dodałem drukarkę w cups bez problemu, ale gdy idzie coś wydrukować dalej jest "nieporuszona". Oto mój errorlog z cups:
Code:

E [08/Dec/2005:15:28:44 +0100] get_printer_attrs: resource name '/classes/lexmark' no good!
E [08/Dec/2005:15:28:48 +0100] get_printer_attrs: resource name '/classes/lexmark' no good!
E [09/Dec/2005:16:43:36 +0100] PID 18914 stopped with status 22!
E [09/Dec/2005:16:44:40 +0100] PID 19318 stopped with status 22!


Dalej nie rozumie dlaczego poprawnie wysyła wszystko ale dalej nie drukuje. :(
_________________
caruso
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum