Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SCIM in openbox (or otherwise outside of kde/gnome) [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Pev
n00b
n00b


Joined: 12 Nov 2003
Posts: 23
Location: Amherst, MA

PostPosted: Wed Nov 30, 2005 5:18 am    Post subject: SCIM in openbox (or otherwise outside of kde/gnome) [SOLVED] Reply with quote

I've followed the excellent instructions at: http://forums.gentoo.org/viewtopic-t-263174-highlight-enabling+japanese.html and I can now use scim-uim and uim-anthy to input japanese kana and kanji within kde. I have not tried gnome because I don't want to emerge it just for that purpose. Trouble is I like to run openbox, typically. When I run openbox I can run SCIM with either the gtk or kde panel option selected and the icon will appear in pypanel. What's more I can access the right click menu and change the configuration. What I can not do is actually activate the program (by pressing ctrl-space). Without that functionality I can't select another input method (there is just a blank box) and the program wont do its work.

Does anyone know a way around this?[/code]

here's what's installed:
Code:
app-i18n/scim
Latest version installed: 1.4.1

app-i18n/scim-anthy
Latest version installed: 0.5.3

app-i18n/skim
Latest version installed: 1.4.1


app-i18n/scim-uim
Latest version installed: 0.1.3

app-i18n/uim
Latest version installed: 0.5.0.1


Here are the relevant USE flags. I did emerge --newuse world after changing them.
Code:

USE="...   cjk nls immqt-bc -immqt unicode"


Here are the environment variables I added to /etc/bash/bashrc: This seems to be most variable in people's setup so perhaps the problem is here? They are definitely loaded: I can echo them.
Code:
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim


locale appears to be alright, but I'll print the output if anyone wants it.

Anyone know anything? I'd appreciate any tips.


Last edited by Pev on Fri Dec 02, 2005 5:59 am; edited 1 time in total
Back to top
View user's profile Send private message
bunsen
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 105

PostPosted: Wed Nov 30, 2005 8:45 am    Post subject: Reply with quote

I can't be sure about openbox, but I do have scim and scim-anthy working for both enlightement (e16.something) and also for xfce. One thing you've not specified as having done is to start the scim daemon

In either my user .xinitrc or .xsession I include the line

Code:
scim -d
before the window manager entry, e.g.

Code:
xmodmap .Xmodmap
scim -d
#xfce4-session
#fvwm
enlightenment


This is the set of instructions that I followed: http://www.killerbob.ca/howto/japanese.html

Note that in xfce the scim panel appears straight away, whereas for enlightenment it seems to first appear when another application is opened.
Back to top
View user's profile Send private message
Pev
n00b
n00b


Joined: 12 Nov 2003
Posts: 23
Location: Amherst, MA

PostPosted: Wed Nov 30, 2005 7:44 pm    Post subject: instructions Reply with quote

I went over the instructions you gave and that were on the site in question and changed the following:

I added this line to my bashrc (again the variable is being set properly):
Code:

export LC_CTYPE=ja_JP.utf8


I also changed my openbox session file to load scim before the window manager, as opposed to launching it manually:

Code:

eval `cat $HOME/.fehbg` &
exec /usr/bin/pypanel &
exec /usr/bin/torsmo -c /home/matt/.torsmo/torsmorc &
exec /usr/bin/scim -d -e kconfig &
exec openbox


I still can't get the program to activate in any app in openbox (tried kwrite, aterm, firefox).

One potentially helpful observation: the program works in kde, but only for kde apps (kwrite specifically). Firefox and kterm allow me to copy past in characters, but not type via scim.
Back to top
View user's profile Send private message
Pev
n00b
n00b


Joined: 12 Nov 2003
Posts: 23
Location: Amherst, MA

PostPosted: Thu Dec 01, 2005 4:34 am    Post subject: more info Reply with quote

I think the problem is definitely xim specific, judging from the fact that kde works. I found this wiki page that is written to address the problem but following its intstructions did not help:
http://www.scim-im.org/wiki/faq/general/why_xim_apps_does_not_work

My bashrc is now:
Code:
export LC_CTYPE=ja_JP.utf8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim


I did notice that while accessing japanese pages the title does not properly display in the windowbar (ie. the window manager generated part) of the firefox window. I just get a bunch of squares. Is it possible that some useflag was not fully installed?

I saw in ]this thread a configuration that set these two env. variables:
Quote:
export XIM=SCIM
export XIM_PROGRAM=SCIM


I don't have these set but neither does anyone else, it seems, but this one poster. Does anyone know what these settings do or if they are helpful? I also noticed that scim-qtim is not installed. Do I need it?
Back to top
View user's profile Send private message
bunsen
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 105

PostPosted: Thu Dec 01, 2005 7:35 am    Post subject: Reply with quote

Please forgive me for saying it, but it seems to me that working from several guides is confusing matters, my own input now included.
The guide from the killerbob site is all I used to set up Japanese input support on an English speaking system for my wife, who uses it daily for her job as a translator. It certainly works well for her, but maybe you have other requirements.

These lines are added to her $HOME/.bash_profile

Code:
export LC_CTYPE=ja_JP.utf8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim


These are the only input method packages that are installed. There's no uim stuff.

  • app-i18n/anthy-6700b
  • app-i18n/scim-1.4.2
  • app-i18n/scim-anthy


The PC was set up with Unicode/UTF support according to the gentoo documentation.

Using xdm for login, it's the user's $HOME/.xsession file as that gets read at login, so that's where I put
Code:
scim -d
. Alternatively, using sthe startx script to start X11, you can put it in $HOME/.xinitrc

The use flag variable for that system is set to:
Code:
USE="3dnow 3dnowext Xaw3d apache2 cddb cdr cjk dvd lesstif mime mmx mmxext
     nptl nptlonly posix sse unicode userlocales wxgtk1 xml -arts -avi
     -esd -gnome -ipv6 -kde -mad -mikmod -mp3 -oggvorbis -xmms"


That's it, as far as I can remember.
Back to top
View user's profile Send private message
Pev
n00b
n00b


Joined: 12 Nov 2003
Posts: 23
Location: Amherst, MA

PostPosted: Fri Dec 02, 2005 5:58 am    Post subject: すごい! Reply with quote

I'm not entirely clear on the process by which it occured but I fixed the problem. The trouble was that I had put my environmental variables in bashrc, which isn't always loaded in an xsession. I was getting in-kde support for the program only when I had started that program from a terminal. Putting the environment variables into .bash_profile as bunsen suggested (and then into my session files -unless I need seperate configs) solved the problem. Then, after an 'USE="gnome gtk" emerge scim-uim' (I wanted uim in case I want to do other things with it later, and the use variables pretty much on a hunch) and a reboot scim started working perfectly well in openbox, using the gtk panel. Not sure how that happened, but I am content.

Next step (eventually) is getting openoffice and latex support and trying to get a terminal with support, but I'll cross those bridges when I get to them. ありがと、bunsen-さん.

my final openbox session file:
Code:
eval `cat $HOME/.fehbg` &
export LC_CTYPE=ja_JP.utf8 &
export XMODIFIERS=@im=SCIM &
export GTK_IM_MODULE=scim &
export QT_IM_MODULE=scim &
exec /usr/bin/pypanel &
exec /usr/bin/torsmo -c /home/matt/.torsmo/torsmorc &
exec /usr/bin/scim -d &
exec openbox
Back to top
View user's profile Send private message
Bigun
Veteran
Veteran


Joined: 21 Sep 2003
Posts: 1969

PostPosted: Tue Dec 01, 2009 4:51 pm    Post subject: Reply with quote

bunsen wrote:
I can't be sure about openbox, but I do have scim and scim-anthy working for both enlightement (e16.something) and also for xfce. One thing you've not specified as having done is to start the scim daemon

In either my user .xinitrc or .xsession I include the line

Code:
scim -d
before the window manager entry, e.g.

Code:
xmodmap .Xmodmap
scim -d
#xfce4-session
#fvwm
enlightenment


This is the set of instructions that I followed: http://www.killerbob.ca/howto/japanese.html

Note that in xfce the scim panel appears straight away, whereas for enlightenment it seems to first appear when another application is opened.


The URL doesn't work anymore. Is there a E16/Japanese tutorial somewhere? Or maybe a mirror of the URL?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5585

PostPosted: Tue Dec 01, 2009 5:43 pm    Post subject: Reply with quote

:roll: Note, that tomorrow this thread would turn 4 years old.
What's more, it was providing incorrect solution in the first place.

Setting up scim is not that hard, note however, that tray icon will
fail to work with recent gtk+ (native windows problem).
You may also look at ibus.
Back to top
View user's profile Send private message
Bigun
Veteran
Veteran


Joined: 21 Sep 2003
Posts: 1969

PostPosted: Tue Dec 01, 2009 6:08 pm    Post subject: Reply with quote

Well, I've set it up using scim-setup, and using the keyboard interface didn't seem to do anything.

But I digress, I'll try ibus.
Back to top
View user's profile Send private message
Bigun
Veteran
Veteran


Joined: 21 Sep 2003
Posts: 1969

PostPosted: Tue Dec 01, 2009 6:17 pm    Post subject: Reply with quote

VoidMage wrote:
:roll: Note, that tomorrow this thread would turn 4 years old.
What's more, it was providing incorrect solution in the first place.

Setting up scim is not that hard, note however, that tray icon will
fail to work with recent gtk+ (native windows problem).
You may also look at ibus.


しゅび!ありがと!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum