Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200511-14 ] GTK+ 2, GdkPixbuf: Multiple XPM decoding vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1613

PostPosted: Wed Nov 16, 2005 3:30 pm    Post subject: [ GLSA 200511-14 ] GTK+ 2, GdkPixbuf: Multiple XPM decoding Reply with quote

Gentoo Linux Security Advisory

Title: GTK+ 2, GdkPixbuf: Multiple XPM decoding vulnerabilities (GLSA 200511-14)
Severity: normal
Exploitable: remote
Date: November 16, 2005
Bug(s): #112608
ID: 200511-14

Synopsis

The GdkPixbuf library, that is also included in GTK+ 2, contains vulnerabilities that could lead to a Denial of Service or the execution of arbitrary code.

Background

GTK+ (the GIMP Toolkit) is a toolkit for creating graphical user interfaces. The GdkPixbuf library provides facilities for image handling. It is available as a standalone library and also packaged with GTK+ 2.

Affected Packages

Package: x11-libs/gtk+
Vulnerable: < 2.8.6-r1
Unaffected: >= 2.8.6-r1
Unaffected: >= 2.6.10-r1 < 2.6.11
Unaffected: < 2.0
Architectures: All supported architectures

Package: media-libs/gdk-pixbuf
Vulnerable: < 0.22.0-r5
Unaffected: >= 0.22.0-r5
Architectures: All supported architectures


Description

iDEFENSE reported a possible heap overflow in the XPM loader (CVE-2005-3186). Upon further inspection, Ludwig Nussel discovered two additional issues in the XPM processing functions : an integer overflow (CVE-2005-2976) that affects only gdk-pixbuf, and an infinite loop (CVE-2005-2975).

Impact

Using a specially crafted XPM image an attacker could cause an affected application to enter an infinite loop or trigger the overflows, potentially allowing the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All GTK+ 2 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose x11-libs/gtk+
All GdkPixbuf users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/gdk-pixbuf-0.22.0-r5"


References

CVE-2005-2975
CVE-2005-2976
CVE-2005-3186
iDefense Security Advisory 11.15.05


Last edited by GLSA on Fri Jul 21, 2006 4:19 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum