Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200511-02 ] QDBM, ImageMagick, GDAL: RUNPATH issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1615

PostPosted: Fri Nov 04, 2005 3:49 pm    Post subject: [ GLSA 200511-02 ] QDBM, ImageMagick, GDAL: RUNPATH issues Reply with quote

Gentoo Linux Security Advisory

Title: QDBM, ImageMagick, GDAL: RUNPATH issues (GLSA 200511-02)
Severity: low
Exploitable: local
Date: November 02, 2005
Updated: May 22, 2006
Bug(s): #105717, #105760, #108534
ID: 200511-02

Synopsis

Multiple packages suffer from RUNPATH issues that may allow users in the "portage" group to escalate privileges.

Background

QDBM is a library of routines for managing a database. ImageMagick is a collection of tools to read, write and manipulate images. GDAL is a geospatial data abstraction library.

Affected Packages

Package: dev-db/qdbm
Vulnerable: < 1.8.33-r2
Unaffected: >= 1.8.33-r2
Architectures: All supported architectures

Package: media-gfx/imagemagick
Vulnerable: < 6.2.4.2-r1
Unaffected: >= 6.2.4.2-r1
Architectures: All supported architectures

Package: sci-libs/gdal
Vulnerable: < 1.3.0-r1
Unaffected: >= 1.3.0-r1
Unaffected: >= 1.2.6-r4 < 1.2.7
Architectures: All supported architectures


Description

Some packages may introduce insecure paths into the list of directories that are searched for libraries at runtime. Furthermore, packages depending on the MakeMaker Perl module for build configuration may have incorrectly copied the LD_RUN_PATH into the DT_RPATH.

Impact

A local attacker, who is a member of the "portage" group, could create a malicious shared object in the Portage temporary build directory that would be loaded at runtime by a dependent executable, potentially resulting in privilege escalation.

Workaround

Only grant "portage" group rights to trusted users.

Resolution

All QDBM users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/qdbm-1.8.33-r2"
All ImageMagick users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-6.2.4.2-r1"
All GDAL users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose sci-libs/gdal


References

CVE-2005-3580
CVE-2005-3581
CVE-2005-3582


Last edited by GLSA on Thu Dec 11, 2008 4:18 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum