Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI] Acceleration 3D sous X [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Thu Oct 06, 2005 7:31 pm    Post subject: [ATI] Acceleration 3D sous X [resolu] Reply with quote

salut !

voilà, j'ai l'impression d'avoir tout bien fait ce qu'il fallait pour avoir OpenGL accéléré avec ma Radeon9600, mais ca n'a pas l'air d'accélérer grand chose...

Code:
guillaume@coyote ~ $ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 1.3.5140 (X4.3.0-8.14.13)
OpenGL extensions:
    GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
    GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
    GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program,
    GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ATI_draw_buffers,
    GL_ATI_element_array, GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader,
    GL_ATI_map_object_buffer, GL_ATI_separate_stencil,
    GL_ATI_texture_env_combine3, GL_ATI_texture_float,
    GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
    GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
    GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
    GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_texgen_reflection,
    GL_EXT_texture3D, GL_EXT_texture_compression_s3tc,
    GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_EXT_vertex_shader,
    GL_HP_occlusion_test, GL_NV_blend_square, GL_NV_occlusion_query,
    GL_NV_texgen_reflection, GL_SGI_color_matrix, GL_SGIS_generate_mipmap,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 None
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 None
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None


la fin de Xorg.log donne :
Code:
(II) fglrx(0): [drm] loaded kernel module for "fglrx" driver
(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe09ea000
(II) fglrx(0): [drm] mapped SAREA 0xe09ea000 to 0xb7cbc000
(II) fglrx(0): [drm] framebuffer handle = 0xc0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):     Name: fglrx
(II) fglrx(0):     Version: 8.14.13
(II) fglrx(0):     Date: Jun  8 2005
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.12.5
(II) fglrx(0):     Build-Kernel MODVERSIONS:        no
(II) fglrx(0):     Build-Kernel __SMP__:            yes
(II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
(II) fglrx(0): [drm] register handle = 0xe5000000
(II) fglrx(0): [agp] Mode=0x1f000213 bridge: 0x1106/0x3099
(II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
(II) fglrx(0): [agp] AGP v3 disable mask   0x00000000
(II) fglrx(0): [agp] enabling AGP with mode=0x1f000312
(II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f000312
)
(II) fglrx(0): [agp] graphics chipset has AGP v2.0
(II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 28672
(II) fglrx(0): [drm] texture shared area handle = 0xe8c81000
(II) fglrx(0): shared FSAAScale=1
(II) fglrx(0): DRI initialization successfull!
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x00701000
(II) fglrx(0): FBMM initialized for area (0,0)-(1280,1434)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer -
assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(II) fglrx(0): Using hardware cursor (scanline 1024)
(II) fglrx(0): Largest offscreen area available: 1280 x 402
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)


de plus, glxgears me donne 1700fps en petite fenetre, et 170fps fenetre plein ecran : 1280x1024. j'ai donc l'impression que l'accélération marche bien.

pourtant les reposes ecrans OpenGL de KDE raaaaaament (1 image par seconde), j'ai installé wolfeinsein 3D c'est guerre mieux... bref je comprends pas trop.

je sais pas trop quels resultats de commande vous posert, donc n'hesitez pas a demander !

merci beaucoup

gUI


Last edited by gbetous on Sun Nov 13, 2005 8:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Thu Oct 06, 2005 7:40 pm    Post subject: Reply with quote

en fait ca va plus vite quand je fais un
Code:
opengl-update xorg-x11
qu'avec
Code:
opengl-update ati
!!!
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2873
Location: Paris

PostPosted: Thu Oct 06, 2005 7:44 pm    Post subject: Reply with quote

direct rendering: Yes
Donc l'accélération marche.

Après tout dépend comment tu as configuré fglrx (fglrxconfig). Si t'as forcé le FSAA par exemple. Sinon, t'as une 9600 gars, c'est pas non plus une bête de course (en plus je te rappelle que les perfs sont bien réduites sous linux avec fglrx par rapport au driver windows). Sans compter que t'as une résolution bien burnée (1280x1024).
Donc si t'es pas satisfait, retourne au 1024 voire moins, ou fait comme moi, trouve un coin de dur pour un xp dédié au jeu...
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Thu Oct 06, 2005 7:52 pm    Post subject: Reply with quote

El_Goretto wrote:
Sinon, t'as une 9600 gars, c'est pas non plus une bête de course


heu... je veux bien, mais un drapeau tout con avec une image dessus a 2 images par secondes faut pas pousser !

ca marche nickel avec une TNT2...

je me plonge dans le fglrxconfig alors :)

gUI
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2873
Location: Paris

PostPosted: Thu Oct 06, 2005 8:07 pm    Post subject: Reply with quote

Si c'est le même drapeau auquel je pense, gaffe, il fait effectivement ramer méchamment, il doit avoir une taille collossale en fait au niveau polygones/textures.
Vaut mieux en essayer d'autres.

Ceci dit, j'ai laché fglrx pour radeon+xinerama ya peu, donc je peux pas donner d'info précise la dessus.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
l.slysz
Apprentice
Apprentice


Joined: 03 Jun 2005
Posts: 256

PostPosted: Thu Oct 06, 2005 8:59 pm    Post subject: Reply with quote

j'ai une radeon 9700 mobility dans mon portable (ça doit etre du meme niveau que ta radeon 9600),
glxgears me donne 1900 fps en fenetre, la fenetre agrandie, ça tape entre 300 et 500 fps (1280x800)

tu dois avoir un probleme avec ton fglrx ....

j'utilise cette version de l'ebuild : media-video/ati-drivers-8.14.13-r4 -dlloader +opengl

as tu un useflag opengl dans ton make.conf ?

edit:
http://gentoo-wiki.com/HOWTO_ATI_Drivers
ça peut te servir :wink:
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2873
Location: Paris

PostPosted: Thu Oct 06, 2005 9:11 pm    Post subject: Reply with quote

l.slysz wrote:
j'ai une radeon 9700 mobility dans mon portable (ça doit etre du meme niveau que ta radeon 9600),
glxgears me donne 1900 fps en fenetre, la fenetre agrandie, ça tape entre 300 et 500 fps (1280x800)

tu dois avoir un probleme avec ton fglrx ....

Euh, fglrx marche (haha, qui a dit mal? je t'ai vu, toi au fond...) ou ne marche pas (du tout si on a oublié une chtite option kivabien), il ne peut pas avoir de "problème" à proprement parler. Pour rappel, glxgears n'est absolument pas un critère fiable de mesure de perfs. En plus, là vous n'avez pas le même chip ni la même résolution (sans parler du CPU). Et même, au final, les résultats sont similaires grosso modo, donc je comprends pas ta conclusion.

l.slysz wrote:

http://gentoo-wiki.com/HOWTO_ATI_Drivers
ça peut te servir :wink:

Certes, mais pour ceux qui ont une ATI et qui l'ignorent (ça existe encore?), ya bien plus complet, cf les docs référencés en signature.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
l.slysz
Apprentice
Apprentice


Joined: 03 Jun 2005
Posts: 256

PostPosted: Thu Oct 06, 2005 9:33 pm    Post subject: Reply with quote

El_Goretto wrote:

Euh, fglrx marche (haha, qui a dit mal? je t'ai vu, toi au fond...) ou ne marche pas (du tout si on a oublié une chtite option kivabien), il ne peut pas avoir de "problème" à proprement parler. Pour rappel, glxgears n'est absolument pas un critère fiable de mesure de perfs. En plus, là vous n'avez pas le même chip ni la même résolution (sans parler du CPU). Et même, au final, les résultats sont similaires grosso modo, donc je comprends pas ta conclusion.


bah glxgears avec mon proc à 600 ou 1600 mhz ne varie pas enormement, je trouve juste bizzare qu'il n'ait 'que' 170fps en plein ecran :?
maintenant vu que tu es une pointure sur les ati, je m'abstiendrais de reposter ici

:arrow:
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2873
Location: Paris

PostPosted: Thu Oct 06, 2005 9:49 pm    Post subject: Reply with quote

l.slysz wrote:

maintenant vu que tu es une pointure sur les ati, je m'abstiendrais de reposter ici
:arrow:

Oulà, pas de malaise, hein, j'ai pas la science infuse et je raconte mon paquet d'ânerie quand ça me prend. J'espère que je t'ai pas froissé. :?
J'ai pas de mobility et j'ai plus fglrx (me suis arrêté au 8.12), donc toute info est toujours bonne apprendre, je te prie même de rester sur le thread et de me corriger si j'en sors "une"... ;)

Fin du HS, désolé pour la parenthèse diplomatique :)
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Zanton
Apprentice
Apprentice


Joined: 16 Jan 2005
Posts: 277

PostPosted: Thu Oct 06, 2005 10:15 pm    Post subject: Reply with quote

Sur ma 9700 Pro o/c, je tourne à 3700 en petite fenetre et 360 en plein écran (1280*1024) avec les derniers drivers ati, pas ceux de Gentoo. Donc ptet que tes resultats avec ta 9600 sont bons en fait. Essaie quand même avec un opengl-update ati et regarde si dans les jeux c'est vraiment injouable.
Mes 2 cents.
_________________
Zanton
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sun Nov 13, 2005 8:05 pm    Post subject: Reply with quote

Bon, j'ai résolu mon pb. Il s'agissait d'ouvrir un tmpfs sur /dev/shm

Dans le fstab :

Code:

tmpfs /dev/shm tmpfs defaults 0 0


Voilà, ca tourne déjà bcp mieux !!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum