Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PORTAGE] xorg bloquea a nvidia. (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Excalibur
n00b
n00b


Joined: 21 Aug 2005
Posts: 21

PostPosted: Thu Oct 05, 2006 10:08 pm    Post subject: [PORTAGE] xorg bloquea a nvidia. (solved) Reply with quote

Estaba intentando ponerme Xorg modular pero me he encontrado con un problema:

Calculating dependencies... done!
-elo2300 -elographics -evdev -fpit -hyperpen -jamstudio
[blocks B ] media-video/nvidia-glx (is blocking x11-base/xorg-server-1.1.1-r1)tics -t
[blocks B ] media-video/nvidia-glx (is blocking x11-drivers/nvidia-legacy-drivers-1.0.7184)
[blocks B ] media-video/nvidia-kernel (is blocking x11-drivers/nvidia-legacy-drivers-1.0.7184)

No puedo tener xorg server y los drivers de nvidi a la vez?:S


Last edited by Excalibur on Sat Oct 07, 2006 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
ekz
l33t
l33t


Joined: 21 Jun 2006
Posts: 994
Location: Temuco - Chile

PostPosted: Fri Oct 06, 2006 12:43 am    Post subject: Reply with quote

nvidia-glx y nvidia-kernel no fueron puestos en package.mask, usandose ahora solo nvidia-drivers ?? un emerge --sync puede que ayude.. ademas que migres a nvidia-drivers
_________________
Mi tumblelog
Back to top
View user's profile Send private message
Excalibur
n00b
n00b


Joined: 21 Aug 2005
Posts: 21

PostPosted: Fri Oct 06, 2006 6:13 am    Post subject: Reply with quote

Creo que igualmente hay un conflicto entre el xorg-server y los nvidia-drivers :S, ahora resulta que he hecho un emerge --sync y se me ha estropeado portage, al intentar hacer cualquier cosa me sale esto:


Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
...........
pTraceback (most recent call last):
File "/usr/bin/emerge", line 4049, in ?
emerge_main()
File "/usr/bin/emerge", line 3770, in emerge_main
portage.global_updates(settings, trees, mtimedb["updates"])
File "/usr/lib/portage/pym/portage.py", line 6656, in global_updates
myupd)
File "/usr/lib/portage/pym/portage_update.py", line 198, in update_config_files
write_atomic(updating_file, "".join(file_contents[x]))
File "/usr/lib/portage/pym/portage_util.py", line 728, in write_atomic
f.close()
File "/usr/lib/portage/pym/portage_util.py", line 696, in close
os.rename(self.name, self._real_name)
OSError: [Errno 16] Device or resource busy


Qué cosas más extrañas me ocurren últimamente :oops:
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Fri Oct 06, 2006 8:21 am    Post subject: Reply with quote

Lee atentamente este bug:
https://bugs.gentoo.org/show_bug.cgi?id=147010

Es importante que actualices el portage en cuanto puedas:
Code:
emerge -u portage


Saludos y suerte
Back to top
View user's profile Send private message
dongeo
n00b
n00b


Joined: 27 Oct 2004
Posts: 33

PostPosted: Fri Oct 06, 2006 11:37 am    Post subject: Reply with quote

Para el xorg 7.0 y los nvidia-drivers has de usar USE="dlloader" eso lo primero.
Haz el emerge --sync y emerge -uD portage (la D es para que actualice tambien sus dependencias, sino solo actualizas el paquete portage) como ya te han comentado antes.
Si tienes una nvidia antigua (creo que hasta geforce 2, la 3 no estoy seguro) has de usar nvidia-legacy-drivers, y para las nuevas nvidia-drivers. Por lo que veo en tu sistema se estan intentando instalar ambos.
Prueba desinstalar todo nvidia,
# emerge -C nvidia-glx nvidia-kernel nvidia-drivers nvidia-legacy-drivers
y luego instala solo nvidia-drivers o nvidia-legacy-drivers, el que corresponda a tu tarjeta.
Si no funciona da mas datos, make.conf, package.keywords/mas/unmask y demas archivos que hayas personalizado.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum