Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200510-14 ] Perl, Qt-UnixODBC, CMake: RUNPATH issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1581

PostPosted: Mon Oct 17, 2005 8:26 am    Post subject: [ GLSA 200510-14 ] Perl, Qt-UnixODBC, CMake: RUNPATH issues Reply with quote

Gentoo Linux Security Advisory

Title: Perl, Qt-UnixODBC, CMake: RUNPATH issues (GLSA 200510-14)
Severity: low
Exploitable: local
Date: October 17, 2005
Updated: May 22, 2006
Bug(s): #105719, #105721, #106678
ID: 200510-14

Synopsis

Multiple packages suffer from RUNPATH issues that may allow users in the "portage" group to escalate privileges.

Background

Perl is a stable, cross-platform programming language created by Larry Wall. Qt-UnixODBC is an ODBC library for Qt. CMake is a cross-platform build environment.

Affected Packages

Package: dev-lang/perl
Vulnerable: < 5.8.7-r1
Unaffected: >= 5.8.7-r1
Unaffected: >= 5.8.6-r6 < 5.8.7
Architectures: All supported architectures

Package: dev-db/qt-unixODBC
Vulnerable: < 3.3.4-r1
Unaffected: >= 3.3.4-r1
Architectures: All supported architectures

Package: dev-util/cmake
Vulnerable: < 2.2.0-r1
Unaffected: >= 2.2.0-r1
Unaffected: >= 2.0.6-r1 < 2.0.7
Architectures: All supported architectures


Description

Some packages may introduce insecure paths into the list of directories that are searched for libraries at runtime. Furthermore, packages depending on the MakeMaker Perl module for build configuration may have incorrectly copied the LD_RUN_PATH into the DT_RPATH.

Impact

A local attacker, who is a member of the "portage" group, could create a malicious shared object in the Portage temporary build directory that would be loaded at runtime by a dependent executable, potentially resulting in privilege escalation.

Workaround

Only grant "portage" group rights to trusted users.

Resolution

All Perl users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose dev-lang/perl
All Qt-UnixODBC users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/qt-unixODBC-3.3.4-r1"
All CMake users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose dev-util/cmake


References

CVE-2005-4278
CVE-2005-4279
CVE-2005-4280


Last edited by GLSA on Mon May 22, 2006 4:19 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum