Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No console output after boot [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
jonathanross
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2005
Posts: 77
Location: Planet Earth

PostPosted: Fri Oct 07, 2005 6:36 pm    Post subject: No console output after boot [solved] Reply with quote

Hi,

I'm a big fan of Gentoo and have been trying to install it on a Netra T1. I've been through the SPARC install docs twice fully but still get this following error, it seems so simple but I can't get round it.

I can turn off the ttys to stop them respawing in inittab but it hangs like this at the end of the boot process with the default install docs:

Code:

 * Loading key mappings ...cannot open file sunkeymap

 * Error loading key mappings
                                                                          [ !! ]
 * Setting terminal encoding to ASCII .../etc/init.d/keymaps: line 71: /dev/vc/1: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/2: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/3: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/4: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/5: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/6: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/7: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/8: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/9: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/10: Permission denied
/etc/init.d/keymaps: line 71: /dev/vc/11: Permission denied
                               
 * Setting user font ...Couldnt open //dev/vc/1
Couldnt open //dev/vc/2
Couldnt open //dev/vc/3
Couldnt open //dev/vc/4
Couldnt open //dev/vc/5
Couldnt open //dev/vc/6
Couldnt open //dev/vc/7
Couldnt open //dev/vc/8
Couldnt open //dev/vc/9
Couldnt open //dev/vc/10
Couldnt open //dev/vc/11

 * Failed to set user font                                              [ !! ]
 
INIT: Id "c1" respawning too fast: disabled for 5 minutes
c2, c3 etc

INIT: no more processes left in this runlevel

Can anyone please shed some light on this ?

It might be a newbie error :o

Many thanks,

Jon


Last edited by jonathanross on Sun Oct 09, 2005 10:29 am; edited 16 times in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Oct 07, 2005 7:43 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on Sparc.
Sparc, so will probably find more response here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
jonathanross
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2005
Posts: 77
Location: Planet Earth

PostPosted: Sat Oct 08, 2005 10:09 am    Post subject: Reply with quote

I have tried everything my poor noobie brain can think of but still I get failed keymap and virtual console errors and it hangs on boot.

:oops:

Netra T1 with kernel-2.4.31-sparc-r2

Any help massively appreciated.

Jon
Back to top
View user's profile Send private message
jonathanross
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2005
Posts: 77
Location: Planet Earth

PostPosted: Sat Oct 08, 2005 12:05 pm    Post subject: Reply with quote

Progress update .... :D

I've narrowed down all of the possible errors causing this as well as recompiling the kernel with a few more built-in modules which didn't help.

## The problem is now known --> It's a console output error. Keymap and VC errors were a red herring. ##

I've managed to get the network up and running and can now get in over SSH and the whole system seems fine except :

Connecting via the LOM means it boots perfectly except there is no prompt after "No more processes in this INIT level". This is the case for both the single user mode and runlevel 3.

Can anyone please help with why the Netra T1 (sparc64 sun4u TI UltraSparc IIi ) won't output to console with a prompt after booting correctly ?

Ironically I need to use this box on a terminal server ! It's not that great not seeing any output after booting !!!!

Thanks again,

Jon


Last edited by jonathanross on Sat Oct 08, 2005 4:07 pm; edited 2 times in total
Back to top
View user's profile Send private message
jonathanross
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2005
Posts: 77
Location: Planet Earth

PostPosted: Sat Oct 08, 2005 4:06 pm    Post subject: Reply with quote

SOLVED 8O

I've finally sussed how the terminals work via the LOM during the boot process and solved this headache.

The console on a headless box seems to jump from standard LOM (like a monitor output) over to serial zero (S0) as soon as the OS is booted, effectively dropping all input and output.

Messing with the inittab and fixing the ttys for s0 and s1 (tried ./MAKEDEV ttys0) fixed this problem.

I now get the full boot process output and the spawned tty login prompt at the end via the console allowing input and output so I can hook her up to a terminal server happily.

Hopefully this doc will assist someone in the future.

Thank you everyone for your help :P

Jon
Back to top
View user's profile Send private message
linnov
n00b
n00b


Joined: 16 Aug 2004
Posts: 5

PostPosted: Sat Oct 22, 2005 2:28 am    Post subject: Reply with quote

can you post your inittab I am having the same problem with a sun box
Back to top
View user's profile Send private message
FreddieD
n00b
n00b


Joined: 16 Nov 2005
Posts: 1

PostPosted: Wed Nov 16, 2005 5:20 am    Post subject: Reply with quote

In /etc/inittab, for me on my ultra5 it was as easy as uncommenting the s0 line:

Code:
# SERIAL CONSOLES
s0:12345:respawn:/sbin/agetty 9600 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty 9600 ttyS1 vt100


For me, the s0 is the 25 pin serial so I can only assume that s1 is the 9 pin serial.

I should also probably mention that to turn off all of the annoying "respawning too fast: disabled for 5 minutes" messages, comment out the c1-c6 lines under TERMINALS in your inittab:

Code:
# TERMINALS
#c1:12345:respawn:/sbin/agetty 38400 tty1 linux
#c2:12345:respawn:/sbin/agetty 38400 tty2 linux
#c3:12345:respawn:/sbin/agetty 38400 tty3 linux
#c4:12345:respawn:/sbin/agetty 38400 tty4 linux
#c5:12345:respawn:/sbin/agetty 38400 tty5 linux
#c6:12345:respawn:/sbin/agetty 38400 tty6 linux


Good luck!

-Fred
Back to top
View user's profile Send private message
Sunthief
n00b
n00b


Joined: 22 Dec 2005
Posts: 34
Location: Grand Forks, BC

PostPosted: Thu Dec 22, 2005 5:26 am    Post subject: Reply with quote

Thank you sooo much for that information, i was banging my head against the wall for hours trying to figure that out!! Good job!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum