Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200510-03 ] Uim: Privilege escalation vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Tue Oct 04, 2005 6:25 pm    Post subject: [ GLSA 200510-03 ] Uim: Privilege escalation vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: Uim: Privilege escalation vulnerability (GLSA 200510-03)
Severity: normal
Exploitable: local
Date: October 04, 2005
Updated: May 22, 2006
Bug(s): #107748
ID: 200510-03

Synopsis


Under certain conditions, applications linked against Uim suffer from a
privilege escalation vulnerability.


Background


Uim is a multilingual input method library which provides secure and
useful input method for all languages.


Affected Packages

Package: app-i18n/uim
Vulnerable: < 0.4.9.1
Unaffected: >= 0.4.9.1
Architectures: All supported architectures


Description


Masanari Yamamoto discovered that Uim uses environment variables
incorrectly. This bug causes a privilege escalation if setuid/setgid
applications are linked to libuim. This bug only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE="immqt" or USE="immqt-bc").


Impact


A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.


Workaround


There is no known workaround at this time.


Resolution


All Uim users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.9.1"


References

Original advisory
CVE-2005-3149


Last edited by GLSA on Sat Apr 12, 2014 4:21 am; edited 6 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum