Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Glibc overlay with amd64 performance patches! (obsolete)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 21, 22, 23  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Wed Feb 15, 2006 8:50 am    Post subject: Reply with quote

piwacet wrote:
dirtyepic wrote:
Code:
[06:31] <CIA-2> azarah * gentoo/src/patchsets/glibc/2.3.6/ (16 files):
[06:31] <CIA-2> Add -Bdirect and amd64 string/math patches among other things.
[06:31] <CIA-2> Many thanks to Simon Strandman for his work on maintaining the patchset for 2.3.90
[06:31] <CIA-2> I used to port these patches to 2.3.6.


:o


Err - pardon my ignorance, but what does this mean?

I think it means if you just want -Bdirect, you won't need to use an overlay anymore. I wonder what "among other things" includes.
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Wed Feb 15, 2006 9:01 am    Post subject: Reply with quote

I was wondering if it meant something like that - that these patches are now somewhere officially in portage. Presumably the AMD64 patches are in there as well. Are they included in a version of glibc now? That would be pretty cool.
Back to top
View user's profile Send private message
jonnevers
Veteran
Veteran


Joined: 02 Jan 2003
Posts: 1592
Location: Gentoo64 land

PostPosted: Wed Feb 15, 2006 2:39 pm    Post subject: Reply with quote

Excellent!

Code:

standard glibc: Memory to memory copy rate = 1411.846802 MBytes / sec. Block size = 1048576.
hacked glibc:   Memory to memory copy rate = 2221.216797 MBytes / sec. Block size = 1048576.

I haven't had any stability issues and I run the machine fairly hard. UT, vmware, OOorg, eclipse, etc.

- Jon
Back to top
View user's profile Send private message
Ulukay
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2002
Posts: 143

PostPosted: Wed Feb 15, 2006 7:55 pm    Post subject: Reply with quote

before:
./a.out 2200 1000 1048576
Memory to memory copy rate = 1242.778442 MBytes / sec. Block size = 1048576.

after:
./a.out 2200 1000 1048576
Memory to memory copy rate = 1240.049316 MBytes / sec. Block size = 1048576.


something isn't right :(

Code:
Portage 2.1_pre4-r1 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.6-r2, 2.6.12.3 i686)
=================================================================
System uname: 2.6.12.3 i686 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
dev-lang/python:     2.2.3-r5, 2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg cvs distlocks keeptemp keepwork noauto noclean notitles sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://ftp.easynet.nl/mirror/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://gentoo.inode.at/source/ rsync://gd.tuwien.ac.at/opsys/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X alsa apm arts avi berkdb bitmap-fonts cups dga eds emboss encode fbcon foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 imlib jpeg kde libclamav libg++ libwww lm_sensors mad mikmod mmx motif mp3 mpeg ncurses nls nocardbus nptl nvidia oav ogg oggvorbis opengl pam pda pdflib perl png ppds python qt quicktime readline samba sdl smp spell sse ssl tcpd threads truetype truetype-fonts type1-fonts usb vorbis win32codecs xml2 xmms xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, LDFLAGS, LINGUAS


any hints?
_________________
Jeden Tag erhöht sich zwangsläufig die Anzahl derer, die mich
am Arsch lecken können... Das ist heute DEIN Tag!
Back to top
View user's profile Send private message
R. Daneel Olivaw
n00b
n00b


Joined: 06 Jul 2004
Posts: 47

PostPosted: Wed Feb 15, 2006 8:15 pm    Post subject: Reply with quote

Ulukay wrote:



something isn't right :(


you seem to use a 32 bits gentoo

i fear the amd64 optimization are 64 bits specific
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Wed Feb 15, 2006 8:46 pm    Post subject: Reply with quote

StringCheesian wrote:
piwacet wrote:
dirtyepic wrote:
Code:
[06:31] <CIA-2> azarah * gentoo/src/patchsets/glibc/2.3.6/ (16 files):
[06:31] <CIA-2> Add -Bdirect and amd64 string/math patches among other things.
[06:31] <CIA-2> Many thanks to Simon Strandman for his work on maintaining the patchset for 2.3.90
[06:31] <CIA-2> I used to port these patches to 2.3.6.


:o


Err - pardon my ignorance, but what does this mean?

I think it means if you just want -Bdirect, you won't need to use an overlay anymore. I wonder what "among other things" includes.


The patches are in CVS but haven't been added to any ebuild in portage yet so an overlay is still needed. The "other things" are some of the bugfixes and other patches I have in my overlay + the hashvals patch.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 426

PostPosted: Thu Feb 16, 2006 6:44 am    Post subject: Reply with quote

Quote:
You should also edit the file /etc/env.d/00basic and add LD_BIND_DIRECT=1.


This is a quote from the first page.... I have a question about the syntax.......

Should the 1 have quotations around it or not?

example.....

Quote:
LD_BIND_DIRECT=1



or should it be like this????

Quote:
LD_BIND_DIRECT="1"
Back to top
View user's profile Send private message
R. Daneel Olivaw
n00b
n00b


Joined: 06 Jul 2004
Posts: 47

PostPosted: Thu Feb 16, 2006 9:43 am    Post subject: Reply with quote

i think it doesn't matter
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Thu Feb 16, 2006 10:04 am    Post subject: Reply with quote

No it shouldn't matter, though I changed to first post to say LD_BIND_DIRECT="1" since that's how the other entries looks like.
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Fri Feb 17, 2006 7:27 am    Post subject: Reply with quote

Is there anywhere there is a listning of patches in the portage tree and which version of binutils and glibc they are applied to, like gentoo-sources have?

What I really am looking for is if the -Bdirect-patch is applied to any other version than 2.16.1-r1.
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Fri Feb 17, 2006 8:03 am    Post subject: Reply with quote

Xake wrote:
Is there anywhere there is a listning of patches in the portage tree and which version of binutils and glibc they are applied to, like gentoo-sources have?

What I really am looking for is if the -Bdirect-patch is applied to any other version than 2.16.1-r1.


Here:
http://www.gentoo.org/cgi-bin/viewcvs.cgi/src/patchsets/binutils/?root=gentoo

It's not applied to any other version than 2.16.1-r1 and that's the older patch. It's proabably better to have your own binutils overlay until the binutils in portage gets updated.
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Fri Feb 17, 2006 11:46 am    Post subject: Reply with quote

Download http://enderandrew.com/conrad/root-overlay-nesl247.tar.bz2, untar it to a seperate file, and copy the binutils from it.
Back to top
View user's profile Send private message
wiSHmaKeR
n00b
n00b


Joined: 04 May 2004
Posts: 44
Location: Stara Zagora, Bulgaria

PostPosted: Sat Feb 18, 2006 2:50 pm    Post subject: Reply with quote

Bravo, I would say! No more segmentation faults on ebuild compilations, which were a big problem for me before :)
Works great, and the results seem faster by more than two times!

Code:
Before:
Memory to memory copy rate = 865.212524 MBytes / sec. Block size = 1048576.
After:
Memory to memory copy rate = 1845.094604 MBytes / sec. Block size = 1048576.


Thank you for this overlay, it works absolutely great :)
_________________
And all your wishes come true... :)
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Sat Feb 18, 2006 3:18 pm    Post subject: Reply with quote

If do not know if you know this yet, but I will tell you anyway ;)

Gentoo Glibc patch ver: 1.7 (2.3.6-r3) includes the following patches already, I just updated the ebuild and excluded them.

2020_all_glibc-2.3.5-gcc4-sanitize-omitfp-optimizations.patch
3000_all_glibc-2.3.6-ld-so-madvise.patch
3001_all_glibc-gentoo-hashvals.patch
3002_all_glibc-bdirect.patch

This is my other pc, so the patch names arent exact because I had to type them.

i do not know if you knew this and that is why you were using patchver 1.4 or what, I just thought I would point it out to you.
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Sat Feb 18, 2006 3:37 pm    Post subject: Reply with quote

Yes the new 2.3.6-r3 ebuild has the patches. :) But the -Bdirect/-hashvals stuff is disabled by default. I'll probably drop the 2.3.6 ebuild from my overlay since there isn't much point maintaing it anymore.
Back to top
View user's profile Send private message
Enverex
Guru
Guru


Joined: 02 Jul 2003
Posts: 501
Location: Worcester, UK

PostPosted: Sun Feb 19, 2006 2:15 pm    Post subject: Reply with quote

So, do we still need this overlay or are these patches now part of glibc by default?
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Sun Feb 19, 2006 3:14 pm    Post subject: Reply with quote

NightShade737 wrote:
So, do we still need this overlay or are these patches now part of glibc by default?


No you can use 2.3.6-r3 in portage, it has all of these changes except nomallocheck. I'm going to focus on 2.3.90 now instead but I'll make another thread about that.
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Sun Feb 19, 2006 3:47 pm    Post subject: Reply with quote

So, I uploaded the Böhm sat solver including a test case. Get it here:

[url]http://punnoor.de/various/böhm-sat.tar.bz2[/url]

Just run "runme10.sh" and check the last lines of each run. If this isn't precise enough, run the full test-case (runme.sh).

On Athlon X2 2GHz(in 64 bit mode) sat32 should take about 17sec and sat64 about 24sec. The full testcase 146 resp 226 (or was it 206?) seconds.

With 2.3.90 glibc the testcases needs about double the time.
Back to top
View user's profile Send private message
ViRgiLiO
n00b
n00b


Joined: 18 Jan 2005
Posts: 17

PostPosted: Sun Feb 19, 2006 9:10 pm    Post subject: Reply with quote

I have some problems compiling glibc 2.3.6-r3.

My emerge info:
Code:

Portage 2.1_pre4-r1 (default-linux/x86/2005.0, gcc-4.0.2-20051117, glibc-2.3.90.20060207-r0, 2.6.15-ck4 i686)
=================================================================
System uname: 2.6.15-ck4 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.0_pre16
ccache version 2.4 [disabled]
dev-lang/python:     2.3.5, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=athlon-xp  -fomit-frame-pointer -pipe -fPIC"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -mtune=athlon-xp  -fomit-frame-pointer -pipe -fPIC -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="es_ES@euro"
LC_ALL="es_ES@euro"
LDFLAGS="-Wl,-O1 -Wl,-Bdirect"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts cdrom cjk crypt dlloader dlopen dvd dvdr eds emboss encode foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad mikmod motif mp3 mpeg mpeg4 ncurses nls nptl nvidia ogg oggvorbis opengl oss pam pdflib perl pic png prelink python qt quicktime readline sdl spell ssl strip tcpd truetype truetype-fonts type1-fonts usb vorbis xml2 xmms xv xvmc zlib elibc_glibc kernel_linux linguas_es userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS


Error:
Code:

i686-pc-linux-gnu-gcc ../nptl/sysdeps/unix/sysv/linux/getpid.c -c -std=gnu99 -O2 -Wall -Winline -Wstrict-protot
ypes -Wwrite-strings -fPIC -mtune=athlon-xp -pipe -mpreferred-stack-boundary=2  -g0 -O2 -fgcse-after-reload -fi
nline-functions -fomit-frame-pointer -D__USE_STRING_INLINES  -fomit-frame-pointer  -I../include -I. -I/var/tmp/
portage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl/posix -I.. -I../libio -I../nptl -I/var/tmp/por
tage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv
/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pth
read -I../sysdeps/pthread -I../nptl/sysdeps/unix/sysv -I../nptl/sysdeps/unix -I../nptl/sysdeps/i386/i686 -I../n
ptl/sysdeps/i386 -I../libidn/sysdeps/unix -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux -I../s
ysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386 -
I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I
../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../sysdeps/i386
 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32                                                    -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -nostdinc -isystem /usr/lib/gcc/i686-pc-linu                                                   x-gnu/4.0.2-20051117/include -isystem /usr/include -D_LIBC_REENTRANT -D_LIBC_REENTRANT -include ../include/libc                                                   -symbols.h       -o /var/tmp/portage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl/posix/getpid.o -M                                                   D -MP -MF /var/tmp/portage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl/posix/getpid.o.dt -MT /var/                                                   tmp/portage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl/posix/getpid.o
../nptl/sysdeps/unix/sysv/linux/i386/../fork.c: In function '__libc_fork':
../nptl/sysdeps/unix/sysv/linux/i386/../fork.c:203: error: can't find a register in class 'BREG' while reloadin                                                   g 'asm'
make[2]: *** [/var/tmp/portage/glibc-2.3.6-r3/work/build-default-i686-pc-linux-gnu-nptl/posix/fork.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.6-r3/work/glibc-2.3.6/posix'
make[1]: *** [posix/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.6-r3/work/glibc-2.3.6'
make: *** [all] Error 2

!!! ERROR: sys-libs/glibc-2.3.6-r3 failed.
Call stack:
  ebuild.sh, line 1894:   Called dyn_compile
  ebuild.sh, line 941:   Called src_compile
  glibc-2.3.6-r3.ebuild, line 1254:   Called toolchain-glibc_src_compile

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Sun Feb 19, 2006 9:28 pm    Post subject: Reply with quote

ViRgiLiO wrote:
I have some problems compiling glibc 2.3.6-r3.

My emerge info:
[code]
Portage 2.1_pre4-r1 (default-linux/x86/2005.0, gcc-4.0.2-20051117, glibc-2.3.90.20060207-r0, 2.6.15-ck4 i686)


You have glibc 2.3.90 installed, why do you want to downgrade? That might break stuff that is compiled against the newer glibc.
Back to top
View user's profile Send private message
6D7474
Tux's lil' helper
Tux's lil' helper


Joined: 08 Sep 2005
Posts: 135

PostPosted: Sun Feb 19, 2006 9:50 pm    Post subject: Reply with quote

@ViRgiLiO: don't put -fPIC to your CFLAGS. it's supposed to be used for libraries only... when it's necessary it's automaticly enabled by ebuilds.
Back to top
View user's profile Send private message
ViRgiLiO
n00b
n00b


Joined: 18 Jan 2005
Posts: 17

PostPosted: Sun Feb 19, 2006 10:09 pm    Post subject: Reply with quote

Ok. I've removed -fPIC from CFLAGS, and yes, I won't downgrade to 2.3.6 version. I heard above that 2.3.6-r3 is similar to 2.3.90 and the overlay package won't be mantained.
Back to top
View user's profile Send private message
SteveYin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 88

PostPosted: Mon Feb 20, 2006 7:26 am    Post subject: Reply with quote

cheater1034 wrote:
If do not know if you know this yet, but I will tell you anyway ;)

Gentoo Glibc patch ver: 1.7 (2.3.6-r3) includes the following patches already, I just updated the ebuild and excluded them.

2020_all_glibc-2.3.5-gcc4-sanitize-omitfp-optimizations.patch
3000_all_glibc-2.3.6-ld-so-madvise.patch
3001_all_glibc-gentoo-hashvals.patch
3002_all_glibc-bdirect.patch

This is my other pc, so the patch names arent exact because I had to type them.

i do not know if you knew this and that is why you were using patchver 1.4 or what, I just thought I would point it out to you.


today I tried to emerge glibc-2.3.6-r3, but I don't see these two patch:
3001_all_glibc-gentoo-hashvals.patch
3002_all_glibc-bdirect.patch

I'm using binutils-2.16.1-r1 with bdirect patched, So, can I use this version of glibc without bdirect patch to glibc?
_________________
Steve Yin
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Mon Feb 20, 2006 8:15 am    Post subject: Reply with quote

ViRgiLiO wrote:
Ok. I've removed -fPIC from CFLAGS, and yes, I won't downgrade to 2.3.6 version. I heard above that 2.3.6-r3 is similar to 2.3.90 and the overlay package won't be mantained.


2.3.6 is not similar to 2.3.90. And I will continue maintain them. I just posted another thread about it. It's just the stable ebuild I wont maintain since it's in portage now.
Back to top
View user's profile Send private message
nxsty
Veteran
Veteran


Joined: 23 Jun 2004
Posts: 1556
Location: .se

PostPosted: Mon Feb 20, 2006 8:16 am    Post subject: Reply with quote

SteveYin wrote:
today I tried to emerge glibc-2.3.6-r3, but I don't see these two patch:
3001_all_glibc-gentoo-hashvals.patch
3002_all_glibc-bdirect.patch

I'm using binutils-2.16.1-r1 with bdirect patched, So, can I use this version of glibc without bdirect patch to glibc?


They're included but disabled by default. You have to edit the ebuild and remove the patch exclude stuff.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 21, 22, 23  Next
Page 22 of 23

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum