Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
transcode fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
burzmali
Apprentice
Apprentice


Joined: 18 Apr 2002
Posts: 238
Location: ca

PostPosted: Thu May 30, 2002 12:50 am    Post subject: transcode fails to compile Reply with quote

hello, i get the following error when i do 'emerge -up world' on the transcode part
Code:
gcc -DHAVE_CONFIG_H -I.. -I. -I.. -I. -Wall -I./ -I../src -I../avilib -I../encore2 -I../libac3 -I./../libac3 -I../libmpeg2 -I./../libmpeg2 -I../libvo -I../dvdread -I./../src -I./../avilib -I./../encore2 -I./../libvo -I./../dvdread -I/usr/include -I/usr/local/include -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/include -I/usr/include/libmpeg3 -I/usr/local/include/libmpeg3 -I/usr/include -I/usr/local/include -I/usr/include/avifile -I/usr/include/libxml2 -D_REENTRANT -funroll-loops -ffast-math -Wall -DMOD_PATH=\"/usr/lib/transcode\" -march=i686 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -malign-functions=4 -O3 -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -c a52_decore.c -Wp,-MD,.deps/a52_decore.TPlo  -fPIC -DPIC -o a52_decore.lo
a52_decore.c: In function `a52_decore':
a52_decore.c:98: `MM_ACCEL_DJBFFT' undeclared (first use in this function)
a52_decore.c:98: (Each undeclared identifier is reported only once
a52_decore.c:98: for each function it appears in.)
a52_decore.c:110: warning: assignment from incompatible pointer type
a52_decore.c:202: too few arguments to function `a52_block'
a52_decore.c:206: warning: implicit declaration of function `a52_samples'
a52_decore.c:206: warning: assignment makes pointer from integer without a cast
make[3]: *** [a52_decore.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/transcode-0.6.0_pre5-r1/work/transcode-0.6.0pre5/import'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/transcode-0.6.0_pre5-r1/work/transcode-0.6.0pre5/import'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/transcode-0.6.0_pre5-r1/work/transcode-0.6.0pre5'
make: *** [all] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line -32, Exitcode 2
!!! (no error message)

!!! emerge aborting on  /usr/portage/media-video/transcode/transcode-0.6.0_pre5-r1.ebuild .


any ideas what this could be? i doupt it is the libdv version as the previos transcode compiled without a problem. thank you for any help.
_________________
burzmali
www.burzmali.net
Back to top
View user's profile Send private message
col
l33t
l33t


Joined: 08 May 2002
Posts: 818
Location: Melbourne - Australia

PostPosted: Thu May 30, 2002 1:17 am    Post subject: Reply with quote

emerge a52dec

dependencies for transocode are all screwed up
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Thu May 30, 2002 8:43 am    Post subject: Reply with quote

Maybe you should add the problem + solve in the BUG section so the maintainter of the package can fix it (one little silly line, that isn't too bad to fix). :wink:
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum