Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Setting up Apache and localhost
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Off the Wall
View previous topic :: View next topic  
Author Message
TripleD
n00b
n00b


Joined: 21 Jan 2003
Posts: 30

PostPosted: Fri Feb 21, 2003 3:37 pm    Post subject: Setting up Apache and localhost Reply with quote

I'm trying too setup apache using the reference in the Desktop Config, but am unable to connect to localhost. I was wondering if someone could point out any problems they see, and if possible, maybe someone who has a working install of apace for localhost post there config?

I've been muking with the config files, but have put them back to how they were installed, accept for this one. Even on a fresh install i am still unable too access it via localhost.

apache.conf:

### You really shouldn't change these settings unless you're a guru
###
ServerType standalone
ServerRoot /etc/apache
ServerName localhost
#LockFile /etc/httpd/httpd.lock
PidFile /var/run/apache.pid
ScoreBoardFile /etc/apache/apache.scoreboard
ErrorLog logs/error_log
LogLevel warn
ResourceConfig /dev/null
AccessConfig /dev/null
DocumentRoot /Web/httpd/htdocs


### Dynamic Shared Object (DSO) Support

permissions are set for the directory:

Script started on Fri Feb 21 10:28:33 2003
ddavid@david:/Web^Gbash-2.05b$ ls -l
total 24
-rw-r--r-- 1 ddavid users 400 Feb 21 10:27 dir.log
drwxr-xr-x 5 ddavid root 4096 Feb 19 17:57 httpd
drwx------ 2 ddavid root 16384 Feb 16 14:02 lost+found
ddavid@david:/Web bash-2.05b$ cd httpd
ddavid@david:/Web/httpd^Gbash-2.05b$ ls -l
total 12
drwxr-xr-x 2 ddavid root 4096 Feb 19 17:41 cgi-bin
drwxr-xr-x 3 ddavid root 4096 Feb 19 19:49 htdocs
drwxr-xr-x 3 ddavid root 4096 Feb 19 17:41 icons
ddavid@david:/Web/httpd^Gbash-2.05b$
ddavid@david:/Web/httpd bash-2.05b$ exit

Script done on Fri Feb 21 10:29:08 2003

error message in browser:
Forbidden

You don't have permission to access / on this server.

Apache/1.3.27 Server at localhost Port 80

[Wed Feb 19 19:52:59 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Feb 19 19:52:59 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Feb 19 19:53:03 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/
[Wed Feb 19 19:53:03 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/
[Wed Feb 19 19:53:09 2003] [notice] caught SIGTERM, shutting down
[Fri Feb 21 09:21:21 2003] [notice] Apache/1.3.27 (Unix) (Gentoo/Linux) mod_ssl/2.8.12 OpenSSL/0.9.6g PHP/4.3.0 configured -- resuming normal operations
[Fri Feb 21 09:21:21 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Feb 21 09:21:21 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Fri Feb 21 10:18:48 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/
[Fri Feb 21 10:18:48 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/
[Fri Feb 21 10:18:48 2003] [error] [client 127.0.0.1] File does not exist: /Web/httpd/htdocs/favicon.ico
[Fri Feb 21 10:32:14 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/
[Fri Feb 21 10:32:14 2003] [error] [client 127.0.0.1] Directory index forbidden by rule: /Web/httpd/htdocs/

Any idea's? more info?

Thanks

David

P.S: I'm setting up a website using Postnuke, and want too get it going on my machine first before uploading too a server
Back to top
View user's profile Send private message
dirtyjake
n00b
n00b


Joined: 06 Jul 2002
Posts: 60

PostPosted: Sat Feb 22, 2003 12:15 am    Post subject: Reply with quote

You need something like this in your .conf file.

Code:

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory "/Web/httpd/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
Back to top
View user's profile Send private message
kyonos
n00b
n00b


Joined: 04 Nov 2002
Posts: 48

PostPosted: Sat Mar 15, 2003 6:00 pm    Post subject: Changing DocumentRoot, don't have permission to access / Reply with quote

I am having the same problem mentioned as above, adding this in /etc/apache/conf/apache.conf, and still have the same negative result (after restart apache).

Code:

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory "/home/httpd/sites">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>


Any clues?
Back to top
View user's profile Send private message
kyonos
n00b
n00b


Joined: 04 Nov 2002
Posts: 48

PostPosted: Sat Mar 15, 2003 7:16 pm    Post subject: Changing DocumentRoot value Reply with quote

Hi,
After further investigation, in /etc/apache/conf/apache.conf: DocumentRoot should be placed after Include conf/commonapache.conf.
In another related point, in gentoo desktop guide:
Quote:


You can check to make sure your Apache web server is working by using any browser to connect to localhost. To make sure that SSL support is functional, use a browser to connect to https://localhost. The https prefix tells the browser to make a secure connection to the server using SSL. Graphical browsers will have a padlock icon somewhere indicating the secure connection.



I also found out, when I try https://localhost/test.php, no matter what DocumentRoot contains, or where it's placed, it behaves as if the value is /home/httpd/htdocs,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Off the Wall All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum