Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Opera/Konqueror have no accents [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Greek
View previous topic :: View next topic  
Author Message
coralsaw
n00b
n00b


Joined: 09 Jun 2005
Posts: 57

PostPosted: Wed Aug 10, 2005 7:23 am    Post subject: Opera/Konqueror have no accents [SOLVED] Reply with quote

Hello,

I followed the advice in Greek Accented Vowels Howto sticky thread and now I can perfectly well Alt-Shift and write in Greek. I can also write accented Greek in aMule, for instance.

What I can't do is write accented Greek in Opera, or Konqueror. Greek is ok, but when I press the accent key <;> and a letter it doesn't come up. Pressing it again gives me the apostrophe. Clearly I need to do something more but what? BTW, I'm not interested in console Greek for the moment, just X.

Here's the output of locale
Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=
LC_CTYPE=el_GR
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE=el_GR
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Here's the output of locale -a
Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
de_DE
de_DE@euro
en_HK
en_PH
en_US
en_US.utf8
es_MX
fa_IR
fr_FR
fr_FR@euro
it_IT
ja_JP
ja_JP.eucjp
ja_JP.utf8

Here's the last 2 lines of my /etc/profile
Code:
export LC_CTYPE="el_GR"
export LC_COLLATE="el_GR"

Clearly something is wrong. Can you please help?

Ευχαριστώ πολύ,

/coralsaw


Last edited by coralsaw on Sat Aug 20, 2005 11:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
parapente
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2003
Posts: 140
Location: Greece

PostPosted: Wed Aug 10, 2005 2:19 pm    Post subject: Reply with quote

Apo oti blepw coralsaw kati paizei me ta locale sou. Sto locale -a pou etre3es den blepw na sou ebgale to el_GR. Enw edw:
Code:
$ locale -a |grep el_GR
el_GR
el_GR.utf8

Ta locale mpainoun otan ginetai emerge h glibc. Mhpws exeis kanei tpt sta locale esy? Epishs den mas eipes pou exeis balei ta export LC_CTYPE kai LC_COLLATE (se poio arxeio ennow).

The message in English:
There seems to be a problem with your locales. The output of locale -a that you gave us has no reference of el_GR anywhere. When I try it here I get:
Code:
$ locale -a |grep el_GR
el_GR
el_GR.utf8

Have you done anything with the locales? locales are installed during the installation of glibc. Also you haven't told us where exactly you have done the exports of LC_CTYPE and LC_COLLATE (which files I mean).
Back to top
View user's profile Send private message
coralsaw
n00b
n00b


Joined: 09 Jun 2005
Posts: 57

PostPosted: Wed Aug 10, 2005 3:08 pm    Post subject: Reply with quote

parapente wrote:
Have you done anything with the locales? locales are installed during the installation of glibc. Also you haven't told us where exactly you have done the exports of LC_CTYPE and LC_COLLATE (which files I mean).


Thx for the reply parapente (I'll stick to En for the moment, if it's ok). I haven't done anything with the locales, perhaps I need to install more? How is this done?

Regarding the LC_CTYPE and LC_COLLATE, I added them in /etc/profile.

/coralsaw
Back to top
View user's profile Send private message
Slammer
Moderator
Moderator


Joined: 28 Mar 2003
Posts: 270
Location: Greece

PostPosted: Wed Aug 10, 2005 10:54 pm    Post subject: Reply with quote

Your glibc does not support Greek locales.
Rebuild your glibc adding the el_GR.UTF-8 locale.

EDIT
Modify the /etc/locales.build file and include the following lines:
Code:

el_GR/ISO-8859-7
el_GR.UTF-8/UTF-8


Rebuild at least glibc (I dont know if you have to rebuild more packages)
Now the Greek locales have to be available.
_________________
Keep Slamming...
Back to top
View user's profile Send private message
coralsaw
n00b
n00b


Joined: 09 Jun 2005
Posts: 57

PostPosted: Sat Aug 20, 2005 11:09 pm    Post subject: Reply with quote

Works fine, thx Slammer! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Greek All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum