Joined: 12 May 2004
|Posted: Fri Aug 05, 2005 11:04 am Post subject: [ GLSA 200508-04 ] Netpbm: Arbitrary code execution in pstop
|Gentoo Linux Security Advisory
Title: Netpbm: Arbitrary code execution in pstopnm (GLSA 200508-04)
Date: August 05, 2005
Updated: May 28, 2009
The pstopnm utility, part of the Netpbm tools, contains a vulnerability which can potentially result in the execution of arbitrary code.
Netpbm is a package of 220 graphics programs and a programming libraries, including pstopnm. pstopnm is a tool which converts PostScript files to PNM image files.
Vulnerable: < 10.28
Unaffected: >= 10.28
Unaffected: >= 10.26.32 < 10.26.33
Unaffected: >= 10.26.33 < 10.26.34
Unaffected: >= 10.26.42 < 10.26.43
Unaffected: >= 10.26.43 < 10.26.44
Unaffected: >= 10.26.44 < 10.26.45
Unaffected: >= 10.26.48 < 10.26.49
Unaffected: >= 10.26.49 < 10.26.50
Unaffected: >= 10.26.59 < 10.26.60
Unaffected: >= 10.26.61 < 10.26.62
Architectures: All supported architectures
Max Vozeler reported that pstopnm calls the GhostScript interpreter on untrusted PostScript files without specifying the -dSAFER option, to convert a PostScript file into a PBM, PGM, or PNM file.
An attacker could craft a malicious PostScript file and entice a user to run pstopnm on it, resulting in the execution of arbitrary commands with the permissions of the user running pstopnm.
There is no known workaround at this time.
All Netpbm users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose media-libs/netpbm
Secunia Advisory SA16184
Last edited by GLSA on Fri May 29, 2009 4:16 am; edited 5 times in total