Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] emerge pvm doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gophix
n00b
n00b


Joined: 10 Oct 2003
Posts: 10
Location: Köln

PostPosted: Wed Dec 01, 2004 10:42 am    Post subject: [solved] emerge pvm doesn't work Reply with quote

I tried to install pvm, but it doesn't work. I got this error.
Code:

grep: /var/tmp/portage/pvm-3.4.4-r1/work/pvm3/conf/LINUXI386.def: No such file or directory
making in . for LINUXI386
./lib/aimk: line 100: exec: PVM_ARCH=LINUXI386: not found
make: *** [default] Error 127

!!! ERROR: sys-cluster/pvm-3.4.4-r1 failed.
!!! Function src_compile, Line 27, Exitcode 2


So I insert 2 lines in the ebuild (should be in /var/portage/sys-cluster/pvm/). Now gentoo compiles it very well for i386.

Code:

# setup def files for other archs
# following 2 lindes instert !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
        cp conf/LINUX.def conf/LINUXI386.def 
        cp conf/LINUX.m4 conf/LINUXI386.m4

        cp conf/LINUX.def conf/LINUXX86_64.def
        cp conf/LINUX.m4 conf/LINUXX86_64.m4
        cp conf/LINUX64.def conf/LINUXIA64.def
        cp conf/LINUX64.m4 conf/LINUXIA64.m4
        cp conf/LINUX64.def conf/LINUXPPC64.def
        cp conf/LINUX64.m4 conf/LINUXPPC64.m4


Have a nice day ;-)

PS: "bug" isn't reported, do I have to?
Back to top
View user's profile Send private message
dberkholz
Developer
Developer


Joined: 18 Mar 2003
Posts: 1008
Location: Minneapolis, MN, USA

PostPosted: Sun Feb 20, 2005 9:53 am    Post subject: Re: [solved] emerge pvm doesn't work Reply with quote

gophix wrote:
PS: "bug" isn't reported, do I have to?

Someone else was kind enough to do it for you: http://bugs.gentoo.org/show_bug.cgi?id=82614

It should be fixed in >=3.4.4-r3.
Back to top
View user's profile Send private message
Chewieip
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2004
Posts: 79
Location: Girona, Spain

PostPosted: Tue Mar 01, 2005 3:49 pm    Post subject: Reply with quote

I need also the pvm module to work with a multi-computer (it's for practical classes in university). And I can't do the emerge. I've followed gophix step's but I gives me the same error.

I'm working with 3.4.4-r3 version. Any solution?

P.D: I'm using a Centrino or a Athlon XP. Both of them are i686.
_________________
El único caso en que P= NP es cuando N = 1.
Back to top
View user's profile Send private message
dberkholz
Developer
Developer


Joined: 18 Mar 2003
Posts: 1008
Location: Minneapolis, MN, USA

PostPosted: Tue Mar 01, 2005 4:03 pm    Post subject: Reply with quote

Chewieip wrote:
I need also the pvm module to work with a multi-computer (it's for practical classes in university). And I can't do the emerge. I've followed gophix step's but I gives me the same error.

I'm working with 3.4.4-r3 version. Any solution?

P.D: I'm using a Centrino or a Athlon XP. Both of them are i686.

Try the latest version, of course. =)
Back to top
View user's profile Send private message
cory2070
n00b
n00b


Joined: 14 Feb 2005
Posts: 3
Location: BC, Canada

PostPosted: Wed Mar 09, 2005 7:10 pm    Post subject: Reply with quote

should be /usr/portage/sys-cluster/pvm/pvm-3.4.4-r2.ebuild

I can't get anything above 3.4.4-r2 to compile, but adding those two lines to the ebuild works great.

Thanks!
Back to top
View user's profile Send private message
Chewieip
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2004
Posts: 79
Location: Girona, Spain

PostPosted: Tue Mar 15, 2005 12:03 pm    Post subject: Reply with quote

I'm having problems with the execution of pvm. All compiles OK but when I want to execute xpvm (I've to emerge the unstable version of xpvm too) it breaks.

The error is like:
Code:

libpvm [pid14165] mksocs() connect: Connection refused
libpvm [pid14165]    socket address tried: /tmp/pvmtmp008325.0
libpvm [pid14165] mksocs() connect: Connection refused
libpvm [pid14165]    socket address tried: /tmp/pvmtmp008325.0


It says also I've running the pvm daemon. Anyone has got the same problem?
_________________
El único caso en que P= NP es cuando N = 1.
Back to top
View user's profile Send private message
jslegare
n00b
n00b


Joined: 26 May 2005
Posts: 5

PostPosted: Thu May 26, 2005 2:44 pm    Post subject: Re: [solved] emerge pvm doesn't work Reply with quote

Quote:

So I insert 2 lines in the ebuild (should be in /var/portage/sys-cluster/pvm/). Now gentoo compiles it very well for i386.
Code:

# setup def files for other archs
# following 2 lindes instert !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
        cp conf/LINUX.def conf/LINUXI386.def 
        cp conf/LINUX.m4 conf/LINUXI386.m4

       ...


Have a nice day ;-)

PS: "bug" isn't reported, do I have to?


You Also need to recompute the digests for the ebuild if you get a "Digest verification failed" error when emerging after the modification.
Type the following command in your shell to fix it:


Code:

ebuild pvm-3.4.4-r2.ebuild digest
Back to top
View user's profile Send private message
DrDoverylittle
n00b
n00b


Joined: 15 Oct 2004
Posts: 41

PostPosted: Wed Aug 31, 2005 5:54 am    Post subject: Reply with quote

Chewieip wrote:
I'm having problems with the execution of pvm. All compiles OK but when I want to execute xpvm (I've to emerge the unstable version of xpvm too) it breaks.

The error is like:
Code:

libpvm [pid14165] mksocs() connect: Connection refused
libpvm [pid14165]    socket address tried: /tmp/pvmtmp008325.0
libpvm [pid14165] mksocs() connect: Connection refused
libpvm [pid14165]    socket address tried: /tmp/pvmtmp008325.0


It says also I've running the pvm daemon. Anyone has got the same problem?


Whenever you see this it means PVM exited badly and left the socket in the /tmp directory which it cant contact.
Just to a
Code:
killall -9 pvmd3 ; rm -f /tmp/pvm*
and this will exorcise any daemons and remove old sockets.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum