Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2.12 beta ebuilds anyone?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Schmolch
l33t
l33t


Joined: 16 Jun 2002
Posts: 746
Location: Germany

PostPosted: Fri Jul 29, 2005 7:47 pm    Post subject: Gnome 2.12 beta ebuilds anyone? Reply with quote

Hi Gnome-Users :-)

Would anyone be kind enough to make some ebuilds for Gnome-2.12 beta?

I tried to modify the existing ebuilds by adjusting all the version-numbers, but after a while i ran into some Access-Violations.
Back to top
View user's profile Send private message
unz
l33t
l33t


Joined: 28 Jul 2004
Posts: 819
Location: Roma, Italia

PostPosted: Sun Jul 31, 2005 12:53 am    Post subject: Reply with quote

i'm struggling with'em ... stay tuned and check this site -> http://www.steev.net/ this guy is collecting an overlay
_________________
Ma che c'hai là? Sulla spalla!!!! http://lascimmia.it/
Back to top
View user's profile Send private message
Shadow Skill
Veteran
Veteran


Joined: 04 Dec 2004
Posts: 1023

PostPosted: Sun Jul 31, 2005 1:46 am    Post subject: Reply with quote

I'm looking forward to this as well, anyone know if it will be possible to have unique wallpaper for each virtual desktop in 2.12? If its already possible with 2.10 someone please clue me in on how to make it work.
_________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.

"First there was nothing, so the lord gave us light. There was still nothing, but at least you could see it."
Back to top
View user's profile Send private message
Schmolch
l33t
l33t


Joined: 16 Jun 2002
Posts: 746
Location: Germany

PostPosted: Sun Jul 31, 2005 10:43 pm    Post subject: Reply with quote

Thanks for the ebuilds, they work for me.
Unfortunately though i cannot get nautilus to run, it crashes immediately.
I emerged it with -uD so i would not miss any dependencies.
Does nautilus work for you?
Back to top
View user's profile Send private message
GaMMa
l33t
l33t


Joined: 23 Aug 2002
Posts: 684
Location: USA

PostPosted: Mon Aug 01, 2005 1:27 am    Post subject: Reply with quote

There's an overlay here too.. http://raphael.slinckx.net/blog/index.php/2005-08-01/beta-packages-summer-of-code
_________________
Ubuntu Linux Dapper Drake running Gnome-2.14.1
[Website | Screenshot | Portage Guide]
Back to top
View user's profile Send private message
guy
Apprentice
Apprentice


Joined: 31 Mar 2003
Posts: 286
Location: USA

PostPosted: Mon Aug 01, 2005 3:19 am    Post subject: Reply with quote

Hot damn, a clipboard manager, 'bout time...
_________________
www.manatee.servemp3.com
www.seas.upenn.edu/~bdodson/gina
www.goatse.cx [it will rise again!]
Back to top
View user's profile Send private message
DeathAndTaxes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2003
Posts: 124

PostPosted: Mon Aug 01, 2005 6:36 am    Post subject: Reply with quote

Shadow Skill wrote:
I'm looking forward to this as well, anyone know if it will be possible to have unique wallpaper for each virtual desktop in 2.12? If its already possible with 2.10 someone please clue me in on how to make it work.


This is an option that unfortunately appears to have zero chance of inclusion. I've ranted about this on slashdot a few times, posted about it on my blog, and even posted to the gnome developers' mailing list(s). Invariably, this option is met with outright hostility on the part of the devs.

Personally, I think it's retarded to promote a "spatially aware work environment" without the simple option of having each workspace appear differently. You're forced to squint at the little applet in your taskbar to figure out what workspace you're on. This is my absolute #1 problem with gnome...Overall I still prefer it over KDE, but I sure miss those customized desktop workspaces in KDE. ;-)

Another issue I have with 2.10 is the "take me there" behavior instead of the "bring this to me" behavior in nautilus. Open a folder on desktop 3, leave it open, switch to desktop 1 and open the folder again. Instead of the folder window being brought to you on desktop 1 (the default behavior <2.10), nautilus takes you to desktop 3, which is very disorienting...Even when you know it's going to happen and expect it.

Overall, I'm very happy with the Mac-like direction gnome is taking. As someone who came up using Macs, gnome feels much more comfortable for me than KDE (I won't even consider Enlightenment). However, there's still niggles to be worked out. :-)
Back to top
View user's profile Send private message
unz
l33t
l33t


Joined: 28 Jul 2004
Posts: 819
Location: Roma, Italia

PostPosted: Mon Aug 01, 2005 9:38 am    Post subject: Reply with quote

Schmolch wrote:
Thanks for the ebuilds, they work for me.
Unfortunately though i cannot get nautilus to run, it crashes immediately.
I emerged it with -uD so i would not miss any dependencies.
Does nautilus work for you?

Code:

revdep-rebuild -p


right now we don't know the right order of dependancy ... so check for broken libs and re-emerge

here nautilus works and is great the new way of displaying the tree [paste in folder too!!]
_________________
Ma che c'hai là? Sulla spalla!!!! http://lascimmia.it/
Back to top
View user's profile Send private message
nomenquis
n00b
n00b


Joined: 30 Mar 2005
Posts: 22

PostPosted: Tue Aug 02, 2005 11:50 am    Post subject: Reply with quote

Does someone know a working overlay for building on amd64? Both of them fail due to failing patches for amd64 with multilib in gtk+ and also some other problems where the makefiles of some packages were not correctly patched for the multilib environment.

kind regards
Back to top
View user's profile Send private message
steevdave
Developer
Developer


Joined: 25 Oct 2004
Posts: 73
Location: Tulsa, OK

PostPosted: Tue Aug 02, 2005 8:40 pm    Post subject: Reply with quote

Hey all, that's my overlay at steev.net - I would be more than willing to help get this going on anyone's system - my aol screenname is realitycomrades, feel free to hit me up with any problems, a majority of everything in my overlay is marked ~86 only as well, that is the only architecture that I have access to. If you would be willing to let me have an account somewhere on an amd64 machine, or you have the know how to get things working, feel free to submit patches to me via email (mydomain-.net@mydomain) and I will work on getting them included. Also, the open a folder here, then move to a different desktop problem has been fixed in my overlay. There was a patch for it, and I have applied it in there.

A few problems that I have come across so far. Apparently, totem locks up a system full screen (haven't tried, i don't actually use totem). gnome-desktop - apparently some wallpapers cause the desktop to look wacky. Not sure if it is a nautilus problem, or a gnome-desktop problem. Off the top of my head, that is about all I can think of. I have another overlay aside from the gnome 2.12 beta setup, which is pretty much an, "ultimate breakage" overlay - which are things that I use, cvs snapshots and so forth. it is similar in url to the gnome 2.11 overlay, except it's path it "files/overlay" on my site. Quick warnings about it if you choose to go through. dbus 0.35.2 is the latest. 0.36 is a cvs snapshot. hal-0.5.2 is the latest, 0.5.4 is a cvs snapshot. gnome-volume-manager 1.3.2 is latest, 1.3.3 is a cvs snapshot. There are other things, but for the most part, everything works here. Hit me up with a private message, an IM or see me on IRC as the username [steev] (and when my dialup connection is being extremely crappy, [steev]_ __ ___ and other variations of the _ after my name from the random disconnects :) )

Glad to see people are trying these out.
Back to top
View user's profile Send private message
sysdeep
n00b
n00b


Joined: 23 Jul 2005
Posts: 12
Location: Asia

PostPosted: Thu Aug 04, 2005 3:01 am    Post subject: Reply with quote

steevdave - great overlay, thanks.

Some edits for you for people using standardish gnome + media uses:

iso-codes ebuild (+depends pyxml)
totem ebuild (+depends musicbrainz)
_________________
Thank you!
Back to top
View user's profile Send private message
steevdave
Developer
Developer


Joined: 25 Oct 2004
Posts: 73
Location: Tulsa, OK

PostPosted: Thu Aug 04, 2005 6:45 am    Post subject: Reply with quote

Updated the depends, thanks sysdeep, i haven't gone over all the ebuilds yet to make sure i have every single depend correct just yet. I am slowly making my way through. Updated overlay posted.
Back to top
View user's profile Send private message
ARealNoobOne
n00b
n00b


Joined: 13 Feb 2005
Posts: 59

PostPosted: Fri Aug 05, 2005 10:34 am    Post subject: Reply with quote

steevdave wrote:
Updated the depends, thanks sysdeep, i haven't gone over all the ebuilds yet to make sure i have every single depend correct just yet. I am slowly making my way through. Updated overlay posted.



gnome-panel should depend on :
1. gnome-menus (libgnome-menu.so.2 instead of old libgnome-menu.so.0)
2. libwnck and gnome applets : otherwise some applets (workspace-switcher, window-list) fail at startup (revdep-rebuild show broken deps on .so)


new gnome-media-2.11.5 (instead of 2.10.2) should depend on new nautilus-cd-burner-2.11.5 (instead of old 2.10.2) if new hal-0.5.2-r1 is already merged (instead of old 0.4.8), to avoid:

/usr/lib/libnautilus-burn.so: undefined reference to `hal_manager_find_device_string_match'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_property_exists'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_free_string'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_find_device_by_capability'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_lock'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_get_property_string'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_initialize'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_free_string_array'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_get_property_bool'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_get_property_int'
/usr/lib/libnautilus-burn.so: undefined reference to `hal_device_unlock'
collect2: ld returned 1 exit status
make[3]: *** [gnome-cd] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-media-2.11.5/work/gnome-media-2.11.5/gnome-cd'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-media-2.11.5/work/gnome-media-2.11.5/gnome-cd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-media-2.11.5/work/gnome-media-2.11.5'
make: *** [all] Error 2


Otherwise very cool : no big desktop crashes up to now... Only had 4 mozilla-firefox crashes, mostly on File/Save. Would have killed my nerves if I hadn't that cool session saver extension to bring back all my open tabs at next startup ;-)


Question:

I see libcairo and libpangocairo dependencies in /usr/lib/libgtk-x11-2.0.so, so Cairo is built in. How can I check that it is actually active (equery f cairo shows no test/bench binary) ? TIA.
Back to top
View user's profile Send private message
Mala Zaba
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 156
Location: Brossard, Qc.

PostPosted: Fri Aug 05, 2005 11:50 am    Post subject: Reply with quote

Quote:
install gentoo only for new gnome, and thanks for ebuilds.rnBut I have a problem with gnome-desktop. When I try emerge it, it show “compilation error: file C/fdl.xml line 15 element article” “xsltParseStylesheetProcess : document is not a stylesheet” and errors. Do you now, what it could be ?rnSorry for my bad english.


emerge gnome-doc-utils before gnome-desktop
Back to top
View user's profile Send private message
Mala Zaba
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 156
Location: Brossard, Qc.

PostPosted: Fri Aug 05, 2005 11:52 am    Post subject: Reply with quote

emerge iso-codes fails...

Code:
error on iso-codesrnrnrnrnTraceback (most recent call last):rn File “../iso2pot.py”, line 9, in ?rn from xml.sax import saxutils, make_parser, saxlib, saxexts, ContentHandlerrnImportError: cannot import name saxlibrnmake[1]: *** [iso_639.pot] Error 1rnmake[1]: *** Waiting for unfinished jobs….rnTraceback (most recent call last):rn File “./iso639tab.py”, line 9, in ?rn from xml.sax import saxutils, make_parser, saxlib, saxexts, ContentHandlerrnImportError: cannot import name saxlibrnmake[1]: *** [iso_639.tab] Error 1rnmake[1]: Leaving directory `/var/tmp/portage/iso-codes-0.46/work/iso-codes-0.46/iso_639′rnmake: *** [all-recursive] Error 1rn


I re-emerge python and pyxml, but no succes.
Back to top
View user's profile Send private message
otaku
Guru
Guru


Joined: 16 Dec 2004
Posts: 428
Location: Rho (MI)

PostPosted: Fri Aug 05, 2005 1:17 pm    Post subject: Reply with quote

Mala Zaba wrote:
emerge iso-codes fails...

Code:
error on iso-codesrnrnrnrnTraceback (most recent call last):rn File “../iso2pot.py”, line 9, in ?rn from xml.sax import saxutils, make_parser, saxlib, saxexts, ContentHandlerrnImportError: cannot import name saxlibrnmake[1]: *** [iso_639.pot] Error 1rnmake[1]: *** Waiting for unfinished jobs….rnTraceback (most recent call last):rn File “./iso639tab.py”, line 9, in ?rn from xml.sax import saxutils, make_parser, saxlib, saxexts, ContentHandlerrnImportError: cannot import name saxlibrnmake[1]: *** [iso_639.tab] Error 1rnmake[1]: Leaving directory `/var/tmp/portage/iso-codes-0.46/work/iso-codes-0.46/iso_639′rnmake: *** [all-recursive] Error 1rn


i've the same error
_________________
Ventiquattr'ore al giorno in preda a una follia contorta...
Back to top
View user's profile Send private message
Mala Zaba
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 156
Location: Brossard, Qc.

PostPosted: Fri Aug 05, 2005 1:31 pm    Post subject: Reply with quote

otaku wrote:

i've the same error


On a fresh install?
Back to top
View user's profile Send private message
ARealNoobOne
n00b
n00b


Joined: 13 Feb 2005
Posts: 59

PostPosted: Fri Aug 05, 2005 2:04 pm    Post subject: Reply with quote

ARealNoobOne wrote:

Otherwise very cool : no big desktop crashes up to now... Only had 4 mozilla-firefox crashes, mostly on File/Save. Would have killed my nerves if I hadn't that cool session saver extension to bring back all my open tabs at next startup ;-)


ARRGHH! THE WHOLE DESKTOP RUNS FINE EXCEPT FIREFOX!!! MULTIPLE CRASHES, VERY ANNOYING :-((

Just didn't merge gtkhtml and Evolution related stuff because it's the tricky part and I use thunderbird anyway, but now Firefox crashes at random time and place e.g. just opening a tab with a png or jpg, or adding a bookmark...

mozilla-firefox-1.0.6 currently under remerging, but I fear the weakness is in some extension... Hate the "disable all of them then try one by one" game. Whi O Why did they fail to have a functionning crash handler... the window just zaps :-(

running xorg-6.8.99.15 if that matters...

==> BEWARE IF USING FIREFOX <== Seen blog entries on planet.gnome.org with people having same pb...
Back to top
View user's profile Send private message
ARealNoobOne
n00b
n00b


Joined: 13 Feb 2005
Posts: 59

PostPosted: Fri Aug 05, 2005 3:41 pm    Post subject: Reply with quote

OK I know the Gnome Desktop browser is Epiphany ;-))

But there seems to be an issue with Mozilla, SVG and the latest GTK+ with Cairo:

# emerge "=www-client/mozilla-firefox-1.0.6-r4"

... < TONS OF BUILD OUTPUT HERE > ...

i686-pc-linux-gnu-g++ -o nsSVGCairoPathGeometry.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -I../../../../../gfx/src - I../../../../../gfx/src/gtk -I../../../../../dist/include/xpcom -I../../../../../dist/include/widget -I../../../../../d ist/include/pref -I../../../../../dist/include/gfx -I../../../../../dist/include/imglib2 -I../../../../../dist/include/s tring -I../../../../../dist/include/dom -I../../../../../dist/include/content -I../../../../../dist/include/necko -I../. ./../../../dist/include/util -I../../../../../dist/include/uconv -I../../../../../dist/include/windowwatcher -I../../../ ../../dist/include/layout -I../../../../../dist/include -I/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/dist/in clude/nspr -fPIC -DGENTOO_NSPLUGINS_DIR=\"/usr/lib/nsplugins\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\"/usr/lib/nsbrows er/plugins\" -fno-rtti -fno-handle-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsy nth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -march=athlon-xp -pipe -Wno-deprecated -Wno-return-type -w -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -ffunction-sections -O2 -I/usr/include/freetype2 -I/usr/include/cair o -I/usr/include/libpng12 -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2/ config -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DGENTOO_NSPLUGINS_DIR=\"/usr/lib/ nsplugins\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\"/usr/lib/nsbrowser/plugins\" -DMOZILLA_CLIENT -include ../../../../../mozi lla-config.h -Wp,-MD,.deps/nsSVGCairoPathGeometry.pp nsSVGCairoPathGeometry.cpp
nsSVGCairoPathGeometry.cpp: In member function `void nsSVGCairoPathGeometry::GeneratePath(cairo_t*)':
nsSVGCairoPathGeometry.cpp:169: error: `cairo_matrix_create_DEPRECATED_BY_cairo_matrix_t' undeclared (first use this fun ction)
nsSVGCairoPathGeometry.cpp:169: error: (Each undeclared identifier is reported only once for each function it appears in .)
nsSVGCairoPathGeometry.cpp:170: error: `cairo_matrix_set_affine_REPLACED_BY_cairo_matrix_init' undeclared (first use thi s function)
nsSVGCairoPathGeometry.cpp:171: error: `cairo_concat_matrix_REPLACED_BY_cairo_transform' undeclared (first use this func tion)
nsSVGCairoPathGeometry.cpp: In member function `virtual nsresult nsSVGCairoPathGeometry::Render(nsISVGRendererCanvas*)':
nsSVGCairoPathGeometry.cpp:218: error: `cairo_set_rgb_color_REPLACED_BY_cairo_set_source_rgb' undeclared (first use this function)
nsSVGCairoPathGeometry.cpp:219: error: `cairo_set_alpha_DEPRECATED_BY_cairo_set_source_rgba_OR_cairo_paint_with_alpha' u ndeclared (first use this function)
nsSVGCairoPathGeometry.cpp: In member function `virtual nsresult nsSVGCairoPathGeometry::ContainsPoint(float, float, PRB ool*)':
/usr/include/cairo/cairo.h:231: error: too few arguments to function `cairo_t* cairo_create(cairo_surface_t*)'
nsSVGCairoPathGeometry.cpp:324: error: at this point in file
nsSVGCairoPathGeometry.cpp:327: error: `cairo_default_matrix_REPLACED_BY_cairo_identity_matrix' undeclared (first use th is function)
gmake[6]: *** [nsSVGCairoPathGeometry.o] Error 1
gmake[6]: *** Waiting for unfinished jobs....
nsSVGCairoCanvas.cpp: In member function `nsresult nsSVGCairoCanvas::Init(nsIRenderingContext*, nsIPresContext*, const n sRect&)':
/usr/include/cairo/cairo.h:231: error: too few arguments to function `cairo_t* cairo_create(cairo_surface_t*)'
nsSVGCairoCanvas.cpp:119: error: at this point in file
nsSVGCairoCanvas.cpp:122: error: `cairo_set_target_drawable_DEPRECATED_BY_cairo_xlib_surface_create' undeclared (first u se this function)
nsSVGCairoCanvas.cpp:122: error: (Each undeclared identifier is reported only once for each function it appears in.)
nsSVGCairoCanvas.cpp: In member function `virtual nsresult nsSVGCairoCanvas::Clear(nscolor)':
nsSVGCairoCanvas.cpp:208: error: `cairo_set_rgb_color_REPLACED_BY_cairo_set_source_rgb' undeclared (first use this funct ion)
gmake[6]: *** [nsSVGCairoCanvas.o] Error 1
gmake[6]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/layout/svg/renderer/src/cairo'
gmake[5]: *** [libs] Error 2
gmake[5]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/layout/svg/renderer/src'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/layout/svg/renderer'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/layout/svg'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla/layout'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.6-r4/work/mozilla'
make: *** [default] Error 2

!!! ERROR: www-client/mozilla-firefox-1.0.6-r4 failed.
!!! Function src_compile, Line 185, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.



(ARRRGGH !! I should have used ebuild rather than emerge for such build)

Now maybe it's related to the mozsvg flag being set:

# emerge mozilla-firefox -vp

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild R ] www-client/mozilla-firefox-1.0.6-r4 -debug +gnome -ipv6 -java -mozcalendar +mozdevelop -moznoxft +mozsvg +truetype -xinerama -xprint 0 kB


Retrying with -mozsvg...

Could that explain those firefox crashes whith new gtk+-2.7.5 and "old" build of firefox with mozsvg set ? (previous gtk+ was 2.6.8, everything was fine and stable)
Back to top
View user's profile Send private message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Fri Aug 05, 2005 3:47 pm    Post subject: Reply with quote

I have this problem instead:
Code:
checking for BASE_DEPENDENCIES_LIBS...
configure: error: Package requirements (glib-2.0 >= 2.7.1    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.5.2-head) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

I have the lib installed, but i don't know how i have to set a PKG_CONFIG_PAGTH.
Someone had this problem?
_________________
about:mozilla
Back to top
View user's profile Send private message
ARealNoobOne
n00b
n00b


Joined: 13 Feb 2005
Posts: 59

PostPosted: Fri Aug 05, 2005 3:52 pm    Post subject: Reply with quote

SilverXXX wrote:
I have this problem instead:
Code:
checking for BASE_DEPENDENCIES_LIBS...
configure: error: Package requirements (glib-2.0 >= 2.7.1    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.5.2-head) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

I have the lib installed, but i don't know how i have to set a PKG_CONFIG_PAGTH.
Someone had this problem?


Didn't have this one:

autoconf is looking for pkgconfig files (with a .pc extension, usually /usr/lib/pkgconfig) and is not able to find one of those...

Add the path to .pc files to PKG_CONFIG_PATH shell var, export it and retry ;-)
Back to top
View user's profile Send private message
otaku
Guru
Guru


Joined: 16 Dec 2004
Posts: 428
Location: Rho (MI)

PostPosted: Fri Aug 05, 2005 4:02 pm    Post subject: Reply with quote

Mala Zaba wrote:
otaku wrote:

i've the same error


On a fresh install?

i've already gnome 2.10 installed
_________________
Ventiquattr'ore al giorno in preda a una follia contorta...
Back to top
View user's profile Send private message
steevdave
Developer
Developer


Joined: 25 Oct 2004
Posts: 73
Location: Tulsa, OK

PostPosted: Fri Aug 05, 2005 5:05 pm    Post subject: Reply with quote

Replies in very random order...

Mozilla, Mozilla-Firefox and (possibly) Mozilla-Thunderbird with latest gtk NEEDS to have -mozsvg flag set. Otherwise it WILL crash/dump core(if you have that enabled) a LOT. I found that on someone else's blog (I believe it was Matt Schick's(sp?)) although I never had it set on mine, so I never had the problem.

Dependencies, I am trying to get em worked out, but for the most part I have gone with what is in the configure.in script, when realistically, I should set them to whatever the smallest version is that is in the beta release...

So, I have updated ebuilds to dependencies when people have let me know, I am re-digesting everything, so hopefully if people have problems, they should either re-download the tarball and try again, or pick and choose through the ebuilds that I have up there. I submitted the patch for amd64 support for gtk+ to bugzilla, so hopefully it will be accepted soon. If there are other amd64 patches that someone knows of/needs and is willing to let me either access their box (or trust me to write a patch for amd64 while on an x86 machine (heh)) let me know. My only/primary machine is a Sharp Mebius laptop with a Mobile Athlon 4 in it, so I am not exactly screaming super fast development here (compile times are quite the suck here)

Also the cairo problem, apparently, the way it works, is this. Pango 1.9.1 requires cairo 0.6.0, apparently, for glitz support in cario, you really need a cvs snapshot of glitz (it says 0.4.3 should work, but apparently it doesn't) I have a 0.4.4_pre ebuild somewhere, not sure if it is in the /files/gnome-2.11 overlay, or in my /files/overlay overlay. When you rebuild, you have to do glib 2.7.6 -> cairo 0.6.0 -> pango 1.9.1 -> gtk+ 2.7.x

Sorry for any inconveniences, I am still working through the deps, so all help is appreciated. Either PM me here, IM me on AIM (realitycomrades), email me, or leave a comment on my site. Thanks again for testing out these ebuilds.

Also, there IS talk of trying to get this stuff included into Portage! It is just a matter of getting a few certain devs to agree to allow it in the tree.
Back to top
View user's profile Send private message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Fri Aug 05, 2005 5:06 pm    Post subject: Reply with quote

i solved using cairo-0.6.0, but i have this problem when compiling metacity now:
Code:
f i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/startup-notification-1.0   -DMETACITY_LIBEXECDIR=\"/usr/libexec\" -DMETACITY_LIBDIR=\"/usr/lib\" -DHOST_ALIAS=\"i686-pc-linux-gnu\" -DMETACITY_LOCALEDIR=\"/usr/share/locale\" -DMETACITY_PKGDATADIR=\"/usr/share/metacity\" -DMETACITY_DATADIR=\"/usr/share\" -DG_LOG_DOMAIN=\"metacity\" -DSN_API_NOT_YET_FROZEN=1    -O2 -march=athlon-xp -fomit-frame-pointer -pipe -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -MT xprops.o -MD -MP -MF ".deps/xprops.Tpo" -c -o xprops.o xprops.c; \
then mv -f ".deps/xprops.Tpo" ".deps/xprops.Po"; else rm -f ".deps/xprops.Tpo"; exit 1; fi
*** glibc detected *** double free or corruption (out): 0x0855bd38 ***
xprops.c: In function `size_hints_from_results':
xprops.c:870: internal compiler error: Abortito
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.

WHat should it be? Compilation stopped, and emerge doesn't exit :cry:

EDIT: i re-emerged metacity, it works now :?: :?:
_________________
about:mozilla
Back to top
View user's profile Send private message
ARealNoobOne
n00b
n00b


Joined: 13 Feb 2005
Posts: 59

PostPosted: Fri Aug 05, 2005 5:22 pm    Post subject: Reply with quote

steevdave wrote:
Sorry for any inconveniences, I am still working through the deps, so all help is appreciated. Either PM me here, IM me on AIM (realitycomrades), email me, or leave a comment on my site. Thanks again for testing out these ebuilds.

Also, there IS talk of trying to get this stuff included into Portage! It is just a matter of getting a few certain devs to agree to allow it in the tree.


Hey you do great job man !

I know how exciting but sometimes painful it is to manage the bleeding edge ebuilds (be it gnome or kde or whatever)...

Just thinking about how people like say spider for gnome-2.6 or matt at breakmygentoo for gnome-2.8 have received too few rewards compared to the huge work they did made me scary about the whole process ;-))

BUG REPORTS ARE:
1. Normal, even expected
2. To be polite and friendly


OK for the -mozsvg, my build is finished I'm gonna try it after dinner: I had very random crashes with mozsvg, could be OK for 3 or 4 hours then crash every 5 minutes for too much time for me to sustain...


Also I gonna have to google about the whole Cairo rendering: I feel something is different, a bit better, mainly on fonts. But there was some _hot_ threads on osnews.com articles 'GTK+ + Cairo sloooowww", and I don't feel it any slower so either the whole argument was bullshit or cairo is builtin but not enabled.


EDIT: Yes, thunderbird is crashing too... e.g. Tools/Message Filters : create a new rule, save it... and TB crashes when you click the button :-(

=> remerge... even if there is no mozsvg flag
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum