Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with Grub
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
condde
n00b
n00b


Joined: 30 Jun 2009
Posts: 5

PostPosted: Thu Jul 02, 2009 3:25 pm    Post subject: Problem with Grub Reply with quote

In my /boot/grub/grub.conf file, I added vga=791, triyng to change my screen resolution out of the X.
Whell, it didn't worked. When I rebooted, an error came up after select my Gentoo Linux: undefined video mode number 317.....

So, I tried to go again to grub.conf file and it disappeard. The hall Grub directory was gone. But the pc continued to start, whit the error....
I reinstalled Grub, and rebuilt grub.conf whit:

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo
root (hd0,0)
kernel /boot/kernel-2.6.29-gentoo-r5 root=/dev/sda3


But, it continues to show the same error..
Where is the previous grub.conf file that still's running (I supose)?
What should I do?
Thanks
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4296

PostPosted: Thu Jul 02, 2009 7:06 pm    Post subject: Reply with quote

your old grub.conf that is running might just be hide... in your boot partition

if / is mount and /boot isn't then anything you are trying to write to your boot partition will in fact be write in your / partition at place /boot

if it's still not clear, you must do "mount /boot" before modifying your grub.conf, else you will modify a grub.conf from /boot but in your root partition.
Back to top
View user's profile Send private message
condde
n00b
n00b


Joined: 30 Jun 2009
Posts: 5

PostPosted: Thu Jul 02, 2009 7:49 pm    Post subject: Reply with quote

ok..

I tried mount /boot but my boot partition is in ext2 and my root parition is in ext3.
Shouls I convert the /boot partition to ext3 or there is another way?

Thanks for all the help!:D
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4296

PostPosted: Thu Jul 02, 2009 8:18 pm    Post subject: Reply with quote

no !

your kernel should handle ext2 and there's no issue mounting an ext2 in an ext3 mount point (nor with others filesystems)
Back to top
View user's profile Send private message
condde
n00b
n00b


Joined: 30 Jun 2009
Posts: 5

PostPosted: Thu Jul 02, 2009 8:30 pm    Post subject: Reply with quote

Hi again!

When I try to mount the boot partition the message bellow is displayed:
mount: unknown filesystem type 'ext2'

How can I mount the /boot partiition?

Thanks in advance,
Best regards!
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Thu Jul 02, 2009 9:09 pm    Post subject: Reply with quote

Hi, can you post this :

Code:

# fdisk -l
# mount
# cat /etc/fstab

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
condde
n00b
n00b


Joined: 30 Jun 2009
Posts: 5

PostPosted: Thu Jul 02, 2009 9:27 pm    Post subject: Reply with quote

Hi!

Here is the information that you had requested:
conddeLaptop ~ # fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2ab060cd

Device Boot Start End Blocks Id System
/dev/sda1 1 14 112423+ 83 Linux
/dev/sda2 15 276 2104515 82 Linux swap / Solaris
/dev/sda3 277 9729 75931222+ 83 Linux
conddeLaptop ~ # mount
/dev/sda3 on / type ext3 (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,gid=5,mode=620)
none on /dev/shm type tmpfs (rw,noexec,nosuid,nodev)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
conddeLaptop ~ # cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1 /boot ext2 defaults,noatime 1 2
/dev/sda2 none swap sw 0 0
/dev/sda3 / ext3 noatime 0 1

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0


# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
#shm /dev/shm tmpfs nodev,nosuid,noexec 0 0


Thanks in advance,
Best regards!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32110
Location: 56N 3W

PostPosted: Thu Jul 02, 2009 10:21 pm    Post subject: Reply with quote

condde,

You have made your kernel without ext2 support.

Add ext2 as a module (it must be <M>) and run
Code:
make modules && make modules_install

Now you can
Code:
modprobe ext2
and proceed to mount your /boot

With /boot mounted, you can remake and reinstall your kernel with ext2 as built in <*>
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Fri Jul 03, 2009 12:40 pm    Post subject: Reply with quote

In fact double check that and if it's not the case, then we will check if you have enable any framebuffer support inside your kernel.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
MaximeG
l33t
l33t


Joined: 15 Apr 2008
Posts: 722
Location: Belgium

PostPosted: Fri Jul 03, 2009 12:44 pm    Post subject: Reply with quote

Hi,

I'd agree with d2_racing. You probably don't have a framebuffer device installed to change your vga settings.

Regards,
Maxime
_________________
Future is wide open.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum