Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge depclean says "You have no system list..."
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Mon Jul 18, 2005 5:11 am    Post subject: emerge depclean says "You have no system list..." Reply with quote

Hello, this is a support question.

I am trying to get rid of unwanted packages by using the recommended procedure:
  • emerge sync
  • emerge -uDva world
  • emerge depclean -va
  • rm -f ~/.revdep*
  • revdep-rebuild -va

However emerge depclean -va reports this:
Quote:
root# emerge depclean -va
...
Calculating depclean dependencies ... done!
!!! You have no system list. Cannot determine system from world.
root#


I also check this and it turns up empty unlike my other Gentoo installation, which appears set.
Quote:
root# python2 -c "import portage; print portage.settings.packages;"
[]
root#


I have tried regenworld already. Please tell me how I can fix this "system list" problem.

Best regards and TIA
Back to top
View user's profile Send private message
hjnenc
Veteran
Veteran


Joined: 15 Aug 2004
Posts: 1599
Location: Vienna, Austria

PostPosted: Mon Jul 18, 2005 6:10 am    Post subject: Reply with quote

Make sure that the /etc/make.profile symlink points to the profile you want to use. On an x86 system this is a good choice:

/etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2005.0

See the Upgrading Guide for the details.
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Mon Jul 18, 2005 7:01 am    Post subject: Reply with quote

hjnenc wrote:
Make sure that the /etc/make.profile symlink points to the profile ...

Yes, this is set correctly on my two systems, as shown below. The setting is the same on both, but one instance is malfunctioning. This does not solve the problem.
Quote:
+3157> ls -aoF /etc/make.profile
lrwxrwxrwx 1 root 50 Apr 10 16:38 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2005.0/2.4/

This is for "x86 2005.0 profile for 2.4 kernels"

Any other hints?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Mon Jul 18, 2005 10:20 am    Post subject: Reply with quote

Post your emerge --info please.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Mon Jul 18, 2005 1:58 pm    Post subject: Reply with quote

kallamej wrote:
Post your emerge --info please.


Quote:
+3166> sudo emerge --info | tee sugar.emerge--info.txt ~ 18Mon225725
Gentoo Base System version 1.4.16
Portage 2.0.51.22-r1 (default-linux/x86/2005.0/2.4, gcc-3.3.5-20050130, glibc-2.3.5-r0, 2.4.26-co-0.6.1 i686)
=================================================================
System uname: 2.4.26-co-0.6.1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python: 2.2.3-r1, 2.3.5
sys-apps/sandbox: 1.2.10
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils: 2.15.92.0.2-r10
sys-devel/libtool: 1.5.18-r1
virtual/os-headers: 2.4.19-r1, 2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=i686 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-Os -march=i686 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.gentoo.gr.jp ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO http://ftp.gentoo.or.kr/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://asobic/gentoo-portage"
USE="x86 X alsa apache2 apm berkdb bitmap-fonts canna cjk crypt curl emacs emacs-w3 emboss esd fam foomaticdb fortran gpm gtk2 jpeg kde libg++ libwww mikmod mmx mp3 mpeg ncurses nls odbc oss pam pcre pdflib perl php postgres python quicktime readline ruby samba sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts unicode xml2 xmms zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Back to top
View user's profile Send private message
hjnenc
Veteran
Veteran


Joined: 15 Aug 2004
Posts: 1599
Location: Vienna, Austria

PostPosted: Mon Jul 18, 2005 3:22 pm    Post subject: Reply with quote

Can you verify, that the contents (including subdirectories) of /usr/portage/profiles on your two systems is the same? Probably the sync did not work.
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Mon Jul 18, 2005 11:17 pm    Post subject: Reply with quote

hjnenc wrote:
Can you verify, that the contents (including subdirectories) of /usr/portage/profiles on your two systems is the same? Probably the sync did not work.


"sugarc" is the hostname for the non-working gentoo. "asobic" is the hostname for the working gentoo.

Quote:
sugarc ~ # rsync -avP root@asobic:/usr/portage/profiles/ /tmp/asobic-profiles/
sugarc ~ # diff -qr /tmp/asobic-profiles/ /usr/portage/profiles/
Only in /tmp/asobic-profiles/base: packages
Only in /tmp/asobic-profiles/commercial/mysql/amd64: packages
Only in /tmp/asobic-profiles/default-alpha-1.4: packages
Only in /tmp/asobic-profiles/default-alpha-2004.0: packages
Only in /tmp/asobic-profiles/default-bsd/fbsd/x86: packages
Only in /tmp/asobic-profiles/default-darwin/macos/10.3: packages
Only in /tmp/asobic-profiles/default-darwin/macos/10.4: packages
Only in /tmp/asobic-profiles/default-darwin/macos/progressive: packages
Only in /tmp/asobic-profiles/default-darwin: packages
Only in /tmp/asobic-profiles/default-linux/alpha/2005.0/2.4: packages
Only in /tmp/asobic-profiles/default-linux/alpha: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2004.3/lib64: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2004.3: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2005.0/no-symlinks: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2005.1/no-symlinks: packages
Only in /tmp/asobic-profiles/default-linux/amd64/2005.1: packages
Only in /tmp/asobic-profiles/default-linux/amd64: packages
Only in /tmp/asobic-profiles/default-linux/arm: packages
Only in /tmp/asobic-profiles/default-linux/hppa/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/hppa: packages
Only in /tmp/asobic-profiles/default-linux/ia64/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/ia64: packages
Only in /tmp/asobic-profiles/default-linux/m68k: packages
Only in /tmp/asobic-profiles/default-linux/mips/cobalt: packages
Only in /tmp/asobic-profiles/default-linux/mips/mips64/2004.2: packages
Only in /tmp/asobic-profiles/default-linux/mips/mips64/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/mips/mips64/ip28/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/mips/mips64/n32/2004.2: packages
Only in /tmp/asobic-profiles/default-linux/mips/mips64/n32/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/mips: packages
Only in /tmp/asobic-profiles/default-linux: packages
Only in /tmp/asobic-profiles/default-linux/ppc/1.0: packages
Only in /tmp/asobic-profiles/default-linux/ppc/1.0_rc: packages
Only in /tmp/asobic-profiles/default-linux/ppc/1.2: packages
Only in /tmp/asobic-profiles/default-linux/ppc/1.4: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2004.0: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2004.1: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2004.2: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2004.3: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2005.1/ppc64/32bit-userland: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2005.1/ppc64/64bit-userland: packages
Only in /tmp/asobic-profiles/default-linux/ppc/2005.1/ppc64/multilib: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/2004.3: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/dev/2005.1/970/pmac: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/dev/2005.1/no-multilib/multilib: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/dev/2005.1/no-multilib: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/dev/2005.1: packages
Only in /tmp/asobic-profiles/default-linux/ppc64/dev/multilib: packages
Only in /tmp/asobic-profiles/default-linux/s390/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/s390: packages
Only in /tmp/asobic-profiles/default-linux/sh: packages
Only in /tmp/asobic-profiles/default-linux/sparc: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/2005.1: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/dev/24headers: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/dev/gcc33/24headers: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/dev/gcc33: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc32/dev: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/2004.2: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/2004.3/26headers: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/2004.3: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/2005.1: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/dev/24headers: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/dev/gcc33/24headers: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/dev/gcc33: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/dev/multilib: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/dev: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64: packages
Only in /tmp/asobic-profiles/default-linux/sparc/sparc64/server: packages
Only in /tmp/asobic-profiles/default-linux/x86/2004.0: packages
Only in /tmp/asobic-profiles/default-linux/x86/2004.2/gcc34/2.6: packages
Only in /tmp/asobic-profiles/default-linux/x86/2004.2/gcc34: packages
Only in /tmp/asobic-profiles/default-linux/x86/2004.2: packages
Only in /tmp/asobic-profiles/default-linux/x86/2004.3: packages
Only in /tmp/asobic-profiles/default-linux/x86/2005.0/2.4: packages
Only in /tmp/asobic-profiles/default-linux/x86/2005.0: packages
Only in /tmp/asobic-profiles/default-linux/x86/2005.1/2.4: packages
Only in /tmp/asobic-profiles/default-linux/x86/2005.1: packages
Only in /tmp/asobic-profiles/default-linux/x86/gcc2: packages
Only in /tmp/asobic-profiles/default-linux/x86/gcc31: packages
Only in /tmp/asobic-profiles/default-linux/x86: packages
Only in /tmp/asobic-profiles/default-linux/x86/xbox: packages
Only in /tmp/asobic-profiles/default-macos/ppc: packages
Only in /tmp/asobic-profiles/default-macos-10.3: packages
Only in /tmp/asobic-profiles/default-macos-10.4: packages
Only in /tmp/asobic-profiles/default-ppc: packages
Only in /tmp/asobic-profiles/default-ppc-1.0: packages
Only in /tmp/asobic-profiles/default-ppc-1.4: packages
Only in /tmp/asobic-profiles/default-ppc-2004.0: packages
Only in /tmp/asobic-profiles/default-ppc-2004.1: packages
Only in /tmp/asobic-profiles/default-ppc-2004.2: packages
Only in /tmp/asobic-profiles/default-ppc-2004.3: packages
Only in /tmp/asobic-profiles/default-ppc64-2004.2: packages
Only in /tmp/asobic-profiles/default-ppc64-2004.3: packages
Only in /tmp/asobic-profiles/default-sparc-1.4: packages
Only in /tmp/asobic-profiles/default-sparc-2004.0: packages
Only in /tmp/asobic-profiles/default-sparc64-1.4: packages
Only in /tmp/asobic-profiles/default-sparc64-2004.0: packages
Only in /tmp/asobic-profiles/default-x86-2004.2: packages
Only in /tmp/asobic-profiles/default-x86-obsd-2004: packages
Only in /tmp/asobic-profiles/embedded: packages
Only in /tmp/asobic-profiles/gcc33-sparc64-1.4: packages
Only in /tmp/asobic-profiles/hardened/amd64: packages
Only in /tmp/asobic-profiles/hardened: packages
Only in /tmp/asobic-profiles/hardened/ppc: packages
Only in /tmp/asobic-profiles/hardened/ppc64: packages
Only in /tmp/asobic-profiles/hardened/x86/2.6: packages
Only in /tmp/asobic-profiles/hardened/x86: packages
Only in /tmp/asobic-profiles/hardened-x86-2004.0: packages
Only in /tmp/asobic-profiles/selinux/2004.1/amd64/lib64: packages
Only in /tmp/asobic-profiles/selinux/2004.1/amd64: packages
Only in /tmp/asobic-profiles/selinux/2004.1: packages
Only in /tmp/asobic-profiles/selinux/2004.1/ppc: packages
Only in /tmp/asobic-profiles/selinux/2004.1/sparc64: packages
Only in /tmp/asobic-profiles/selinux/2004.1/x86: packages
Only in /tmp/asobic-profiles/selinux/2004.1/x86-uclibc: packages
Only in /tmp/asobic-profiles/selinux/2005.1/amd64: packages
Only in /tmp/asobic-profiles/selinux/2005.1/mips/mips64: packages
Only in /tmp/asobic-profiles/selinux/2005.1: packages
Only in /tmp/asobic-profiles/selinux/2005.1/ppc: packages
Only in /tmp/asobic-profiles/selinux/2005.1/sparc64: packages
Only in /tmp/asobic-profiles/selinux/2005.1/x86: packages
Only in /tmp/asobic-profiles/selinux/2005.1/x86-uclibc: packages
Only in /tmp/asobic-profiles/selinux: packages
Only in /tmp/asobic-profiles/uclibc/arm/2.4: packages
Only in /tmp/asobic-profiles/uclibc/arm/armeb/2.4: packages
Only in /tmp/asobic-profiles/uclibc: packages
Only in /tmp/asobic-profiles/uclibc/x86/2.4: packages
Only in /tmp/asobic-profiles/uclibc/x86/hardened/2.4: packages
Only in /tmp/asobic-profiles/vserver: packages
sugarc ~ #


It seems that the "packages" file in each directory is missing. What is the safe way to make sure I have the correct information? (The obvious method of using rsync is ok?)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Jul 19, 2005 7:36 am    Post subject: Reply with quote

piyo wrote:
It seems that the "packages" file in each directory is missing. What is the safe way to make sure I have the correct information? (The obvious method of using rsync is ok?)

The packages files are the system list so that explains the message about no system list. If you copy those manually to "sugarc", do they get removed the next time you sync?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Tue Jul 19, 2005 3:41 pm    Post subject: Reply with quote

kallamej wrote:
piyo wrote:
It seems that the "packages" file in each directory is missing. What is the safe way to make sure I have the correct information? (The obvious method of using rsync is ok?)

The packages files are the system list so that explains the message about no system list. If you copy those manually to "sugarc", do they get removed the next time you sync?


Yes!

After I copy the files manually to "sugarc", they are indeed removed when I do a "emerge sync".

Why?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Jul 19, 2005 4:20 pm    Post subject: Reply with quote

Don't know why that happens. If you use an official rsync mirror for sugarc instead of your local one, does that work better?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Wed Jul 20, 2005 11:16 pm    Post subject: Reply with quote

kallamej wrote:
Don't know why that happens. If you use an official rsync mirror for sugarc instead of your local one, does that work better?


Yes!

Using an official rsync mirror instead of my local mirror does not delete the "packages".

Obviously the problem is the portage tree rsync settings between the client and the in-home mirror. I think I found the problem in the /etc/rsyncd.conf, "exclude = distfiles packages" line.

Quote:
# /etc/rsyncd.conf
# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/files/rsyncd.conf,v 1.4 2005/03/18 02:00:40 vapier Exp $

# Minimal configuration file for rsync daemon
# See rsync(1) and rsyncd.conf(5) man pages for help

# This line is required by the /etc/init.d/rsyncd script
pid file = /var/run/rsyncd.pid

uid = nobody
gid = nobody
use chroot = yes
read only = yes

#limit access to private LAN's
hosts allow=192.168.0.0/255.255.0.0 10.0.0.0/255.0.0.0
hosts deny=*

max connections = 15
motd file = /etc/rsync/rsyncd.motd

#This will give you a separate log file
#log file = /var/log/rsync.log

#This will log every file transferred - up to 85,000+ per user, per sync
#transfer logging = yes

log format = %t %a %m %f %b
syslog facility = local3
timeout = 300

[gentoo-portage]
#modern versions of portage use this entry
path = /usr/portage
comment = Gentoo Linux Portage tree mirror
exclude = distfiles packages


Is the [gentoo-portage] setting the correct way to have an local mirror?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Thu Jul 21, 2005 6:49 am    Post subject: Reply with quote

The local rsync mirror guide has a trailing slash so as to only match directories.
Code:
exclude=distfiles/ packages/

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
IamtheOne
Apprentice
Apprentice


Joined: 27 Sep 2002
Posts: 157
Location: Iowa

PostPosted: Sat Jul 23, 2005 8:47 am    Post subject: Reply with quote

Thank you, that was very annoying. Actually they only have slashes in one of the two rsyncd.conf files.

I hope someone notices and adds trailing slashes to both.
_________________
AMD Athlon64 x2 5000+ Brisbane | 4GB OCZ Platinum PC2-6400
ASUS M2N32-SLI Deluxe | Sapphire Radeon 2900 Pro
Creative Audigy | NEC ND3500 DVD Burner
Antec P182 Case | OCZ GameXStream 700W PS
Gentoo x86_64/Windows Vista x64/Others
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sat Jul 23, 2005 10:00 am    Post subject: Reply with quote

IamtheOne wrote:
I hope someone notices and adds trailing slashes to both.

If you want to be sure someone notices you should file a bug report.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
piyo
n00b
n00b


Joined: 20 Mar 2004
Posts: 12

PostPosted: Sat Jul 23, 2005 10:49 pm    Post subject: Reply with quote

kallamej wrote:
The local rsync mirror guide has a trailing slash so as to only match directories.
Code:
exclude=distfiles/ packages/


Thank you! I redefined this to match the documentation (how did it get wrong?!?) and it made the process I wanted to do successful.

Thank you to all for the information. I consider this issue closed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum