Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[install-pear-installer] bus error on dev-php/php-4.4.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
f.meltzer
n00b
n00b


Joined: 01 Jun 2003
Posts: 38
Location: Norway

PostPosted: Sat Jul 16, 2005 4:35 pm    Post subject: [install-pear-installer] bus error on dev-php/php-4.4.0 Reply with quote

I'm having trouble updating dev-php/php from 4.3.11 to 4.4.0.
Can anyone tell me what "Bus error" means here, and help me troubleshoot this problem?

Code:

/usr/lib/libc-client.a(osdep.o)(.text+0xb104): In function `ssl_onceonlyinit':
: warning: the use of `tmpnam' is dangerous, better use `mkstemp'

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

>>> Test phase [not enabled]: dev-php/php-4.4.0

>>> Install php-4.4.0 into /var/tmp/portage/php-4.4.0/image/ category dev-php
 * Running make INSTALL_ROOT=/var/tmp/portage/php-4.4.0/image/ install
Installing PHP CLI binary:        /var/tmp/portage/php-4.4.0/image//usr/bin/
Installing PHP CLI man page:      /var/tmp/portage/php-4.4.0/image//usr/share/man/man1/
Installing PEAR environment:      /var/tmp/portage/php-4.4.0/image//usr/lib/php/
make[1]: *** [install-pear-installer] Bus error
make: *** [install-pear] Error 2

!!! ERROR: dev-php/php-4.4.0 failed.
!!! Function php-sapi_src_install, Line 538, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


Output of emerge info:
Code:

Portage 2.0.51.22-r1 (default-linux/sparc/sparc64/2005.0, gcc-3.3.5-20050130, glibc-2.3.3.20040420-r2, 2.4.30-sparc sparc64)
=================================================================
System uname: 2.4.30-sparc sparc64 sun4u
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.10
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.4.23
ACCEPT_KEYWORDS="sparc"
AUTOCLEAN="yes"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3 -pipe -fomit-frame-pointer"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ http://ftp.du.se/pub/os/gentoo http://gentoo.linux.no/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="sparc X arts avi berkdb bitmap-fonts clamav crypt cups curl dlloader encode esd fbcon foomaticdb fortran gcc64 gd gdbm gif gtk gtk2 imap imlib java jpeg ldap libwww mad maildir mbox mikmod motif mozilla mpeg mysql ncurses nls nntp oggvorbis opengl oss pam pdflib perl png python qt readline samba sdl sftplogging slang snmp spell ssl tcltk tcpd tiff truetype truetype-fonts type1-fonts vhosts xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

_________________
fm
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 892
Location: Pompano Beach, Florida

PostPosted: Sat Jul 16, 2005 6:00 pm    Post subject: Reply with quote

I had the same problem a few weeks ago, I reemerged pear-DB then ran revdep-rebuild and it emerged.
pear-DB is the only thing that was installed when I searched;
emerge search pear | less
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
dskennedy
n00b
n00b


Joined: 18 Apr 2005
Posts: 13
Location: United Kingdom

PostPosted: Wed Aug 17, 2005 10:40 pm    Post subject: Reply with quote

I'd also like to know why it does this. My system is a Sun Microsystems Ultra 5 (UltraSPARC 2i) and my emerge --info is below:

Code:
Gentoo Base System version 1.6.13
Portage 2.0.51.22-r2 (default-linux/sparc/sparc64/2005.0, gcc-3.3.5-20050130, glibc-2.3.3.20040420-r2, 2.4.30-sparc sparc64)
=================================================================
System uname: 2.4.30-sparc sparc64 sun4u
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.4.23
ACCEPT_KEYWORDS="sparc"
AUTOCLEAN="yes"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=ultrasparc"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=ultrasparc"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="sparc apache2 arts avi bitmap-fonts bzlib crypt cups dlloader encode esd fbcon foomaticdb fortran gcc64 gif gpm gtk gtk2 hardenedphp imlib jpeg libwww mad mcal mikmod mime motif mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl php png python readline sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY



I won't post my error output because it is identical to the one posted by f.meltzer, though mine fails on line 549 and also fails on PHP 4.3.11 (if I try and remerge it, or use revdep-rebuild).

~D. Kennedy
_________________
Must not sleep, must warn others.
Back to top
View user's profile Send private message
f.meltzer
n00b
n00b


Joined: 01 Jun 2003
Posts: 38
Location: Norway

PostPosted: Wed Aug 17, 2005 10:57 pm    Post subject: solved - sort of... Reply with quote

From your post I can see that you use "hardenedphp".

Try:
Code:
USE="-hardenedphp" -va emerge dev-php/mod_php dev-php/php


At least it did the trick for me. Currently running PHP 4.4.0 without the hardenedphp flag set.
Hopefully, this helps you out...
_________________
fm
Back to top
View user's profile Send private message
dskennedy
n00b
n00b


Joined: 18 Apr 2005
Posts: 13
Location: United Kingdom

PostPosted: Thu Aug 18, 2005 11:07 am    Post subject: Reply with quote

It has worked, thank you. :)
_________________
Must not sleep, must warn others.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum