Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.12-nitro5 "Make my day"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sat Jul 16, 2005 12:46 pm    Post subject: 2.6.12-nitro5 "Make my day" Reply with quote

Big thanks to b3cks for providing nitro a temporary new home on his webserver!!!!!!!

2.6.12-nitro5 "Make my day"

READ THIS FIRST
Nitro-sources is an experimental kernel patchset which is NOT supported by the Gentoo devs. If you have problems with something, see if the problem persists with a kernel supported by Gentoo. If you still have the same problem with a kernel supported by Gentoo (like vanilla-sources), then file a bug report at h**p://bugs.gentoo.org . If you only had the problem with 2.6.12-nitro5, and not with a vanilla kernel, then bug us in this thread.


Reiser4 fixed !!! The rest are the good things from nitro4, no changes.....

There is very little support for GCC4 PROBLEMS, ATI/NVIDIA MODULES OR REISER4

Need exhaustive feedback on x86_64 and ppc, so please do report and please do it with
SUFFICIENT debug info (dmesg etc..) The latter applies to ALL bugreports


PLEASE READ SPECIAL NOTES BELOW CHANGENOTES BEFORE POSTING BUGS !!!

This kernel already contains the ipw2100 and ipw2200 drivers same version as portage !!!

Patchlist wrote:

ck3_pdflush-tweaks_reiser-BUGfix-nitro4.diff
/* ck3 plus 2 patches from 13-rc-ck THX CON */

alsa_CVS_12_7_04-nitro4.diff
/* Alsa from CVS as usual */

fbsplash_vesafb-tng.diff
/* vfb-tng and fbsplash from spock */

inotify-0.23-rml-2.6.12-15.patch
inotify_ntfs_oops_fix.patch
/* Inotify plus the ntfs-oops fix */

ite-821X-alancox.patch
/* ite driver from alan */

kernel-2.6.11-layer7-1.4.patch
/* Layer7 ipt patch */

mm-patches.diff
/* very few of these, most got weeded out */

reiser4.diff
/* reiser4 + vfs patch, first attempt to address lkml complaints
about reiser4 trying to copy linux' vfs */

reiser4_fix-take-1.diff
/* remove the offending reiser4 changes, update to version from 15.07.2005 */

swsusp-2.1.9.9-for-2.6.12.2-cumulative.diff
/* Software Suspend 2 */

genetic_lib-and-genetic_anticipatory_iosched-nitro4.diff
/* genetic anticipatory io-scheduler */

n10-config-hz-2.6.12.diff
/* config kernel's internal timer freq */

n11-squashfs2.1-r2.diff
/* compact readonly fs */

n18-lufs2.diff
/* lufs from last cvs ever commited */

n19-daconfig-2.2.0-FROM_NO.diff
/* Pretty menuconfig, THX damouse */

n21-config-nr-tty-devices-FROM_NO.diff
/* config nr of tty* entries in /dev, thx steel */

n23-nitro-fb_logo.diff
/* framebuffer logo , who did it again? */

n33-lirc_cvs_28-06-05_fullconfig-nitro.diff
/* lirc cvs, extensive kconfig (please verify receiver settings before compiling!!!) */

n34-svgalib_helper-1.9.21-nitro.diff
/* nitro users never reemerge this again after kernel upgrade ;), THX nitro
* :lol: */

n27-adjust_nr_running.diff
/* ... */

n9-usbhid-readd-kconfig-r2.diff
/* ... */

use_once_cleanup
320-irqbal_fast
390-slabtune
410-fasync_lock_rcu
480-physnode_map
/* from mjb, mostly slab stuff */

fat-fix_slab_cache_leak.diff
/* ... */

ieee80211_wifi.patch

/* for compatibility with ipw2x00 from portage */


kstrdup-1-rml-2.6.12-rc3-1.patch
kstrdup-2-rml-2.6.12-rc3-1.patch
/* keep kstrdump in one place for all users */

linux-2.6.12-mppe-mppc-1.3.patch
/* Microsoft Point-to-Point Encryption and Compression support */

nitro-menu.diff
/* ;) */

sk98lin_v8.23.1.3_2.6.12.patch
/* updated sk98lin driver from syskonnect */

staircase-ctl-w-kconfig.diff
/* some ctls for staircase-sched tuning */

wbsd-2.6.12-1.patch
wbsd-mmc-bulk.patch
wbsd-mmc-powercycle.patch
/* should fix some problem with cardreader in notebooks ? */

slowdown_fix_thx-legoguy.diff
/* fix a bug in irq handling code */


NiTR0 menu wrote:

Staircase scheduler tunables --->
[ ] Genetic Anticipatory I/O scheduler (EXPERIMENTAL)
[ ] Inotify file change notification support
< > SVGALIB-HELPER driver ver. 1.9.21
[ ] Software Suspend 2 --->
< > SquashFS 2.1 - Squashed file system support
< > LUFS file system support (EXPERIMENTAL)
Linux InfraRed Controller --->
< > IT821X IDE support
< > Intel PRO/Wireless 2100 Network Connection
< > Intel PRO/Wireless 2200BG and 2915ABG Network Connection
< > Microsoft PPP compression/encryption (MPPC/MPPE)
< > Layer 7 match support (EXPERIMENTAL)


Staircase scheduler tunables ---> wrote:

(6) Basetimeslice for the staircase cpu-scheduler
(14) Basetimeslice factor for RR scheduling
(1) Task burst factor (staircase jumps) (DANGEROUS!!!)


MM-patches wrote:

acpi-disable-c2-c3-for-_all_-ibm-r40e-laptops-bug-3549.patch
acpi-ext-build-fix.patch
acpi-videoc-properly-remove-notify-handlers.patch
call-device_shutdown-with-interrupts-enabled.patch
drivers-net-wireless-ipw2100-use-the-dma_32bit_mask-constant.patch
drivers-net-wireless-ipw2200-use-the-dma_32bit_mask-constant.patch
export-file_ra_state_init-again.patch
ext3-reduce-allocate-with-reservation-lock-latencies.patch
fix-recursive-ipw2200-dependencies.patch
fix-soft-lockup-due-to-ntfs-vfs-part-and-explanation.patch
git-drm-initmap.patch
git-drm-via-fixup.patch
git-drm-via.patch
git-libata-adma-mwi.patch
git-libata-chs-support.patch
git-libata-passthru.patch
git-libata-promise-sata-pata.patch
git-netdev-register-netdev.patch
git-netdev-we18-ieee80211-wifi.patch
git-ntfs.patch
input-alps-fix-tap-logic.patch
input-atkbd-allow-0x7f-scancode.patch
input-usb-ignore-logitech-vendor-usages.patch
ipw2100-assume-recent-kernel.patch
ipw2100-cleanup-debug-prints.patch
ipw2100-kill-dead-macros.patch
ipw2100-old-gcc-fix.patch
ipw2100-remove-by-hand-function-entry-exit-debugging.patch
ipw2100-remove-commented-out-code.patch
ipw2100-small-cleanups.patch
ipw2200-build-fix.patch
iw_we18-5.diff
kbuild-build-a-single-module-using-make-dir-moduleko.patch
tty-output-lossage-fix.patch
x86_64-div-by-zero-fix.patch


changes since -nitro4

Code:

ONLY reiser4 fix, go see nitro4 notes for more info



Special Notes:
IPW2x00 are now synced with portage
[EDIT2] Now reported as working

VMWare : if having problems, look here: http://forums.gentoo.org/viewtopic-p-2584698.html#2584698

Win4Lin users: do _not_ select 1G_LOWMEM and do _not_ select REGPARM !

Reiser4 users: Reiser4 is not compatible with 4K STACKS

SWSUSP2: need reports

Only Nvidia drivers 76.64 and 76.67 were __verified__ to work, use NVAgp=3 or 2, it works and is faster (for me at least)

If having problems with ATI DRIVERS see this post and the others on the subject in that thread : }

BrokenOut: __SORRY__

Stuff not in NiTR0 menu is arch dependent stuff, you will find it in the usual place of Kconfig

Staircase controls: this is no magic, wont make u an uber desktop ;)
test as you want to find out best settings... i go with 1 10 1 and am ok for now ;)
settings are in these ranges:
timeslice = {1 to 20}
timeslice_factor = {10 to 26}
burst_factor = {1 to 10}
Can also be changed on the fly through /proc/sys/kernel/{timeslice,timeslice_factor,burst_factor} with an echo command too

OK, now the LINKS:
You must apply BOTH patches, first Patch1 then Patch2 !!!
ebuild already does this for you ;)

Mirror1(b3cks):
Ebuild
Patch1
Patch2
Release Notes

Mirror2(moi ;) ):
Ebuild
Patch1
Patch2
Release Notes

Mirror3(Lenz):
Ebuild
Patch1
Patch2

MD5sums (thx Lenz, i was too lazy ;) )
Code:
MD5 c5d2a1b62e1dad502c871bba267337d5 linux-2.6.12.tar.bz2 37511570
MD5 efff3f3ffe06e427fff88e984832ef92 patch-2.6.12-nitro5.bz2 1719297
MD5 a407e2d87661e3aed52a81dda6d859c4 reiser4_fix-take-1.diff.bz2 102955



Gentree wrote:

Gentoo + Nitro = Gazzzzz!
8)


And as usual:
HAVE FUN GODDAMMIT!!!! ;)
_________________
Retired gentoo user


Last edited by Tiger683 on Wed Jul 27, 2005 8:25 am; edited 5 times in total
Back to top
View user's profile Send private message
Lenz
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1439
Location: Marburg [HE, D, EU]

PostPosted: Sat Jul 16, 2005 1:10 pm    Post subject: Reply with quote

Another high speed mirror has been set up: ;)

ebuild:
nitro-sources-2.6.12-r5.ebuild

distfiles:
patch-2.6.12-nitro5.bz2
reiser4_fix-take-1.diff.bz2

Note: In most cases it should be enough to download the ebuild (in bold letters), the other required files will be downloaded automatically from my webspace while emerging the ebuild!

MD5s: (as requested)
Code:
MD5 c5d2a1b62e1dad502c871bba267337d5 linux-2.6.12.tar.bz2 37511570
MD5 efff3f3ffe06e427fff88e984832ef92 patch-2.6.12-nitro5.bz2 1719297
MD5 a407e2d87661e3aed52a81dda6d859c4 reiser4_fix-take-1.diff.bz2 102955



Have fun! :)
_________________
.:: Lenz' Signature 1.7b ::.

| Gentoo Linux since v1.4 (08-2003) [Screenshot]
| NetHack Highscore: 5.476.380 Pts., Val-Dwa-Fem-Law, ~ ascended to demigoddess-hood ~


Last edited by Lenz on Sat Jul 16, 2005 11:49 pm; edited 2 times in total
Back to top
View user's profile Send private message
schiznik
n00b
n00b


Joined: 01 Apr 2005
Posts: 66
Location: Gloucester, UK

PostPosted: Sat Jul 16, 2005 1:13 pm    Post subject: Reply with quote

GAH!!!!

Ive literally just rebooted from upgrading .11-nitro2 to .12-nitro4.

Time to upgrade again I guess.


Last edited by schiznik on Sat Jul 16, 2005 1:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
andrew_wiggin
n00b
n00b


Joined: 21 Apr 2005
Posts: 59
Location: Israel

PostPosted: Sat Jul 16, 2005 1:13 pm    Post subject: Reply with quote

going to check it now
Back to top
View user's profile Send private message
m0p
Apprentice
Apprentice


Joined: 20 Jun 2005
Posts: 205
Location: en_GB

PostPosted: Sat Jul 16, 2005 1:18 pm    Post subject: Reply with quote

I'll try this out later. I have digested the ebuild already, but I am running emerge -e world right now, so I don't want to put any more strain on my system.
Back to top
View user's profile Send private message
lnxz
Guru
Guru


Joined: 03 Jul 2005
Posts: 472
Location: Earth

PostPosted: Sat Jul 16, 2005 1:56 pm    Post subject: Reply with quote

I had to compile agpgart as module to get nvidia-agp module to load. Now Xorg doesn't seem to recognize the nvidia-agp module, nor is it listed by lsmod.
Using patched version of ati-drivers, which worked without problems with nitro3, and I didn't have to compile agpgart as module either.
Would building them both as inbuilt fix this, or is there no way of fixing this problem at the time being? I'm asking because I've tried a couple of different combination and I want to know if it's worth bothering trying any more.
I am aware that this is an experimental kernel flavour and that one should expect things to break, but it seems a bit odd to me that this particular problem should occour, when taken into account that it worked in nitro3.
Not a big problem, though, as I don't use any opengl-apps, it's just nice to have as many things as possible working while having a relativly bleeding edge system.
Back to top
View user's profile Send private message
Lenz
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1439
Location: Marburg [HE, D, EU]

PostPosted: Sat Jul 16, 2005 2:18 pm    Post subject: Reply with quote

Code:
lenz@sulphur ~ $ uname -a
Linux sulphur 2.6.12-nitro5 #1 Sat Jul 16 15:57:01 CEST 2005 i686 AMD Athlon(tm) XP 2000+ AuthenticAMD GNU/Linux

:arrow: Works smoothly! :mrgreen:
_________________
.:: Lenz' Signature 1.7b ::.

| Gentoo Linux since v1.4 (08-2003) [Screenshot]
| NetHack Highscore: 5.476.380 Pts., Val-Dwa-Fem-Law, ~ ascended to demigoddess-hood ~
Back to top
View user's profile Send private message
lnxz
Guru
Guru


Joined: 03 Jul 2005
Posts: 472
Location: Earth

PostPosted: Sat Jul 16, 2005 2:38 pm    Post subject: Reply with quote

Ignore my previous post. Compiling agpgart and nvidia-agp as inbuilt fixed it. Now everything works very smoothly for me too. Great kernel, suits all my needs and then some (probably alot more).
Back to top
View user's profile Send private message
b3cks
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1481
Location: Bremen (GER)

PostPosted: Sat Jul 16, 2005 3:51 pm    Post subject: Reply with quote

Works great so far... :D ThX.

Code:
b3cks@fishbox ~ $ uname -a
Linux fishbox 2.6.12-nitro5 #1 Sat Jul 16 17:30:16 CEST 2005 i686 Intel(R) Pentium(R) M processor 1.70GHz GenuineIntel GNU/Linux


And finally this f*cking preempt output on TTY1 is gone...
_________________
I am /root and if you see me laughing you better have a backup.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sat Jul 16, 2005 4:29 pm    Post subject: Reply with quote

:D :D :D :D :D :D :D :D :D :D :D :!: :!: :!: :!: :!: :!:
_________________
Retired gentoo user
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Sat Jul 16, 2005 5:07 pm    Post subject: Reply with quote

this patchset works perfect!!! :D
thx for this job Tiger683...

Code:
Linux entropie 2.6.12-nitro5 #2 Sat Jul 16 18:39:16 CEST 2005 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz GenuineIntel GNU/Linux
Linux babykart 2.6.12-nitro5 #1 SMP Sat Jul 16 18:40:05 CEST 2005 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux


(with full reiser4 fs)
_________________
>> Gentoo-FR <<
-----
Back to top
View user's profile Send private message
XioXouS
n00b
n00b


Joined: 01 Apr 2005
Posts: 59

PostPosted: Sat Jul 16, 2005 6:06 pm    Post subject: Reply with quote

Applied the patch listed in the link up top, but I had to change my xorg.conf to the following for ATI drivers to work correctly.
Code:

    Option "UseInternalAGPGART"         "yes"


No problems with nvidia-kernel ebuild, VMWare 5, Layer7, alsa-drivers ebuild, or anything else I can think of to look at. Looks like another great job. Thanks.

Code:

Linux sephiroth 2.6.12-nitro5 #2 Sat Jul 16 12:20:31 CDT 2005 i686 AMD Athlon(TM) XP 2000+ AuthenticAMD GNU/Linux
Linux cloud 2.6.12-nitro5 #2 Sat Jul 16 12:19:20 CDT 2005 i686 AMD Athlon(TM) XP 3000+ AuthenticAMD                                                                                                   
Linux jenova 2.6.12-nitro5 #2 Sat Jul 16 12:43:36 CDT 2005 i686 Intel(R) Pentium(R) M processor 1300MHz GenuineIntel GNU/Linux


PS - All are running completely reiser4 paritions except the boot partitions which are ext3
Back to top
View user's profile Send private message
_sys/sid
Guru
Guru


Joined: 27 Aug 2004
Posts: 346
Location: Asola (Mantova)

PostPosted: Sat Jul 16, 2005 6:31 pm    Post subject: I've 2 problem... Reply with quote

I have two problem with -nitro5... (-nitro3 works without problems)
The Configuration of nitro5 is nitro3 config...

The first problem is with: SplashUtils and svga... nitro5 boot with 80x25 console but grub.conf say 1280x1024...
Code:

title GNU/Linux Gentoo 1.6.12 (Kernel 2.6.12-nitro5)
kernel (hd0,2)/kernel-2.6.12-nitro5 ro root=/dev/hda8 video=vesafb:ywrap,pmipal,1280x1024-16@60 splash=silent,fadein,tty:8,theme:livecd-2005.1 quiet CONSOLE=/dev/tty1 vga=794 elevator=anticipatory
initrd (hd0,2)/splash/initrd-spl-livecd-2005.1-all


Code:

title GNU/Linux Gentoo 1.6.12 (Kernel 2.6.12-nitro5)
kernel (hd0,2)/kernel-2.6.12-nitro5 ro root=/dev/hda8  vga=794 elevator=anticipatory


I have:
media-gfx/splashutils-1.1.9.7
svgalib-1.9.21

The Second problem is with Nvidia Kernel...
Code:

# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.12-nitro5/video/nvidia.ko): No such device


Reiser4 [ OK ]

tnks
_________________
http://th30z.netsons.org/
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sat Jul 16, 2005 6:58 pm    Post subject: Reply with quote

for the first: i would get rid of that vga= statement for vesafb-tng , its wrong.
Other than that, i run vfb-tng + fbsplash w/o problems with:
Code:

# For booting GNU/Linux
title  GNU/Linux
root (hd0,0)
kernel /vmlinuz ro root=/dev/hdc3 video=vesafb:ywrap,mtrr,pmipal,1024x768-32@85 elevator=cfq splash=verbose,theme:MaiHoshino CONSOLE=/dev/tty1
initrd (hd0,0)/fbsplash-MaiHoshino-1024x768


for second: same.... Nvidia 6600GT no probs, full hw accel....

i think you should reconfigure your kernel from scratch instead of reusing config, quite some things have changed.
_________________
Retired gentoo user
Back to top
View user's profile Send private message
rjmalagon
n00b
n00b


Joined: 16 Jul 2005
Posts: 7
Location: Cuernavaca, Mexico

PostPosted: Sat Jul 16, 2005 8:26 pm    Post subject: Software suspend2 on AMD64 problem, stops compilation Reply with quote

With or without software suspend 2 activated in the kernel, I can't compile the kernel
This is the output:

Code:

CHK     include/linux/version.h
  CC      arch/x86_64/kernel/asm-offsets.s
In file included from include/linux/suspend2.h:4,
                 from include/linux/suspend.h:12,
                 from arch/x86_64/kernel/asm-offsets.c:11:
include/linux/dyn_pageflags.h: In function `__get_next_bit_on':
include/linux/dyn_pageflags.h:43: error: `max_mapnr' undeclared (first use in this function)
include/linux/dyn_pageflags.h:43: error: (Each undeclared identifier is reported only once
include/linux/dyn_pageflags.h:43: error: for each function it appears in.)
make[1]: *** [arch/x86_64/kernel/asm-offsets.s] Error 1
make: *** [arch/x86_64/kernel/asm-offsets.s] Error 2
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sat Jul 16, 2005 9:06 pm    Post subject: Reply with quote

rjmalagon: this can only happen on a NUMA system,
do you have such system? (Multiprocessor AMD Opteron for example...)
If so, sorry, i have to fix it...if not, i still have to fix it, but you will probably want to swich to normal x86_64 (SMP?????) or
something similar.

cheers

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
rjmalagon
n00b
n00b


Joined: 16 Jul 2005
Posts: 7
Location: Cuernavaca, Mexico

PostPosted: Sat Jul 16, 2005 9:59 pm    Post subject: Thanks about this, yes was NUMA Reply with quote

Was the NUMA support. I only have a CPU, but the nexth month an Athlon 64 x2 is in budget...
For now I will disable smp support. in the kernel.
Thanks for the tip
Back to top
View user's profile Send private message
vrln
Guru
Guru


Joined: 11 Sep 2004
Posts: 534
Location: Finland

PostPosted: Sat Jul 16, 2005 11:04 pm    Post subject: Reply with quote

Just a small request: could you include the tarball md5sums in the announcement?

edit: sorry this is a bit off topic, but seems like CK has released http://members.optusnet.com.au/ckolivas/interbench/ --> has anyone tried it yet and compared ck-based patchsets (like nitro) to vanilla 2.6? Would be interesting to see some statistics.
_________________
Interested in E17? Get Enlightened by reading the user guide.
Back to top
View user's profile Send private message
rjmalagon
n00b
n00b


Joined: 16 Jul 2005
Posts: 7
Location: Cuernavaca, Mexico

PostPosted: Sat Jul 16, 2005 11:51 pm    Post subject: Nforce 4, ati-drivers, kernel 2.6.12. A mercyless mess. Reply with quote

Ati-drivers don't like my radeon X700 PCIE.
Without the patch, is a meltdown for xorg.
With patch some time (most of the time just freeze xorg) works withouth dri. But any atempt on activate DRI in the driver and is sure freeze the machine when xorg is loading.

I am suspecting of IOMMU.

Ati-drivers have internalagpgart on
Kernel have drm off

This is a nforce4 based motherboard (sli edition), 4 GB ram, Athlon64 3000+, Ati radeon X700 PCIE 256MB in slot 1.
Gentoo is compiled for AMD64 arch.

If any of you have this combination working fine, please give some tip o tell me about your config.
Back to top
View user's profile Send private message
Kensai
Guru
Guru


Joined: 09 Mar 2004
Posts: 568
Location: Puerto Rico

PostPosted: Sun Jul 17, 2005 4:42 am    Post subject: Reply with quote

I have nitro4 perfectly running I am compiling nitro 5 just to have a higher number LOL.:lol:
_________________
Gentoo: Gigabyte: nFORCE 2: nVIDIA GeForce 6600: AMD Athlon XP 3200+
Perspective of a Thinking Human Being
Back to top
View user's profile Send private message
_sys/sid
Guru
Guru


Joined: 27 Aug 2004
Posts: 346
Location: Asola (Mantova)

PostPosted: Sun Jul 17, 2005 5:17 am    Post subject: Reply with quote

I've rebuilded without svgalib_helper and now all works...

Code:

# uname -a
Linux nebula 2.6.12-nitro5 #1 SMP Sat Jul 16 21:15:44 CEST 2005 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GenuineIntel GNU/Linux


Code:

# cat /proc/version
Linux version 2.6.12-nitro5 (root@nebula) (gcc version 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1)) #1 SMP Sat Jul 16 21:15:44 CEST 2005


tnks
_________________
http://th30z.netsons.org/
Back to top
View user's profile Send private message
ilikelinux
n00b
n00b


Joined: 19 Dec 2003
Posts: 50

PostPosted: Sun Jul 17, 2005 5:37 am    Post subject: Reply with quote

The ati-drivers work fine under nitro4 - I havent upgraded because I don't use reiser4, so I can't see why they won't work in nitro5.

If you want, i can make an archive of my driver ebuild dir. that has all the patches that includes all the 2.6.12 patches that it needs to work.
Back to top
View user's profile Send private message
kare
n00b
n00b


Joined: 06 Jun 2004
Posts: 26
Location: Friedberg, Germany

PostPosted: Sun Jul 17, 2005 10:13 am    Post subject: Reply with quote

ipw2200 is not working for me. The output from iwconfig looks like being connected, but there are packages in the "Invalid misc" counter.
I removed it from kernel and emerged ipw2200-1.0.4, ipw2200-firmware-2.3 which is now working.
Other ebuilds (older and newer) didn't compile.

All other runs perfectly.
Thanks.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sun Jul 17, 2005 10:51 am    Post subject: Reply with quote

the version of the driver in the kernel _IS_ALSO_ ipw2200-1.0.4,
actually taken from portage ;)

it might be that you have to reemerge firmware after having ipw built AS MODULE in the kernel.

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
chronophobic
Apprentice
Apprentice


Joined: 07 Mar 2005
Posts: 237
Location: Sofia, Bulgaria

PostPosted: Sun Jul 17, 2005 10:58 am    Post subject: Reply with quote

Just compiled and ran it, all works great except for alsa. I know that Nitro contains the CVS version and I shouldn't emerge it from portage, but I already had it emerged and I'm not sure what I'm supposed to do now.

Which ones of the alsa-things that I have installed do I need to get rid of now?

Code:
 
alsa-lib
xmms-alsa
alsa-jack
alsa-headers
gst-plugins-alsa


Will it work by just emerge -C some (or all) of the things above and then reboot, or do I have to do something else to get alsa to work?
_________________
Confutatis maledictis, flammis acribus addictis!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Page 1 of 10

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum