Joined: 12 May 2004
|Posted: Mon Jul 11, 2005 1:43 pm Post subject: [ GLSA 200507-09 ] Adobe Acrobat Reader: Buffer overflow vul
|Gentoo Linux Security Advisory
Title: Adobe Acrobat Reader: Buffer overflow vulnerability (GLSA 200507-09)
Date: July 11, 2005
Adobe Acrobat Reader is vulnerable to a buffer overflow that could lead to remote execution of arbitrary code.
Adobe Acrobat Reader is a utility used to view PDF files.
Vulnerable: <= 5.10
Unaffected: >= 7.0
Architectures: All supported architectures
A buffer overflow has been discovered in the UnixAppOpenFilePerform() function, which is called when Adobe Acrobat Reader tries to open a file with the "Filespec" tag.
By enticing a user to open a specially crafted PDF document, a remote attacker could exploit this vulnerability to execute arbitrary code.
There is no known workaround at this time.
Since Adobe will most likely not update the 5.0 series of Adobe Acrobat Reader for Linux, all users should upgrade to the latest available version of the 7.0 series:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/acroread-7.0"
iDEFENSE Security Advisory
Adobe Security Advisory
Last edited by GLSA on Sun May 07, 2006 4:57 pm; edited 1 time in total