Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[USB]Probleme de montage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Auze
n00b
n00b


Joined: 31 Jan 2006
Posts: 13

PostPosted: Tue Feb 14, 2006 10:19 pm    Post subject: [USB]Probleme de montage Reply with quote

Bonjour à tous !!!

Voila j'esseye de configurer mes ports usb pour pouvoir branches les peripherique de stockage de masse ( clef usb, mp3 etc..)

J'ai bien compiler les bonnes options dans le kernel j'ai vérifié plusieurs fois.fi

mon .config :

http://pastebin.com/556433

J'ai suivi à la lettre les tuto pour mettre udev, ivman, hal, hotplug, coldplud.

Lorsque je monte à la main j'obtient ceci

Code:

 localhost auze # mount /dev/sda1 /home/auze/Psp
mount: /dev/sda1 is not a valid block device


et lorsque je branche un périphérique à chaud j'obtient cei (ici une psp) :

http://pastebin.com/554981

je précise que je suis sur un Pc portable Fujitsu Amilo :

Athlon XP-m 2.2ghz
760 Mo de ram
Kernel 2.6.15

Merci à vous :P


Last edited by Auze on Wed Feb 15, 2006 7:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
Auze
n00b
n00b


Joined: 31 Jan 2006
Posts: 13

PostPosted: Wed Feb 15, 2006 3:17 pm    Post subject: Reply with quote

Personne n'a d'idées ???


S'il vous plait, c'est vraiment relou la...

Merci
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1591
Location: 127.0.0.1

PostPosted: Wed Feb 15, 2006 3:23 pm    Post subject: Reply with quote

Bonjour,

Mettre ton .config en entier ne sert qu'à une chose : faire fuir tout le monde. :wink:
Tu devrais plutôt donner les informations suggérées par kernel_sensei (Problème avec l'usb).
Lorsque tu branches ta clef, que donne :
Code:

dmesg | tail
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Feb 15, 2006 3:24 pm    Post subject: Reply with quote

Salut,

désactive ça Low Performance USB Block driver qui est situé ici :
Code:


  │   Location:                                                             │
  │     -> Device Drivers                                                   │
  │       -> Block devices                                                  │


Concernant ton support USB, essaye en activant uniquement le support USB pour ton chip !

Et que donne un dmesg quand tu branche un periph mass storage ? (pas la peine de donner tout le dmesg, juste les 10 dernieres lignes ca devrait suffire)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Auze
n00b
n00b


Joined: 31 Jan 2006
Posts: 13

PostPosted: Wed Feb 15, 2006 4:59 pm    Post subject: Reply with quote

raaahhh Merci :) :)

bon j'ai regardé le post de kernel_sensei

Mes periph usb sont bien reconnu.

Dsl pour le .config mais je pensai bien faire.

Sinon voila ce que me retourne le dmesg :

Quote:


usb_storage: device found at 2
usb_storage: waiting for device to settle before scanning
usb 1-1 new high speed USB device using ehci_hcd and adress 3
scsi1: SCSI emulation for USB Mass Storage devices
usb_storage: device found at 3
usb_storage: waiting for device to settle before scanning
Vendor: Sony Model: PSP Rev: 1.00
Type: Direct-access ANSI SCSI revision: 00
usb_storage: device scan complete



Et voila ce que me retourne le syslog-ng :

Quote:

Feb 14 23:41:23 localhost ivman: New Device: /org/freedesktop/Hal/devices/usb_device_54c_1c8_noserial_if0_scsi_host
Feb 14 23:41:23 localhost ivman: /org/freedesktop/Hal/devices/usb_device_54c_1c8_noserial_if0_scsi_host wasn't mounted, by us or by others...
Feb 14 23:41:28 localhost Vendor: Sony Model: PSP Rev: 1.00
Feb 14 23:41:28 localhost Type: Direct-Access ANSI SCSI revision: 00
Feb 14 23:41:28 localhost usb-storage: device scan complete
Feb 14 23:41:28 localhost ivman: New Device: /org/freedesktop/Hal/devices/usb_device_54c_1c8_noserial_if0_scsi_host_scsi_device_lun0
Feb 14 23:41:28 localhost ivman: /org/freedesktop/Hal/devices/usb_device_54c_1c8_noserial_if0_scsi_host_scsi_device_lun0 wasn't mounted, by us or by others...
Feb 14 23:41:28 localhost scsi.agent[8363]: disk at /devices/pci0000:00/0000:00:10.3/usb1/1-1/1-1:1.0/host3/target3:0:0/3:0:0:0


Par contre :

Quote:

Concernant ton support USB, essaye en activant uniquement le support USB pour ton chip !


C'est à dire ???

Quote:

# may also be needed; see USB_STORAGE Help for more information
#
CONFIG_USB_STORAGE=y
# CONFIG_USB_STORAGE_DEBUG is not set
CONFIG_USB_STORAGE_DATAFAB=y
CONFIG_USB_STORAGE_FREECOM=y
CONFIG_USB_STORAGE_ISD200=y
CONFIG_USB_STORAGE_DPCM=y
CONFIG_USB_STORAGE_USBAT=y
CONFIG_USB_STORAGE_SDDR09=y
CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y


Enlever ça par exemple ???

Merci beaucoup :)
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Wed Feb 15, 2006 10:27 pm    Post subject: Reply with quote

Code:
lspci -v


Code:
lsusb -v


Tu auras des infos...

[EDIT] Est-ce que tu as bien formaté ta partition ?Fait une vérif des blocs...[/EDIT]


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Auze
n00b
n00b


Joined: 31 Jan 2006
Posts: 13

PostPosted: Thu Feb 16, 2006 10:58 am    Post subject: Reply with quote

Coucou !!

Le lsusb -v ne donne rien d'anormal apparament puisque l'usb est coorectement configuré.

Le formatage est bon aussi puisque sous un liveCD tout marche correctement sur les 5 ports

Je cherche, je cherche.....


:x :x 8O 8O :x :x 8O 8O
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Thu Feb 16, 2006 12:07 pm    Post subject: Reply with quote

Code:
ls /dev/sd*


Si tu n'a rien il faudra créer un fichier spécial avec mknod , man mknod

Code:
fdisk -l



Je suppose que tu cherches avec le moteur de recherche de gentoo ou il y a sûrement des infos sur les périphs , usb, scsi, flash qui peuvent t'intéresser...


@+
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum