Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QSampler, libgig dependency fails download [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Palhoto
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2003
Posts: 102
Location: Iberian Peninsula

PostPosted: Mon Jun 20, 2005 1:38 pm    Post subject: QSampler, libgig dependency fails download [SOLVED] Reply with quote

Hi,

QSampler needs to be unmasked (in /etc/portage/package.unmask) and ~x86-ified (in /etc/portage/package.keywords), along with its dependencies, media-libs/libgig and media-libs/liblscp.

liblscp emerged without a hassle. libgig is the real problem.

The file is retrieved successfully from http://stud.fh-heilbronn.de/~cschoene/projects/libgig/libgig-2.0.0.tar.bz2 . Length: 62,603 Bytes.

But then, without any apparent reason:

Code:
!!! Couldn't download libgig-2.0.0.tar.bz2. Aborting.

And therefore, the emerge doesn't even compile.

I tried removing the file several times, downloaded manually, emerged with --oneshot, but no luck.

It could probably be a problem with the ebuild file, unfortunately I'm not ebuild literate yet.

Thanks in advance.


Last edited by Palhoto on Fri Jun 24, 2005 12:35 am; edited 2 times in total
Back to top
View user's profile Send private message
Palhoto
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2003
Posts: 102
Location: Iberian Peninsula

PostPosted: Thu Jun 23, 2005 11:21 pm    Post subject: Reply with quote

Bug report at http://bugs.gentoo.org/show_bug.cgi?id=96904 .
Back to top
View user's profile Send private message
Palhoto
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2003
Posts: 102
Location: Iberian Peninsula

PostPosted: Fri Jun 24, 2005 12:21 am    Post subject: Reply with quote

I found a solution, by using Portage Overlay for the libgig-2.0.1 version.

I also had to comment out the following line in the libgig-2.0.1.ebuild.

Code:
#S="${WORKDIR}/${PN}"

The corresponding bug is now "WORKSFORME".
Back to top
View user's profile Send private message
Palhoto
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2003
Posts: 102
Location: Iberian Peninsula

PostPosted: Fri Jun 24, 2005 1:34 pm    Post subject: Latest versions of the linux sampler packages working Reply with quote

I've gotten the latest linuxsampler platform packages working using Portage Overlay.

Code:
# emerge -pv libgig liblscp linuxsampler qsampler
[...]
[ebuild   R   ] media-libs/libgig-2.0.1  -doc 0 kB [1]
[ebuild   R   ] media-libs/liblscp-0.3.0  -doc 0 kB [1]
[ebuild   R   ] media-sound/linuxsampler-0.3.2  +jack 0 kB [1]
[ebuild   R   ] media-sound/qsampler-0.1.2  +arts -debug +kdeenablefinal +xinerama 0 kB [1]

BTW, you need to comment out the following line of the linuxsampler-0.3.2.ebuild (as with libgig):

Code:
#S="${WORKDIR}/${PN}"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum