Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Booting SGI O2 R5000 IP32 180Mhz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Mon Mar 14, 2005 11:01 pm    Post subject: Booting SGI O2 R5000 IP32 180Mhz Reply with quote

I'm posting as much information as I can so I can get a second opinion.

I can't boot via the command bootp(): root=/dev/ram0 On the sgi I get this output: Setting $netaddr to 10.1.2.11 (from server ) Unable to execute bootp():: Invalid argument


ashpool root # ls -l /tftproot/
total 8696
-rwxrwxrwx 1 root root 8885699 Jan 28 23:34 ip32-r5k-20050128.img


/var/log/messages:
Mar 14 13:26:03 ashpool dhcpd: BOOTREQUEST from 08:00:69:0c:15:73 via eth0 Mar 14 13:26:03 ashpool dhcpd: BOOTREPLY for 10.1.2.11 to sgi (08:00:69:0c:15:73) via eth0 Mar 14 18:26:03 ashpool in.tftpd[6780]: RRQ from 10.1.2.11 filename /tftproot/ip32-r5k-20050128.img Mar 14 18:26:32 ashpool in.tftpd[6781]: RRQ from 10.1.2.11 filename /tftproot/ip32-r5k-20050128.img

ashpool root # cat /etc/conf.d/in.tftpd # Config file for /etc/init.d/in.tftpd # Remove the -l if you use [x]inetd

INTFTPD_PATH="/tftproot"
INTFTPD_OPTS="-l -v -s ${INTFTPD_PATH}"

ashpool root # cat /etc/dhcp/dhcpd.conf
# Tell dhcpd to disable dynamic DNS.
# dhcpd will refuse to start without this.
ddns-update-style none;

# Create a subnet:
subnet 10.1.2.0 netmask 255.255.255.0 {
# Address pool for our booting clients. Don't forget the 'dynamic-bootp' bit!
pool {
range dynamic-bootp 10.1.2.1 10.1.2.254;
}

# DNS servers and default gateway -- substitute as appropriate
option domain-name-servers 10.0.0.5, 10.0.0.10;
option routers 10.1.2.1;

# Tell the DHCP server it's authoritative for this subnet.
authoritative;

# Allow BOOTP to be used on this subnet.
allow bootp;

# SGI Workstation... change 'sgi' to your SGI machine's hostname.
host sgi {

# MAC Address of SGI Machine. Normally this is written on the back
# or base of the machine.
hardware ethernet 08:00:69:0c:15:73;

# TFTP Server to download from (by default, same as DHCP server)
next-server 10.1.2.10;

# IP address to give to the SGI machine
fixed-address 10.1.2.11;

# Filename for the PROM to download and boot
filename "/tftproot/ip32-r5k-20050128.img";
}
}

Thanks,
James
Back to top
View user's profile Send private message
dj604
n00b
n00b


Joined: 30 Mar 2004
Posts: 26
Location: milwaukee

PostPosted: Mon Mar 14, 2005 11:57 pm    Post subject: Reply with quote

try changing this:

filename "/tftproot/ip32-r5k-20050128.img";

to this:

filename "/ip32-r5k-20050128.img";

I think with tftpd if you have the tftproot directory already set in it's conf file, then you don't need to set it again- your system might be trying to find the file at /tftproot/tftproot/ip32-r5k-20050128.img if you hardcode that path in there..
Back to top
View user's profile Send private message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Tue Mar 15, 2005 3:16 pm    Post subject: Reply with quote

Quote:
I think with tftpd if you have the tftproot directory already set in it's conf file, then you don't need to set it again- your system might be trying to find the file at /tftproot/tftproot/ip32-r5k-20050128.img if you hardcode that path in there..


Do you mean in the dhcp conf?

thanks,
James
Back to top
View user's profile Send private message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Tue Mar 15, 2005 3:45 pm    Post subject: Reply with quote

Okay I tried it both ways in /etc/dhcp/dhcp.conf and got:

Mar 15 15:19:41 ashpool in.tftpd[13264]: RRQ from 10.1.2.11 filename ip32-r5k-20050128.img
Mar 15 15:20:10 ashpool in.tftpd[13304]: RRQ from 10.1.2.11 filename ip32-r5k-20050128.img
Mar 15 15:20:40 ashpool in.tftpd[13305]: RRQ from 10.1.2.11 filename ip32-r5k-20050128.img
Mar 15 15:21:10 ashpool in.tftpd[13306]: RRQ from 10.1.2.11 filename ip32-r5k-20050128.img
Mar 15 15:22:49 ashpool in.tftpd[13442]: RRQ from 10.1.2.11 filename /ip32-r5k-20050128.img
Mar 15 15:23:18 ashpool in.tftpd[13443]: RRQ from 10.1.2.11 filename /ip32-r5k-20050128.img
Mar 15 15:23:48 ashpool in.tftpd[13444]: RRQ from 10.1.2.11 filename /ip32-r5k-20050128.img
Mar 15 15:24:18 ashpool in.tftpd[13445]: RRQ from 10.1.2.11 filename /ip32-r5k-20050128.img

I'm still have the same problem. Any other thoughts?


thanks,
James
Back to top
View user's profile Send private message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Tue Mar 15, 2005 4:27 pm    Post subject: Reply with quote

I used a cross over cable and went direct between these two machines.,

tcpdump -v
I'm guessing this is the relevant stuff.

11:20:35.038264 arp who-has 10.1.2.11 tell 10.1.2.11
11:20:35.038390 IP (tos 0x0, ttl 255, id 48, offset 0, flags [none], length: 328) 10.1.2.11.bootpc > 255.255.255.255.bootps: [no cksum] BOOTP/DHCP, Request [|bootp]
11:20:35.039014 arp who-has 10.1.2.1 tell ashpool
11:20:35.039080 IP (tos 0x10, ttl 16, id 0, offset 0, flags [none], length: 328) ashpool.bootps > 10.1.2.11.bootpc: BOOTP/DHCP, Reply, length: 300, xid:0x252c, secs:5, flags: [none]
Client IP: 10.1.2.11
Your IP: 10.1.2.11
Server IP: ashpool [|bootp]
11:20:35.039278 arp who-has 10.1.2.11 tell 10.1.2.11
11:20:35.050091 IP (tos 0x0, ttl 255, id 49, offset 0, flags [none], length: 63) 10.1.2.11.9517 > ashpool.tftp: [no cksum] 35 RRQ "/ip32-r5k-20050128.img" o
11:21:04.967708 IP (tos 0x0, ttl 255, id 50, offset 0, flags [none], length: 63) 10.1.2.11.9518 > ashpool.tftp: [no cksum] 35 RRQ "/ip32-r5k-20050128.img" o
11:21:04.968696 IP (tos 0x0, ttl 64, id 36231, offset 0, flags [DF], length: 544) ashpool.33237 > 10.1.2.11.9518: UDP, length: 516
11:21:05.968426 IP (tos 0x0, ttl 64, id 36232, offset 0, flags [DF], length: 544) ashpool.33237 > 10.1.2.11.9518: UDP, length: 516
11:21:06.045413 IP (tos 0x0, ttl 64, id 6313, offset 0, flags [DF], length: 544) ashpool.33235 > 10.1.2.11.9517: UDP, length: 516
11:21:07.968117 IP (tos 0x0, ttl 64, id 36233, offset 0, flags [DF], length: 544) ashpool.33237 > 10.1.2.11.9518: UDP, length: 516
11:21:11.967514 IP (tos 0x0, ttl 64, id 36234, offset 0, flags [DF], length: 544) ashpool.33237 > 10.1.2.11.9518: UDP, length: 516
11:21:12.967352 arp who-has 10.1.2.11 tell ashpool
11:21:12.967491 arp reply 10.1.2.11 is-at 08:00:69:0c:15:73
11:21:19.966291 IP (tos 0x0, ttl 64, id 36235, offset 0, flags [DF], length: 544) ashpool.33237 > 10.1.2.11.9518: UDP, length: 516
11:21:34.964147 IP (tos 0x0, ttl 255, id 51, offset 0, flags [none], length: 63) 10.1.2.11.9519 > ashpool.tftp: [no cksum] 35 RRQ "/ip32-r5k-20050128.img" o


Hope this helps,

James
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Thu Mar 17, 2005 10:59 am    Post subject: Reply with quote

What do you get if you type cat /proc/sys/net/ipv4/ip_{no_pmtu_disc,local_port_range}? It should be something like this:

Code:
(20:56) www stuartl # cat /proc/sys/net/ipv4/ip_{no_pmtu_disc,local_port_range}
1
2048    32767


If it isn't ... have another read of the netbooting section of the Gentoo/MIPS handbook -- and try the commands there for setting those options.

(Also... when posting configs/command output... could you please use [ code ][ /code ] tags -- that way it's all nicely tabbed out in a monospace font)
_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Mon Mar 21, 2005 9:42 pm    Post subject: Reply with quote

Here is the output:
Quote:
ashpool conf.d # cat /proc/sys/net/ipv4/ip_no_pmtu_disc
0
ashpool conf.d # cat /proc/sys/net/ipv4/ip_local_port_range
32768 61000
ashpool conf.d #


Thanks for the input on the quoting, wasn't sure what the etiquette was.

Does ip_no_pmtu_disc get changed after a reboot? I did make the change according to the doc but have rebooted since.
thanks,
James
Back to top
View user's profile Send private message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Mon Mar 21, 2005 9:44 pm    Post subject: Reply with quote

Okay its booting thanks very much!
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Tue Mar 22, 2005 12:38 am    Post subject: Reply with quote

Yep... like many other files in /proc, it's set back to the default value once it boots.

If you want the change to stay, try putting the appropriate commands in /etc/conf.d/local.start
_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 208
Location: Stockholm, Sweden

PostPosted: Fri Jun 03, 2005 9:09 pm    Post subject: /proc and SGI O2 installation Reply with quote

I'm in the process of trying to do the same thing as jmarcus and am getting the same error message. However, unlike jmarcus, I did NOT follow one of the instructions in the MIPS handbook, and that is the part where you funnel stuff into /proc.
Quote:

Code Listing 5: Some fixes to SGI machines to have TFTP work properly
(Disable "Path Maximum Transfer Unit", otherwise SGI Prom won't find the kernel)
# echo 1 > /proc/sys/net/ipv4/ip_no_pmtu_disc

(Set the port range usable by the SGI PROM)
# echo "2048 32767" > /proc/sys/net/ipv4/ip_local_port_range
This should be sufficient to allow the Linux server to play nice with SGI's PROM.

I took a look at what was in /proc (under Irix 6.5) and I only saw bunches of two-digit numbers plus one directory (pinfo, or some such) which itself only contained bunches of two-digit numbers. I don't have the machine in front of me now, but if there was a sys under /proc, that was as far as it went.

So my question: Is one supposed to build the path /proc/sys/net/ipv4/{ip_no_pmtu_disc, ip_local_port_range} if it doesn't already exist?
If so, and /proc is wiped out on reboot, how does one get from a root console (where they have just funnelled the stuff into /proc to the PROM manager without a reboot? Is the only way to use the "local.start" as Redhatter suggests? I am a newbie to Irix admin, so please forgive me if these are stupid questions.
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Sat Jun 04, 2005 12:15 am    Post subject: Re: /proc and SGI O2 installation Reply with quote

iMike wrote:
I'm in the process of trying to do the same thing as jmarcus and am getting the same error message. However, unlike jmarcus, I did NOT follow one of the instructions in the MIPS handbook, and that is the part where you funnel stuff into /proc.
Quote:

Code Listing 5: Some fixes to SGI machines to have TFTP work properly
(Disable "Path Maximum Transfer Unit", otherwise SGI Prom won't find the kernel)
# echo 1 > /proc/sys/net/ipv4/ip_no_pmtu_disc

(Set the port range usable by the SGI PROM)
# echo "2048 32767" > /proc/sys/net/ipv4/ip_local_port_range
This should be sufficient to allow the Linux server to play nice with SGI's PROM.

I took a look at what was in /proc (under Irix 6.5) and I only saw bunches of two-digit numbers plus one directory (pinfo, or some such) which itself only contained bunches of two-digit numbers. I don't have the machine in front of me now, but if there was a sys under /proc, that was as far as it went.


Those are commands you're susposed to run on the TFTP/BOOTP server, which is assumed to run Linux in the Handbook. It even states this here under section 2.c. Netbooting Overview. ;-)
As far as IRIX is concerned, I have no idea where you'd go to set those options... have a look on the web for how to disable MTU discovery and to set the local port range.

Quote:
So my question: Is one supposed to build the path /proc/sys/net/ipv4/{ip_no_pmtu_disc, ip_local_port_range} if it doesn't already exist?
If so, and /proc is wiped out on reboot, how does one get from a root console (where they have just funnelled the stuff into /proc to the PROM manager without a reboot? Is the only way to use the "local.start" as Redhatter suggests? I am a newbie to Irix admin, so please forgive me if these are stupid questions.


If you're a newbie IRIX admin... then I'm a newbie IRIX user.... I have NO idea how you'd set these options... Have a look at your documentation and see if there's any instructions on how to netboot a workstation... and just substitute their kernel for the Gentoo one.
_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 208
Location: Stockholm, Sweden

PostPosted: Sun Jun 05, 2005 5:42 pm    Post subject: Re: /proc and SGI O2 installation Reply with quote

Dear Redhatter,

Thank you for the advice; I'll give it a try!

I went back and re-read the handbook, but--and don't get me wrong, I think the Gentoo manuals are really well done--it still was not clear to me WHERE the funneling into /proc was supposed to be done: on the SGI or the boot server. Admittedly, now when I re-read:

Quote:

This should be sufficient to allow the Linux server to play nice with SGI's PROM


It does sound more like the server, :oops: but it could be a clearer 8O. Ah, maybe I'm just a grump! I really appreciate the help! :D
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Sun Jun 05, 2005 11:55 pm    Post subject: Reply with quote

Hey, thanks for the feedback... Does this look better?

Quote:
We're almost done, but there's a couple of little tweaks still to be done. Pull up a console with root privileges, and enter the following commands.

Note: These commands are intended to be run on the TFTP server, which (as mentioned earlier) is assumed to run Linux. If you run another OS, you will need to read the appropriate documentation on how you change the Path Maximum Transfer Unit and Local Port Range settings used.

Code listing 5: Some fixes on Linux to SGI machines to have TFTP work properly.

_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 208
Location: Stockholm, Sweden

PostPosted: Tue Jun 07, 2005 12:16 pm    Post subject: Re: /proc and SGI O2 installation Reply with quote

Dear Redhatter,

Yes, that is clearer. Thanks for taking the time to improve the wording. Also, a big thanks for your tip. My O2 netbooted with Gentoo this morning :!: just following the docs with your tip on where to funnel those values on the tftp server. You is da man! Thanks :D

/Mike
Back to top
View user's profile Send private message
Kumba
Developer
Developer


Joined: 16 Jul 2002
Posts: 383
Location: Sigma 957

PostPosted: Mon Jun 13, 2005 7:39 pm    Post subject: Reply with quote

Just for clarification, the Port and MTU bits only need changing on Linux systems with a kernel 2.4 or greater. IRIX, Solaris, Linux 2.2, etc.., don't need these settings applied.


--Kumba
_________________
"The past tempts us, the present confuses us, the future frightens us. And our lives slip away, moment by moment, lost in that vast, terrible in-between."
--Emperor Turhan, Centauri Republic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum