Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Setting gateway on boot: [!!] [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Conditional_Zenith
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2004
Posts: 144
Location: Australia

PostPosted: Sun Jun 12, 2005 4:46 am    Post subject: Setting gateway on boot: [!!] [solved] Reply with quote

After the new net.eth0 init script, I get these lines while booting.

Quote:

* Starting eth0
* --Bringing up eth0
* ----dhcp
* ------Running dhcpcd ... [ ok ]
* ------eth0 received address 192.168.0.xxx
* --Adding routes
* ----default gw 192.168.0.1 ... [ !! ]


(it didn't really say xxx, I changed it cause I'm paranoid :) )

I'm trying to work out what is happening, but I'm getting lost in /etc/init.d/net.eth0

I get this from route, and everything appears to work fine (I can access the internet, etc.).
Quote:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
loopback localhost 255.0.0.0 UG 0 0 0 lo
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0


Does anyone know how I can get the error message? or know straight out what is happening?

Edit: added the '-'s to show indentation


Last edited by Conditional_Zenith on Mon Jun 13, 2005 2:05 am; edited 1 time in total
Back to top
View user's profile Send private message
fido
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2003
Posts: 148
Location: WSU, Pullman, WA

PostPosted: Sun Jun 12, 2005 5:42 am    Post subject: Reply with quote

First off, I wouldnt worry too much about hiding your actual IP address, since it is an internal IP which really doesn't mean anything to anyone outside of your network.

Second, can you check what is in your syslog around that time? There might be something in there telling you why it isnt working.
_________________
Amatures built the Ark, professionals built the Titanic
Back to top
View user's profile Send private message
Conditional_Zenith
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2004
Posts: 144
Location: Australia

PostPosted: Sun Jun 12, 2005 6:48 am    Post subject: Reply with quote

I did tell you I was being paranoid. Seriously though, I am behind a router that isn't mine, and the password is the factory default, so I might as well have a external IP.

The logs stop saying stuff as soon as init is run.
Back to top
View user's profile Send private message
maigret
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2004
Posts: 139
Location: Germany

PostPosted: Sun Jun 12, 2005 5:20 pm    Post subject: Reply with quote

Check out this link :
http://forums.gentoo.org/viewtopic-t-347256-highlight-gateway.html

Hope it helps... I have the same problem now.
Back to top
View user's profile Send private message
Conditional_Zenith
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2004
Posts: 144
Location: Australia

PostPosted: Mon Jun 13, 2005 1:15 am    Post subject: Reply with quote

It does help. Just needed to comment out the line in my /etc/conf.d/net for setting the gateway. Seems dhcpcd does that itself.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum