Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New Glibc5.5 & Pthreads && Libstdc++ &&& Multilib = !@#$
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Mandr4ke
Apprentice
Apprentice


Joined: 25 Jul 2002
Posts: 214
Location: Chicago, IL

PostPosted: Thu Jan 11, 2007 4:02 pm    Post subject: New Glibc5.5 & Pthreads && Libstdc++ &&& Reply with quote

I think i was reading that pthreads is no longer viable with the new glibc.. this pretty much made me kill my system and reinstall with the older version.

Has anyone else noticed a problem with stdc++ and pthreads in multilib 32 bit environment and what was replaced with it, I think I saw something about linux threads but what header are thoese in? and is there a replacement for libstdc++ compability? I'm was getting crazy seg defaults, and what a fraken mess!

This was a very nasty surprise and I was compiling "amd64" not the "~am64".. It still shows 2.4 as last major version on their site. Seems that the gcc4.1.1 also needs to be downgraded, even with glibc2.4 you still can't run programs compiled with -m32 properly without them crashing becasue the emul libs mis-match.

You might think it would at least wait for full compability before being thrown in the stable tree. I've been re-emergeing and reinstalling fresh since Last Friday tracking this all down.. haha


Last edited by Mandr4ke on Sat Jan 13, 2007 2:12 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1752

PostPosted: Fri Jan 12, 2007 2:20 pm    Post subject: Reply with quote

http://packages.gentoo.org/search/?sstring=glibc
Back to top
View user's profile Send private message
Mandr4ke
Apprentice
Apprentice


Joined: 25 Jul 2002
Posts: 214
Location: Chicago, IL

PostPosted: Sat Jan 13, 2007 2:20 am    Post subject: Reply with quote

Keruskerfuerst wrote:
http://packages.gentoo.org/search/?sstring=glibc


Ah very nice chart, never knew about that.. :) not sure how i got it emerged then if it's not marked as stable, although i had to mask it on a second "fresh" installed might be that gcc-4.1.1 is pulling glibc2.5

Ahwell after a long week I've gotten the system going so far, i tried just masking glibc but found that gcc4.1.1 doesn't work with the stdlibc++ and pthreads with the -m32 env.. and re-downgraded gcc to 3.4.6 .. re-emerging world right now and just hope i can relax this weekend.. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum