Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update world doesn't tell the truth? [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
henrikj
n00b
n00b


Joined: 03 Jun 2007
Posts: 5

PostPosted: Wed Nov 12, 2008 2:24 pm    Post subject: Update world doesn't tell the truth? [Solved] Reply with quote

Hi,

I'm not sure if this is a bug or expected behaviour, but if I try to update world this happens:

Code:
# emerge -pvuD world

These are the packages that would be merged, in order:

Calculating world dependencies... done!

Total: 0 packages, Size of downloads: 0 kB


i.e nothing. I interpret this as "this machine is already up-to-date, no need to emerge anything"

But this command shows something else:
Code:

 # emerge -pveDt mysql

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] dev-db/mysql-5.0.60-r1  USE="berkdb latin1 perl ssl -big-tables -cluster -debug -embedded -extraengine -max-idx-128 -minimal (-selinux) -static"
[ebuild   R   ]  dev-perl/DBD-mysql-4.00.5  0 kB
[ebuild   R   ]   dev-db/mysql-5.0.60-r1  USE="berkdb latin1 perl ssl -big-tables -cluster -debug -embedded -extraengine -max-idx-128 -minimal (-selinux) -static" 0 kB
[nomerge      ] dev-perl/DBD-mysql-4.00.5
[nomerge      ]  dev-perl/DBI-1.601
>>> cut <<<
[nomerge      ] dev-db/mysql-5.0.60-r1  USE="berkdb latin1 perl ssl -big-tables -cluster -debug -embedded -extraengine -max-idx-128 -minimal (-selinux) -static"
[ebuild     U ]  sys-apps/ed-1.0 [0.9] 67 kB
[nomerge      ] sys-apps/man-pages-posix-2003a
[ebuild   R   ]  sys-apps/man-1.6f-r2  USE="nls" 0 kB
[ebuild   R   ]   sys-apps/groff-1.19.2-r1  USE="-X -cjk" 0 kB
... continues ...


Look at sys-apps/ed - is is not updated?!

This command shows nothing either:
Code:

# emerge -pvuD mysql

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB


So, is this wrong? Or is this the expected result? I'd like to have installed packages in the latest stable version available :)

Btw, I'm on x86 (stable)

/Henrik


Last edited by henrikj on Wed Nov 12, 2008 2:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
notHerbert
Advocate
Advocate


Joined: 11 Mar 2008
Posts: 2228
Location: 45N 73W

PostPosted: Wed Nov 12, 2008 2:25 pm    Post subject: Reply with quote

Try this

Code:
emerge -uDNav --with-bdeps y world
Back to top
View user's profile Send private message
henrikj
n00b
n00b


Joined: 03 Jun 2007
Posts: 5

PostPosted: Wed Nov 12, 2008 2:37 pm    Post subject: Reply with quote

notHerbert wrote:
Try this

Code:
emerge -uDNav --with-bdeps y world


Well that did the trick! :) As usual it's me who should have read the manual better... No bug at least - that's good!

I'll just have to change my update routine and this extra option to emerge (or to EMERGE_DEFAULT_OPTS).

Thank you! :)
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Wed Nov 12, 2008 2:38 pm    Post subject: Reply with quote

To get this all time add this to /etc/make.conf
Quote:
EMERGE_DEFAULT_OPTS="--with-bdeps y"

_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum