Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to get xdirectfb working
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
bruor
Apprentice
Apprentice


Joined: 08 Jul 2003
Posts: 239

PostPosted: Fri Dec 26, 2003 2:21 pm    Post subject: Reply with quote

qingy was just an idea cause its a framebuffer log in manager i havent got around to trying it out yet...
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Fri Dec 26, 2003 3:27 pm    Post subject: Reply with quote

bruor wrote:
qingy was just an idea cause its a framebuffer log in manager i havent got around to trying it out yet...

Well, if you have framebuffer and you like eye candy, Quingy is more bang for a buck than you can ever get. Give it a try, it's really no hassle to get it working.

I havent toyed more xdirectfb, but I came to think, maybe xdirectfb is made to be the sole terninal interface, once it's started.

Qingy uses the same framebuffer, but you still can have text terminal to witch you can switch, and it's not in conflict with gpm (while in xdirectfb, you see gpm drawing on the canvas when moving the mouse. Pretty ugly in Gnome).
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
Moled
l33t
l33t


Joined: 09 Jul 2003
Posts: 635

PostPosted: Fri Dec 26, 2003 5:29 pm    Post subject: Reply with quote

add the line:
Code:

vt-switching


to your ~/.directfbrc to enabled vt-switching


and does anybody have any idea how to fix the mouse double click issue?
Back to top
View user's profile Send private message
zerwas
n00b
n00b


Joined: 22 Dec 2003
Posts: 24

PostPosted: Fri Dec 26, 2003 10:05 pm    Post subject: Reply with quote

I have the same problem with the double click issue. It's the only thing that holds me from using xdirectfb. My Mouse seems to get detected twice (or the libdirectfb_ps2mouse.so driver) - perhaps that is the problem? And if i click too much around, it doesn't react at all.
Back to top
View user's profile Send private message
bruor
Apprentice
Apprentice


Joined: 08 Jul 2003
Posts: 239

PostPosted: Sun Dec 28, 2003 4:14 pm    Post subject: Reply with quote

i have the same problem with my mouse... well the TP control stick thing...
is there a way to change the driver it uses so that i dont have this issue? and if not how do i tell it to use a usb mouse over that one?
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 405

PostPosted: Mon Jan 26, 2004 11:38 am    Post subject: Reply with quote

i can get this to work as root when i don't have an existing xserver running by running the startxdfb script. i typically run xdm, and can't figure out how to start this as a separate wm (:1). any ideas what i need to do?

i can run XDirectFB :1 -enableRoot as a user and get a separate window to come up, but it doesn't source my .xinitrc which looks like:

Code:

#!/bin/sh

# merge in defaults and keymaps

USERRESOURCES=$HOME/.Xresources
USERMODMAP=$HOME/.Xmodmap

if [ -f $USERRESOURCES ]; then
    xrdb -merge $USERRESOURCES
fi
if [ -f $USERMODMAP ]; then
    xmodmap $USERMODMAP
fi

# console window
exec fluxbox
xterm +sb -fg white -bg black -C -geometry 45x6-200+8 -fn 6x13 -name console &
mozilla &


.xinitrc for me is actually a symlink to .xsession, but that's the contents.any suggestions how to get this to work along side xdm would be nice. i get the blue screen with the drop shaped mouse pointer, and wait and wait, but it doesn't run anything in .xinitrc. help?
Back to top
View user's profile Send private message
Dillinger
Apprentice
Apprentice


Joined: 27 Jul 2003
Posts: 226
Location: Huntington Beach, Ca

PostPosted: Tue Feb 03, 2004 3:00 am    Post subject: Reply with quote

I'm having source compile errors when trying to emerge the latest ebuild. I checked out the bug reports and supposedly its fixed, is anyone else having problems?
_________________
registered Linux user #338885
www.easylinuxguide.com
www.linuxforums.org
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Fri Feb 27, 2004 12:42 pm    Post subject: Reply with quote

lurid wrote:
fimblo wrote:
Code:
waoh xdirectfb# ACCEPT_HEYWORDS="~x86" emerge xdirectfb-1.0_rc4.ebuild
[snip]


Try it again, and this time spell KEYWORDS correctly. ;)

I just did this - by cutting and pasting from the original article in the thread.

gsfgf - if you get a spare minute you might want to do a quick edit :)
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1317
Location: UK

PostPosted: Mon Mar 01, 2004 9:25 pm    Post subject: Reply with quote

heres one nobodys asked :-)

i'm installing it on my laptop (low spec, need a less heavy x server, figured i'd try xdirectfb) and i would like to use xfce4 with it :- ) however now i want not to install XFree86.

whats the chances i HAVE to have it installed for xfce4 to install?
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1317
Location: UK

PostPosted: Mon Mar 01, 2004 9:52 pm    Post subject: Reply with quote

ok xdirectfb does not work on it's own, startxdirectfb (for one is not in the default run path) and gives xauth command not found and xinit command not found.

running "XDirectFB -enableRoot" gives libXext.so.6 no such file or directory :-(
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Mon Mar 01, 2004 10:29 pm    Post subject: Reply with quote

mmm... I concur. I took xfree off my old laptop and put xdirectfb on, hoping to save some resources. I'm trying to run afterstep and/or ratpoison here, so it's not an xfce4 issue.

I got the impression that Damn Small Linux runs using xdirectfb in place of xfree, but then the docs that come with xdirectfb propose installing by patching xfree

and if the xdirectfb code depended upon xfree, shouldn't that show up in the dependancies?

I'm getting confused here
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1317
Location: UK

PostPosted: Mon Mar 01, 2004 10:33 pm    Post subject: Reply with quote

or the part of xfree86 needed should be a dependancy...

i'm installing it now (xfree86) and xfce4, i will just not use xfree, it's out of date now anyway with xserver probably taking over due to the new licence
Back to top
View user's profile Send private message
psofa
Guru
Guru


Joined: 28 Feb 2004
Posts: 485

PostPosted: Fri Mar 12, 2004 1:21 pm    Post subject: Reply with quote

does someone know how to solve the double mouse bug?
_________________
psofa
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1317
Location: UK

PostPosted: Fri Mar 12, 2004 3:23 pm    Post subject: Reply with quote

nope, i switched back to sloe bulky Xfree86
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Fri Mar 12, 2004 4:29 pm    Post subject: Reply with quote

I found this which doesn't help that much since the original poster has yet to reply, but the idea that the system might be seeing two mice instead of just the one is interesting.

I'm limited in how far I can pursue this at the moment since I too uninstalled it from one machine, and the other isn't ytet ready for it. All the same I wonder... could it be that gpm and xfree are both reporting the clicks to the application at once?

Edit:
Also found this which looks promising.

Hope that helps
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
psofa
Guru
Guru


Joined: 28 Feb 2004
Posts: 485

PostPosted: Sat Mar 13, 2004 1:37 am    Post subject: Reply with quote

the problem about it is that although i have got it to recognise only one mouse i still get
CAUGHT SIGNAL 11 even after making the change to dfb's code
_________________
psofa
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Sat Mar 13, 2004 2:19 am    Post subject: Reply with quote

Signal 11 - that's a segmentation violation. Any dependant libraries need recompiling? That'd be my first guess
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
psofa
Guru
Guru


Joined: 28 Feb 2004
Posts: 485

PostPosted: Sat Mar 13, 2004 11:11 am    Post subject: Reply with quote

it happens only when trying to use the input layer
_________________
psofa
Back to top
View user's profile Send private message
psofa
Guru
Guru


Joined: 28 Feb 2004
Posts: 485

PostPosted: Sat Mar 13, 2004 11:16 am    Post subject: Reply with quote

the other thing is that i cant find the log of directfb so i dont know whats wrong exaclty
:(
_________________
psofa
Back to top
View user's profile Send private message
psofa
Guru
Guru


Joined: 28 Feb 2004
Posts: 485

PostPosted: Sat Mar 13, 2004 11:44 am    Post subject: Reply with quote

ok after one day experimenting i fixed it see my new thread
HOWTO:Fix the directfb double mouse bug !
http://forums.gentoo.org/viewtopic.php?t=148454
_________________
psofa
Back to top
View user's profile Send private message
Sephiroth
n00b
n00b


Joined: 30 Jun 2003
Posts: 27
Location: California, USA

PostPosted: Fri Mar 19, 2004 8:22 pm    Post subject: Reply with quote

Ladies and gentleman, I am happy to inform you of...
8O OpenGL support for xdirectfb. 8O

I will be installing this over the weekend and give you a full report when it's done (Tuesday at the latest).

** EDIT **: Sorry, but it'll be a bit longer. I ran into some unforseen difficulties and won't be able to post my configuration for a while.
_________________
You can't beat free!


Last edited by Sephiroth on Wed Mar 24, 2004 2:14 am; edited 2 times in total
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Tue Mar 23, 2004 6:12 am    Post subject: Reply with quote

Sephiroth wrote:
Ladies and gentleman, I am happy to inform you of...
8O OpenGL support for xdirectfb. 8O

I will be installing this over the weekend and give you a full report when it's done (Tuesday at the latest).

Old news. It's been out for a while. I guess you are one of the luckys that have a Matrox card.

I gave a new shot at xdirectfb with the new rc emerged in. Same look & feel. Altough the system feels faster, it is also succeptible to CPU usage fluctuations. Finally, I will have to find a way to keep the virtual terminals to which I can't switch no more if xdirectfb is running.

I guess I will either have to wait for a SiS driver OR go buy myself a Matrox card. But would I love to see this in accelerated mode. Whoo whee must it fly.

Back to xfree version "almost" 4.4
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
Sephiroth
n00b
n00b


Joined: 30 Jun 2003
Posts: 27
Location: California, USA

PostPosted: Wed Mar 24, 2004 2:16 am    Post subject: Reply with quote

tecknojunky wrote:
Old news. It's been out for a while.


Sorry, didn't meen to give out the impression that it's new. I know it's been out for a while, it's just that most of the other posts said "XDirectFB has no OpenGL support" so I thought this would be as good a place as any to post the link.

Again, sorry if I gave off the wrong impression! :oops:
_________________
You can't beat free!
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Wed Mar 24, 2004 2:30 am    Post subject: Reply with quote

Sephiroth wrote:
tecknojunky wrote:
Old news. It's been out for a while.


Sorry, didn't meen to give out the impression that it's new. I know it's been out for a while, it's just that most of the other posts said "XDirectFB has no OpenGL support" so I thought this would be as good a place as any to post the link.

Again, sorry if I gave off the wrong impression! :oops:
No problem. It does offer GL support, but only for some Matrox cards only.
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
Sephiroth
n00b
n00b


Joined: 30 Jun 2003
Posts: 27
Location: California, USA

PostPosted: Wed Mar 24, 2004 8:49 pm    Post subject: Reply with quote

tecknojunky wrote:
No problem. It does offer GL support, but only for some Matrox cards only.

Just to clarify, Matrox cards are the only ones supported for hardware acceleration. Other card will work, but only with software acceleration.

Also, wish me luck, cause I'm going to try something difficult (well, difficult for me)! Since DirectFBGL uses Mesa for OpenGL and Mesa had an old project (Utah-GLX) that supported hardware acceleration for NVidia cards, I'm going to try and combine them for hardware accelerated OpenGL with DirectFB on my NVidia card.

If it works, great. If not, at least I tried!
_________________
You can't beat free!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 4 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum