Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wpa_supplicant] Failed to initialize EAPOL state machines ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
DieterVDW
n00b
n00b


Joined: 15 Nov 2004
Posts: 12
Location: Gent, Belgium

PostPosted: Tue May 24, 2005 2:13 am    Post subject: [wpa_supplicant] Failed to initialize EAPOL state machines ? Reply with quote

Hi,

I'm starting a new attempt to get WPA-PSK working in Gentoo.
When I'm starting wpa_supplicant, I get the following:

Code:
# wpa_supplicant -c /etc/wpa_supplicant.conf -i eth1 -D ipw
Failed to initialize EAPOL state machines.


???

My wireless card: Intel Corp. PRO/Wireless 2200BG (rev 05)
Versions:
- ipw2200: 1.0.4
- ipw2200-firmware: 2.3
- wpa-supplicant: 0.4.0
- iwtools: 28_pre6

/etc/wpa_supplicant:
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

opensc_engine_path=/usr/lib/opensc/engine_opensc.so
pkcs11_engine_path=/usr/lib/opensc/engine_pkcs11.so
pkcs11_module_path=/usr/lib/pkcs11/opensc-pkcs11.so

network={
        ssid="<ssid>"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP WEP104 WEP40
        psk="<key>"
        priority=2
}


I can't find anything about this!
Any idea's?

Edit: And now, without changing anything, I suddenly get:
Code:
# wpa_supplicant -w -c /etc/wpa_supplicant.conf -i eth1 -D ipw
ioctl[SIOCSIWPMKSA]: Operation not supported


*sigh*
Back to top
View user's profile Send private message
tsunam
Retired Dev
Retired Dev


Joined: 23 Feb 2004
Posts: 343

PostPosted: Tue May 24, 2005 4:03 am    Post subject: Reply with quote

I've had nothing but trouble with the 0.4.X tree of wpa_supplicant. I'm still using 0.3.8 because of it and it works fine.

You might want to try and apply this patch From Brix.

Also about the ioctl[SIOCSIWPMKSA]: Operation not supported, thatis a "non issue" according to wpa_supplicant developers and should not affect anything. I however suspect that its a deeper issue causing it but don't know the code's language to be able to psosible submit a fix.

Code:
diff -urp wpa_supplicant-0.4.1/driver_ipw.c wpa_supplicant-0.4.1-ipw/driver_ipw.c
--- wpa_supplicant-0.4.1/driver_ipw.c   2005-05-23 18:15:58.000000000 +0200
+++ wpa_supplicant-0.4.1-ipw/driver_ipw.c   2005-05-23 18:16:23.000000000 +0200
@@ -73,6 +73,7 @@ struct ipw_param {
       } wpa_param;
       struct {
          u32 len;
+         u8 reserved[32];
          u8 data[0];
       } wpa_ie;
            struct{

_________________
I'm not afraid of happy endings, just afraid my life wont work that way.
Back to top
View user's profile Send private message
DieterVDW
n00b
n00b


Joined: 15 Nov 2004
Posts: 12
Location: Gent, Belgium

PostPosted: Tue May 24, 2005 4:38 pm    Post subject: Reply with quote

tsunam wrote:
I've had nothing but trouble with the 0.4.X tree of wpa_supplicant. I'm still using 0.3.8 because of it and it works fine.


I just downgraded to 0.3.8 now, and indeed: it works a whole lot better now!
Back to top
View user's profile Send private message
fcgreg
Apprentice
Apprentice


Joined: 17 May 2003
Posts: 264
Location: California, USA

PostPosted: Thu May 26, 2005 7:09 am    Post subject: Try removing the OpenSSL config lines Reply with quote

I was able to resolve this problem on my 0.4.1 install by removing the OpenSSL module lines from the configuration file (assuming you have them and OpenSSL support enabled in the build). This didn't get everything working perfectly for me, but it did resolve the issue you're having.

HTH
_________________
Greg T.
Back to top
View user's profile Send private message
paulbiz
Guru
Guru


Joined: 01 Feb 2004
Posts: 506
Location: St. Louis, Missouri, USA

PostPosted: Wed Jun 29, 2005 1:56 am    Post subject: Re: Try removing the OpenSSL config lines Reply with quote

fcgreg wrote:
I was able to resolve this problem on my 0.4.1 install by removing the OpenSSL module lines from the configuration file (assuming you have them and OpenSSL support enabled in the build). This didn't get everything working perfectly for me, but it did resolve the issue you're having.

HTH


Thanks!! I was having the same EAPOL error. Commenting out the OpenSSL lines did indeed cure the problem, I'm on wireless using wpa_supplicant 0.4.3 to write this post :)
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Mon Oct 17, 2005 4:01 pm    Post subject: Reply with quote

i had the same probleme but commenting these lines works fine for me too
thx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum