Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200505-12 ] PostgreSQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Sun May 15, 2005 10:58 am    Post subject: [ GLSA 200505-12 ] PostgreSQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 200505-12)
Severity: normal
Exploitable: remote
Date: May 15, 2005
Updated: June 26, 2007
Bug(s): #91231
ID: 200505-12

Synopsis


PostgreSQL is vulnerable to Denial of Service attacks and possibly allows
unprivileged users to gain administrator rights.


Background


PostgreSQL is a SQL compliant, open source object-relational database
management system.


Affected Packages

Package: dev-db/postgresql
Vulnerable: < 7.3.10
Vulnerable: < 7.4.7-r2
Vulnerable: < 8.0.2-r1
Unaffected: = 7.3*
Unaffected: = 7.4*
Unaffected: >= 8.0.1-r3 < 8.0.2
Unaffected: >= 8.0.2-r1
Architectures: All supported architectures


Description


PostgreSQL gives public EXECUTE access to a number of character
conversion routines, but doesn't validate the given arguments
(CAN-2005-1409). It has also been reported that the contrib/tsearch2
module of PostgreSQL misdeclares the return value of some functions as
"internal" (CAN-2005-1410).


Impact


An attacker could call the character conversion routines with specially
setup arguments to crash the backend process of PostgreSQL or to
potentially gain administrator rights. A malicious user could also call
the misdeclared functions of the contrib/tsearch2 module, resulting in
a Denial of Service or other, yet uninvestigated, impacts.


Workaround


There is no known workaround at this time.


Resolution


All PostgreSQL users should update to the latest available version and
follow the guide at http://www.postgresql.o
rg/about/news.315
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose dev-db/postgresql


References

CAN-2005-1409
CAN-2005-1410
PostgreSQL Announcement


Last edited by GLSA on Tue Jul 01, 2014 4:19 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum