Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xalan: target release 1.1 conflicts with source release 1.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hlevyn
Apprentice
Apprentice


Joined: 14 Jan 2005
Posts: 240
Location: Santa Clara, California

PostPosted: Fri May 13, 2005 8:49 pm    Post subject: xalan: target release 1.1 conflicts with source release 1.5 Reply with quote

I'm a bit stumped at the moment with the following error:
Code:
# emerge dev-java/ant
Calculating dependencies ...done!
>>> emerge (1 of 16) dev-java/xalan-2.6.0-r2 to /
>>> md5 files   ;-) xalan-2.5.2.ebuild
>>> md5 files   ;-) ChangeLog
>>> md5 files   ;-) metadata.xml
>>> md5 files   ;-) xalan-2.6.0.ebuild
>>> md5 files   ;-) xalan-2.6.0-r2.ebuild
>>> md5 files   ;-) files/digest-xalan-2.5.2
>>> md5 files   ;-) files/digest-xalan-2.6.0
>>> md5 files   ;-) files/digest-xalan-2.6.0-r2
>>> md5 src_uri ;-) xalan-j_2_6_0-src.tar.gz
>>> Unpacking source...
>>> Unpacking xalan-j_2_6_0-src.tar.gz to /var/tmp/portage/xalan-2.6.0-r2/work
tar: A lone zero block at 36857
Could not find package xerces-2
>>> Source unpacked.
Buildfile: build.xml

prepare:
     [echo] Project:Xalan-Java version:2_6_0 build.xml $Revision: 1.206 $
    [mkdir] Created dir: /var/tmp/portage/xalan-2.6.0-r2/work/xalan-j_2_6_0/build
    [mkdir] Created dir: /var/tmp/portage/xalan-2.6.0-r2/work/xalan-j_2_6_0/build/classes

xml.compile:
     [echo] Compiling DTM implementation and utilities
    [javac] Compiling 185 source files to /var/tmp/portage/xalan-2.6.0-r2/work/xalan-j_2_6_0/build/classes
    [javac] javac: target release 1.1 conflicts with default source release 1.5

BUILD FAILED
/var/tmp/portage/xalan-2.6.0-r2/work/xalan-j_2_6_0/build.xml:256: Compile failed; see the compiler error output for details.

Total time: 2 seconds

!!! ERROR: dev-java/xalan-2.6.0-r2 failed.
!!! Function src_compile, Line 48, Exitcode 1
!!! build failed
!!! If you need support, post the topmost build error, NOT this status message.
Code:
# emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3-20050110, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r8 i686)
=================================================================
System uname: 2.6.11-gentoo-r8 i686 AMD Athlon(TM) XP 2100+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5,dev-lang/python-2.4.1 [2.4.1 (#1, May 13 2005, 10:05:38)]
dev-lang/python:     2.3.5, 2.4.1
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.5, 1.5, 1.7.9-r1, 1.8.5-r3, 1.4_p6, 1.6.3
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O2 -pipe -mtune=i686"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -mtune=i686"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups curl dvd dvdr eds emboss encode esd fam flac foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imagemagick imlib ipv6 java jpeg kde ldap libg++ libwww mad mikmod motif mozilla mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png ppds python qt quicktime readline sdl slang spell sqlite ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode usb vorbis x86 xine xml xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS



I'm trying to emerge dev-java/ant in hopes that it will help solve an error I'm getting when trying to build OpenOffice-1.9.100. I don't expect an answer to this part, but if anyone has guess as to what's causing the following I'd really like to hear it. One thing I suspect might be the JDK I'm using (1.5 rather than 1.4). If this error is indicative of another problem though, please let me know. =)
Code:
BUILD FAILED
/var/tmp/portage/openoffice-1.9.100/work/src680-m100/beanshell/unxlngi6.pro/misc/build/BeanShell/build.xml:176: Compile failed; see the compiler error output for details.

Total time: 6 seconds
dmake:  Error code 1, while making 'ANTBUILD'
'---* tg_merge.mk *---'
dmake:  Error code 255, while making './unxlngi6.pro/misc/build/so_built_ooo_beanshell'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-1.9.100/work/src680-m100/beanshell

!!! ERROR: app-office/openoffice-1.9.100 failed.
!!! Function src_compile, Line 462, Exitcode 1
!!! Build failed!
!!! If you need support, post the topmost build error, NOT this status message.


Thanks!
_________________
Madness takes its toll. Please have exact change.
Back to top
View user's profile Send private message
hlevyn
Apprentice
Apprentice


Joined: 14 Jan 2005
Posts: 240
Location: Santa Clara, California

PostPosted: Sat May 14, 2005 10:50 pm    Post subject: Reply with quote

I finally managed to get xalan-2.6.0 installed instead of 2.6.0-r2. I switched back to sun-jdk-1.4.2.08, and then worked backwards rebuilding various packages with that JDK when a build complained due to version mismatch. Unfortunately, if I try to build 2.6.0-r2 I get an error when it's trying to build its XSLTC component. Since I can't find a package that originated from, I think I'll just leave it as is and mask 2.6.0-r2 for now.

Cheers!
_________________
Madness takes its toll. Please have exact change.
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1043
Location: Gentoo Forums

PostPosted: Wed Jun 01, 2005 5:44 pm    Post subject: Reply with quote

i had not yet been able to get ant going with java-1.5. even switching to a java-1.4 version didn't help without rebuilding all needed packages. if one has the same problem - switch your java compiler to a 1.4.X and
Code:
emerge --nodeps =dev-java/ant-core-1.6.2-r3 =dev-java/jakarta-regexp-1.3-r2 =dev-java/bsh-2.0_beta1-r1 =dev-java/libreadline-java-0.8.0-r1 =dev-java/jython-2.1-r5 =dev-java/jakarta-oro-2.0.8-r1  =dev-java/servletapi-2.3-r1 =dev-java/bsf-2.3.0-r2 =app-arch/unzip-5.50-r2 =dev-java/bcel-5.1-r1 =dev-java/javacup-0.10k =dev-java/xalan-2.6.0-r2 =dev-java/xml-commons-1.0_beta2 =dev-java/xml-commons-resolver-1.1 =dev-java/xjavac-20041208 =dev-java/xerces-2.6.2-r2 =dev-java/junit-3.8.1-r1 =dev-java/log4j-1.2.9 =dev-java/avalon-logkit-bin-1.2.2 =dev-java/commons-logging-1.0.4 =dev-java/commons-collections-3.1 =dev-java/commons-beanutils-1.6.1-r2 =dev-java/commons-net-1.2.2-r1 =dev-java/jdepend-2.8.1 =dev-java/jzlib-1.0.5 =dev-java/gnu-crypto-2.0.1 =dev-java/jsch-0.1.18 =dev-java/antlr-2.7.3 =dev-java/rhino-1.5.5-r1 =dev-java/ant-tasks-1.6.2-r9 =dev-java/ant-1.6.2-r6

the version specified are the current version of the needed packages as of 01.06.2005.

EDIT: the reason ant isn't working yet with java-1.5 is xalan. all yet available version in portage don't support 1.5 target support (up to xalan-2.6.0-r2.ebuild at least).
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
kustos
Apprentice
Apprentice


Joined: 10 Sep 2003
Posts: 168

PostPosted: Wed Jun 01, 2005 8:27 pm    Post subject: Reply with quote

BlinkEye wrote:

EDIT: the reason ant isn't working yet with java-1.5 is xalan. all yet available version in portage don't support 1.5 target support (up to xalan-2.6.0-r2.ebuild at least).

The problem is portage. For some reasons the build.xml sets only -target and not -souce. So javac is free to assume anything. With Java 1.5 is assumes 1.5. But -target 1.1 doesn't work with -source 1.5.

The solution is simple:
Set -source to a compatible value if you set -target FFS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum